Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: K3b can't find cdrecord

  1. #1
    Join Date
    Jul 2008
    Location
    San Diego, CA
    Posts
    193

    Default K3b can't find cdrecord

    Whenever I open K3b I'm presented with this:



    I checked and cdrtools and cdrecord are installed.

    Code:
    > zypper se cdrtools
    Loading repository data...
    Reading installed packages...
    
    S | Name                   | Summary                                                | Type   
    --+------------------------+--------------------------------------------------------+--------
    i | cdrkit-cdrtools-compat | Tool for Writing CDRs - cdrtools Compatibility Package | package
    
    > which cdrecord
    cdrecord is /usr/bin/cdrecord
    cdrecord is /usr/bin/X11/cdrecord
    Has anyone seen this before? Can I just ignore it?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,369

    Default Re: K3b can't find cdrecord

    Which version of openSUSE?
    Henk van Velden

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,151

    Default Re: K3b can't find cdrecord

    /usr/bin/cdrecord is a symbolic link to /usr/bin/wodim
    Make sure that the wodim package is installed.

    Code:
    :~ # l /usr/bin/cdrecord
    lrwxrwxrwx 1 root root 5 Feb  8 21:02 /usr/bin/cdrecord -> wodim*
    
    :~ # l /usr/bin/X11
    lrwxrwxrwx 1 root root 1 Feb  8 19:46 /usr/bin/X11 -> ./
    
    :~ # zypper in -f wodim
    Loading repository data...
    Reading installed packages...
    Forcing installation of 'wodim-1.1.11-10.1.1.x86_64' from repository '12.3-repo-oss'.
    Resolving package dependencies...
    
    The following package is going to be reinstalled:
      wodim 
    
    1 package to reinstall.
    Overall download size: 379.9 KiB. No additional space will be used or freed after the operation.
    Continue? [y/n/?] (y): 
    Retrieving package wodim-1.1.11-10.1.1.x86_64                                                  (1/1), 379.9 KiB (  1.2 MiB unpacked)
    Retrieving: wodim-1.1.11-10.1.1.x86_64.rpm ...................................................................................[done]
    (1/1) Installing: wodim-1.1.11-10.1.1 ........................................................................................[done]
    
    :~ #
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  4. #4
    Join Date
    Jul 2008
    Location
    San Diego, CA
    Posts
    193

    Default Re: K3b can't find cdrecord

    Quote Originally Posted by hcvv View Post
    Which version of openSUSE?
    Sorry. It's 12.3 (KDE 4.10)

    Make sure that the wodim package is installed.
    It is.

    Code:
    > zypper se wodim
    Loading repository data...
    Reading installed packages...
    
    S | Name  | Summary               | Type   
    --+-------+-----------------------+--------
    i | wodim | Tool for Writing CDRs | package

  5. #5
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,151

    Default Re: K3b can't find cdrecord

    Quote Originally Posted by ccin1492 View Post
    Sorry. It's 12.3 (KDE 4.10)



    It is.

    Code:
    > zypper se wodim
    Loading repository data...
    Reading installed packages...
    
    S | Name  | Summary               | Type   
    --+-------+-----------------------+--------
    i | wodim | Tool for Writing CDRs | package
    Sorry, but that just shows that the package had been installed and has not been uninstalled with rpm or YaST, etc. K3B complained that it could not find a file, so you should look to see if the file is there and/or reinstall it. The code I provided checks whether the binary (/usr/bin/wodim) and the required symbolic links are in place.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: K3b can't find cdrecord

    On 2013-03-21 21:26, eng-int wrote:
    > Sorry, but that just shows that the package had been installed and has
    > not been uninstalled with rpm or YaST, etc. K3B complained that it
    > could not find a file, so you should look to see if the file is there
    > and/or reinstall it. The code I provided checks whether the binary
    > (-/usr/bin/wodim-) and the required symbolic links are in place.


    If you start k3b, go to settings, then configure k3b. On that dialog,
    click on "programs" on the left hand panel. Once there, click on the
    "search" button. It should find the applications you have installed.
    Then "OK" to exit.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Jul 2008
    Location
    San Diego, CA
    Posts
    193

    Default Re: K3b can't find cdrecord

    Quote Originally Posted by robin_listas View Post

    If you start k3b, go to settings, then configure k3b. On that dialog,
    click on "programs" on the left hand panel. Once there, click on the
    "search" button. It should find the applications you have installed.
    Then "OK" to exit.
    Ah, that was it. Thank you.

    Why isn't this automatic? Just asking.

  8. #8
    Join Date
    Oct 2008
    Location
    Central Texas, in the sticks
    Posts
    148

    Default Re: K3b can't find cdrecord

    I have the same problem, when I search for cdrecord, it is missing from my machine and seems to be missing from the repositories. I deleted all of K3B and installed Brasero thinking it would work, but it needs the same file package. Any thoughts.????

  9. #9

    Default AW: Re: K3b can't find cdrecord

    Quote Originally Posted by cherock1254 View Post
    I have the same problem, when I search for cdrecord, it is missing from my machine and seems to be missing from the repositories. I deleted all of K3B and installed Brasero thinking it would work, but it needs the same file package. Any thoughts.????
    Install the package "cdrkit-cdrtools-compat".This contains compatibility symlinks for cdrecord and some other burning tools to the cdrkit equivalents (wodim and so on).

    But AFAICS k3b does require /usr/bin/cdrecord, so the necessary packages should be installed automatically...
    And the same is true for brasero.

    How did you install them?
    Try to reinstall the "cdrkit-cdrtools-compat" package, maybe those symlinks got deleted somehow:
    Code:
    sudo zypper in -f cdrkit-cdrtools-compat

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: K3b can't find cdrecord

    On 2013-12-28 23:06, cherock1254 wrote:
    >
    > I have the same problem, when I search for cdrecord, it is missing from
    > my machine and seems to be missing from the repositories. I deleted all
    > of K3B and installed Brasero thinking it would work, but it needs the
    > same file package. Any thoughts.????



    Code:
    Elessar:~ # which cdrecord
    /usr/bin/cdrecord
    Elessar:~ # rpm -qf /usr/bin/cdrecord
    cdrkit-cdrtools-compat-1.1.11-16.1.3.x86_64
    Elessar:~ # l /usr/bin/cdrecord
    lrwxrwxrwx 1 root root 5 Nov  6 20:52 /usr/bin/cdrecord -> wodim*
    Elessar:~ # l /usr/bin/wodim
    -rwxr-xr-x 1 root root 410344 Sep 28 04:44 /usr/bin/wodim*
    Elessar:~ # rpm -qf /usr/bin/wodim
    wodim-1.1.11-16.1.3.x86_64
    Elessar:~ #
    There is also the original version (cdrtools) from Joerg Schilling, at the repo "multimedia:apps"
    (see wikipedia for explanation).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" (Elessar))

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •