Results 1 to 10 of 10

Thread: mount netwerkschijf binnen een domein aan /home

  1. #1

    Default mount netwerkschijf binnen een domein aan /home

    Hallo forums,

    Na het doorspitten van het forum en Google breng ik mijn vraag toch bij jullie. Wat ik wil bereiken is dat de samba share //192.168.62.30/Staff$ word gemount op /home/LINCOLNCOLLEGE. Vervolgens zou ik willen inloggen met een account van het domein (LINCOLNCOLLEGE) en deze share benaderen

    Wat ik heb gedaan is op de client (openSUSE 12.2) fstab aangepast en de volgende regel toegevoegd:
    Code:
    //192.168.62.30/Staff$ /home/LINCOLNCOLLEGE cifs iocharset=iso8859-15,uid=100,gid=100,rw,noserverino,noperm,file_mode=0777,dir_mode=0777,username=****,password=**** 0 0
    wanneer ik inlog met een domein account en blader naar deze share wordt ik begroet me de volgende melding:
    An error occurred while accessing 'Staff$' on //192.168.62.30', the system responded: mount: only root can mount //192.168.62.30/Staff$ on /home/LINCOLNCOLLEGE
    Nu is het vreemde dat wanneer ik inlog met een andere lokale gebruiker (niet root) ik deze melding niet krijg en de share succesvol is gemount.

    output linux-f3xv:/home # ls -l
    Code:
    drwxr-xr-x   25       administrator       users                                         4096 Mar 21 13:09 administrator
    drwxrwxrwx 3         root                   LINCOLNCOLLEGE\domain users       4096 Mar 20 11:25 LINCOLNCOLLEGE (text is highligted in groen)
    drwxr-xr-x   9                           999 users                                         4096 Aug 29 2012 linux~
    drwx------  2         root                  root                                          16384 Mar 10:35 lost+found
    Waar ga ik de fout in?

  2. #2

    Default Re: mount netwerkschijf binnen een domein aan /home

    EDIT: correctie, het andere lokale account wil de share ook niet mounten.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: mount netwerkschijf binnen een domein aan /home

    Hoe heb je dit opgezet Kevin? Met instructies, zo ja, linkje? Via Yast? Probeer aan te geven welke stappen je ondernomen hebt.
    Graag output van
    Code:
    mount
    met de fstab regel erbij in.

    En wat moet er precies kunnen, ik krijg daar niet een goed beeld van.

    Als je in fstab de boel al aankoppelt, moet een gebruiker dat niet opnieuw doen. Je moet dan de inhoud van de share al "zien" in /home/LINCOLNCOLLEGE
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: mount netwerkschijf binnen een domein aan /home

    We hebben een bestaand netwerk met een Microsoft Server 2008 waar een domein op draait (LINCOLNCOLLEGE.AC.UK). Hier staat een AD in vol met user accounts. Daarnaast hebben we een server (192.168.62.30) waar alle documenten van de gebruikers in worden opgeslagen (denk aan een roaming profile idee). Deze folders staan in het mapje /Staff$

    Wat ik heb gedaan is een installatie van openSUSE 12.2, die toegevoegd aan het domein via "Windows Domain Membership" en de proxy instellingen ingevuld. Toen lokaal ingelogd als root en fstab aangevuld met voorheen gegeven regel daarna herstart en ingelogd met een domain user (Kstoffers). Vervolgens met dolphin naar /home/LINCOLNCOLELGE gegaan maar daar staat alleen een lokaal aangemaakt mapje, wel staat in de navigatie: Staff$ on //192.168.62.30. wanneer ik daar heen wil navigeren word ik dus begroet met die foutmelding.

    uitvoer mount & fstab:

    Code:
    LINCOLNCOLLEGE\kstoffers@linux-f3xv:~> mount | more /etc/fstab
    devtmpfs on /dev type devtmpfs (rw,relatime,size=500872k,nr_inodes=125218,mode=755)
    tmpfs on /dev/shm type tmpfs (rw,relatime)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
    /dev/sda1 on / type ext4 (rw,relatime,data=ordered)
    proc on /proc type proc (rw,relatime)
    sysfs on /sys type sysfs (rw,relatime)
    tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)                                                                                                            
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)                                                                                                          
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)                                                                                                          
    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)                                                                                                          
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)                                                                                                              
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)                                                                                                    
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)                                                                           
    tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
    tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    tmpfs on /media type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    securityfs on /sys/kernel/security type securityfs (rw,relatime)
    /dev/sda2 on /home type ext4 (rw,relatime,data=ordered)
    none on /proc/fs/vmblock/mountPoint type vmblock (rw,relatime)
    ::::::::::::::
    /etc/fstab
    ::::::::::::::
    /dev/disk/by-id/ata-HDS728080PLA380_PFDBU0EJUAVRYX-part3        swap    swap    defaults 0 0 
    /dev/disk/by-id/ata-HDS728080PLA380_PFDBU0EJUAVRYX-part1        /       ext4    acl,user_xattr 1 1 
    /dev/disk/by-id/ata-HDS728080PLA380_PFDBU0EJUAVRYX-part2        /home   ext4    acl,user_xattr 1 2 
    //192.168.62.30/Staff$ /home/LINCOLNCOLLEGE cifs username=Kstoffers,password=****,rw,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0
    sysfs   /sys    sysfs   noauto 0 0 
    debugfs /sys/kernel/debug       debugfs noauto 0 0 
    devpts  /dev/pts        devpts  mode=0620,gid=5 0 0
    Wat ik wil bereiken is dat domein gebruikers naar deze map kunnen browsen, maar momenteel krijg ik als domein gebruiker de melding dat de samba share alleen kan worden gemount door root

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: mount netwerkschijf binnen een domein aan /home

    Zoals je ziet in de output van "mount' is de share niet aangekoppeld. Wat er misgaat, kun je controleren met
    Code:
    su -
    mount -a
    tail -20 /var/log/messages
    dmesg | tail
    Ik mis nog wat: Hoe ben je gekomen waar je bent?
    Heb je al eens gekeken naar Yast - Network services - Windows Domain Membership, en dan vooral naar de Advanced Options? Let wel, ik heb geen windozen, dus ook geen Samba.

    Ik zou ook eerst eens proberen hoe ik met handmatig mounten kwam:
    Code:
    mount //192...../Staff\$ -t cifs /mnt
    cd /mnt
    ls
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: mount netwerkschijf binnen een domein aan /home

    Hey Gertjan. Ik heb de fstab even aangepast naar /mnt inplaats van /home/LINCOLNCOLLEGE. Dit omdat gisteren mijn hele /home niet meer werd gemount!. Dezelfde uitdagingen blijven bestaan.

    Code:
    LINCOLNCOLLEGE\kstoffers@linux-f3xv:~> su -
    Password: 
    linux-f3xv:~ # mount -a
    linux-f3xv:~ # tail -20 /var/log/messages
    Mar 22 10:41:51 linux-f3xv dbus[695]: [system] Activating via systemd: service name='org.freedesktop.NetworkManager' unit='dbus-org.freedesktop.NetworkManager.service'
    Mar 22 10:41:51 linux-f3xv dbus[695]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.NetworkManager.service': Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
    Mar 22 10:41:56 linux-f3xv dbus-daemon[695]: dbus[695]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service'
    Mar 22 10:41:56 linux-f3xv dbus[695]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service'
    Mar 22 10:41:57 linux-f3xv dbus-daemon[695]: dbus[695]: [system] Successfully activated service 'org.freedesktop.RealtimeKit1'
    Mar 22 10:41:57 linux-f3xv dbus[695]: [system] Successfully activated service 'org.freedesktop.RealtimeKit1'
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Successfully called chroot.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Successfully dropped privileges.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Successfully limited resources.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Running.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Canary thread running.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Watchdog thread running.
    Mar 22 10:42:02 linux-f3xv pulseaudio[2635]: [pulseaudio] pid.c: Stale PID file, overwriting.
    Mar 22 10:42:12 linux-f3xv pulseaudio[2729]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:17 linux-f3xv pulseaudio[2743]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:21 linux-f3xv pulseaudio[2746]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:25 linux-f3xv pulseaudio[2750]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:31 linux-f3xv polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.40 [/usr/lib/kde4/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
    Mar 22 10:42:51 linux-f3xv su: (to root) LINCOLNCOLLEGE\kstoffers on /dev/pts/1
    Mar 22 10:42:55 linux-f3xv dbus-daemon[695]: **** /proc/self/mountinfo changed
    linux-f3xv:~ # dmesg | tail
    [   26.693916] FS-Cache: Netfs 'nfs' registered for caching
    [   26.810073] CIFS VFS: Error connecting to socket. Aborting operation
    [   26.810188] CIFS VFS: cifs_mount failed w/return code = -101
    [   27.349069] vboxguest: VirtualBox Guest PCI device not found.
    [   28.532052] NET: Registered protocol family 17
    [  113.213639] CIFS VFS: default security mechanism requested.  The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.3
    [  113.252480] CIFS VFS: cifs_mount failed w/return code = -6
    [  113.265247] CIFS VFS: cifs_mount failed w/return code = -6
    [  120.812417] EXT4-fs (sda1): re-mounted. Opts: acl,user_xattr,commit=0
    [  120.922127] EXT4-fs (sda2): re-mounted. Opts: acl,user_xattr,commit=0
    Wat ik vertelde is alles wat ik heb gedaan. De college heeft al een bestaande omgeving. Daar heb ik een pc aangehangen er openSUSE 12.2 op geinstalleerd. Proxy ingesteld, toegevoegd aan het domein. en de fstab aangevuld. Zo ben ik gekomen waar ik ben, Er zijn geen andere stappen geweest. Ik heb inderdaad ook al even gekeken naar de advanced options en het americaanse onderdeel van het forum doorgespit waar ik trouwens posts van jouw tegen kwam. Daar was een persoon met dezelfde situatie als mij en die heeft uiteindelijk wel gebruik gemaakt van de advanced opties om de gebruikers profiles te mappen, maar dezelfde methode deed bij mij helaas niets.

    Het handmatig mounten werkt wel goed, misschien een wilde gok maar als ik een scriptje maak met de mount regel en die in /etc/rc.d zet, word die dan automatisch als root gedraaid bij boot?

  7. #7

    Default Re: mount netwerkschijf binnen een domein aan /home

    interessante bug gevonden trouwens, wanneer ik naar Yast > Network Services > Windows Domain Membership > Expert settings ga en daar een Mount Server Directory add dan word de locatie die ik bij Local Mount Point invul na herstarten niet meer geladen. Heb het zoals eerder vermeld met /home gehad en nu met /mnt. Maar dit terzijde, is namelijk een andere pc die verder niets met degene te maken heeft waar mijn eerdere vragen over gaan.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: mount netwerkschijf binnen een domein aan /home

    Quote Originally Posted by Ginkevin View Post
    Hey Gertjan. Ik heb de fstab even aangepast naar /mnt inplaats van /home/LINCOLNCOLLEGE. Dit omdat gisteren mijn hele /home niet meer werd gemount!. Dezelfde uitdagingen blijven bestaan.

    Code:
    LINCOLNCOLLEGE\kstoffers@linux-f3xv:~> su -
    Password: 
    linux-f3xv:~ # mount -a
    linux-f3xv:~ # tail -20 /var/log/messages
    Mar 22 10:41:51 linux-f3xv dbus[695]: [system] Activating via systemd: service name='org.freedesktop.NetworkManager' unit='dbus-org.freedesktop.NetworkManager.service'
    Mar 22 10:41:51 linux-f3xv dbus[695]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.NetworkManager.service': Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
    Mar 22 10:41:56 linux-f3xv dbus-daemon[695]: dbus[695]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service'
    Mar 22 10:41:56 linux-f3xv dbus[695]: [system] Activating via systemd: service name='org.freedesktop.RealtimeKit1' unit='rtkit-daemon.service'
    Mar 22 10:41:57 linux-f3xv dbus-daemon[695]: dbus[695]: [system] Successfully activated service 'org.freedesktop.RealtimeKit1'
    Mar 22 10:41:57 linux-f3xv dbus[695]: [system] Successfully activated service 'org.freedesktop.RealtimeKit1'
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Successfully called chroot.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Successfully dropped privileges.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Successfully limited resources.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Running.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Canary thread running.
    Mar 22 10:41:57 linux-f3xv rtkit-daemon[2636]: Watchdog thread running.
    Mar 22 10:42:02 linux-f3xv pulseaudio[2635]: [pulseaudio] pid.c: Stale PID file, overwriting.
    Mar 22 10:42:12 linux-f3xv pulseaudio[2729]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:17 linux-f3xv pulseaudio[2743]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:21 linux-f3xv pulseaudio[2746]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:25 linux-f3xv pulseaudio[2750]: [pulseaudio] pid.c: Daemon already running.
    Mar 22 10:42:31 linux-f3xv polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.40 [/usr/lib/kde4/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_GB.UTF-8)
    Mar 22 10:42:51 linux-f3xv su: (to root) LINCOLNCOLLEGE\kstoffers on /dev/pts/1
    Mar 22 10:42:55 linux-f3xv dbus-daemon[695]: **** /proc/self/mountinfo changed
    linux-f3xv:~ # dmesg | tail
    [   26.693916] FS-Cache: Netfs 'nfs' registered for caching
    [   26.810073] CIFS VFS: Error connecting to socket. Aborting operation
    [   26.810188] CIFS VFS: cifs_mount failed w/return code = -101
    [   27.349069] vboxguest: VirtualBox Guest PCI device not found.
    [   28.532052] NET: Registered protocol family 17
    [  113.213639] CIFS VFS: default security mechanism requested.  The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.3
    [  113.252480] CIFS VFS: cifs_mount failed w/return code = -6
    [  113.265247] CIFS VFS: cifs_mount failed w/return code = -6
    [  120.812417] EXT4-fs (sda1): re-mounted. Opts: acl,user_xattr,commit=0
    [  120.922127] EXT4-fs (sda2): re-mounted. Opts: acl,user_xattr,commit=0
    Wat ik vertelde is alles wat ik heb gedaan. De college heeft al een bestaande omgeving. Daar heb ik een pc aangehangen er openSUSE 12.2 op geinstalleerd. Proxy ingesteld, toegevoegd aan het domein. en de fstab aangevuld. Zo ben ik gekomen waar ik ben, Er zijn geen andere stappen geweest. Ik heb inderdaad ook al even gekeken naar de advanced options en het americaanse onderdeel van het forum doorgespit waar ik trouwens posts van jouw tegen kwam. Daar was een persoon met dezelfde situatie als mij en die heeft uiteindelijk wel gebruik gemaakt van de advanced opties om de gebruikers profiles te mappen, maar dezelfde methode deed bij mij helaas niets.

    Het handmatig mounten werkt wel goed, misschien een wilde gok maar als ik een scriptje maak met de mount regel en die in /etc/rc.d zet, word die dan automatisch als root gedraaid bij boot?
    Als je de share handmatig mount, dan werkt het. Hoe ziet het mount commando er dan uit?
    Wat gebeurt er als je na het booten domweg zegt dat de mounts in fstab allemaal moeten worden uitgevoerd?
    Code:
    su -
    mount -a
    mount
    Ik zit nl. opeens te denken dat 't ook kan zijn dat alles wel OK is, maar dat het aankoppelen van de share gedaan wordt voordat het netwerk start ........ Je zou eens kunnen kijken naar de instellingen van de netwerkkaart, de activatie moet niet op "Cable connection" staan, maar op "At boot". Met NFS kun je daar last van hebben, ik wil 't hier in ieder geval uitsluiten.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: mount netwerkschijf binnen een domein aan /home

    Code:
    LINCOLNCOLLEGE\kstoffers@linux-f3xv:/mnt> mount
    devtmpfs on /dev type devtmpfs (rw,relatime,size=500872k,nr_inodes=125218,mode=755)
    tmpfs on /dev/shm type tmpfs (rw,relatime)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
    /dev/sda1 on / type ext4 (rw,relatime,data=ordered)
    proc on /proc type proc (rw,relatime)
    sysfs on /sys type sysfs (rw,relatime)
    tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
    tmpfs on /media type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
    tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    securityfs on /sys/kernel/security type securityfs (rw,relatime)
    /dev/sda2 on /home type ext4 (rw,relatime,data=ordered)
    none on /proc/fs/vmblock/mountPoint type vmblock (rw,relatime)
    //192.168.62.30/Staff$ on /mnt type cifs (rw,relatime,sec=ntlm,unc=\\192.168.62.30\Staff$,username=Kstoffers,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.62.30,file_mode=0777,dir_mode=0777,nounix,noperm,rsize=61440,wsize=65536,actimeo=1)
    Na het opstarten de mounts in fstab uitvoeren schiet ik niets mee op aangezien het erom gaat dat deze share gemount moet worden zonder tussenkomst van een root wachtwoord. Leerlingen moeten kunnen inloggen en de share zien. De netwerk-kaart stond inderdaad geconfigureerd als 'ifplugged' en is verandert naar 'onboot'. Of dit een verschil zal maken weet ik niet aangezien met het inloggen als Root de share wel automatisch door fstab word gemount, zal het niet eerder een rechten probleem zijn?

    ik zal je zo nog even de uitkomst geven van

    Code:
    su -
    mount -a
    mount

  10. #10

    Default Re: mount netwerkschijf binnen een domein aan /home

    gloeiende.. gertjan jij genie! het veranderen van de netwerkaart instellingen heeft gewerkt. Bij het inloggen werd de share automatisch gemount.

    Code:
    LINCOLNCOLLEGE\kstoffers@linux-f3xv:~> mount
    devtmpfs on /dev type devtmpfs (rw,relatime,size=500872k,nr_inodes=125218,mode=755)
    tmpfs on /dev/shm type tmpfs (rw,relatime)
    tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
    /dev/sda1 on / type ext4 (rw,relatime,data=ordered)
    proc on /proc type proc (rw,relatime)
    sysfs on /sys type sysfs (rw,relatime)
    tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
    cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
    cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
    cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
    cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
    cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
    cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
    cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
    cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
    cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
    systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
    hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
    tmpfs on /media type tmpfs (rw,nosuid,nodev,noexec,relatime,mode=755)
    debugfs on /sys/kernel/debug type debugfs (rw,relatime)
    mqueue on /dev/mqueue type mqueue (rw,relatime)
    securityfs on /sys/kernel/security type securityfs (rw,relatime)
    tmpfs on /var/lock type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    tmpfs on /var/run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
    /dev/sda2 on /home type ext4 (rw,relatime,data=ordered)
    //192.168.62.30/Staff$ on /mnt type cifs (rw,relatime,sec=ntlm,unc=\\192.168.62.30\Staff$,username=Kstoffers,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.62.30,file_mode=0777,dir_mode=0777,nounix,noperm,rsize=61440,wsize=65536,actimeo=1)
    none on /proc/fs/vmblock/mountPoint type vmblock (rw,relatime)
    Engeland is u dankbaar

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •