Results 1 to 4 of 4

Thread: Steam Bastion Black screen

  1. #1

    Default Steam Bastion Black screen

    Hi,

    After the 12.3 review on LinuxActionShow I decided to try opensuse for the first time. Pretty solid distro but I have only been using it for a day.

    I purchased bastion from the humble indie bundle yesterday and have installed it through steam. However after the initial vendor logos I get music and a blue cursor but a black screen. I've disabled full screen compositing in KDE and installed libtxc-dxtn libraries from software.opensuse which seems to fix peoples problems in Ubuntu but still no joy.

    The libtxc-dxtn packages were source though? software.opensuse.org:

    Anyone fixed this problem or know which packages I should install?

    Thanks,

    James

  2. #2

    Default Re: Steam Bastion Black screen

    Start steam from the command-line. (open a terminal)

    type:
    steam
    and then hit enter.

    You will see allot of messages. ( you can probably ignore them)

    Then start the game as you do usual.
    when you have the black screen, quit the game, and look the the command-line output from steam.

    There will be a line were you can see the game is started.
    Below that with a bit of luck you will see the game complaining about missing libs, or some other error messages.

  3. #3

    Default Re: Steam Bastion Black screen

    Do you have the latest graphics drivers set up?

    I wrote a post concerning setting up steam and the graphics drivers in OpenSUSE, note the bit at the end about adding your user to the "video" group. It covers how I got source engine games working but hopefully it could help you as well. (https://forums.opensuse.org/english/...ml#post2539327)

    I'll install Bastion over the weekend and see if I can replicate your error.

    PS. Are you running 64bit or 32bit?

  4. #4

    Default Re: Steam Bastion Black screen

    This doesn't seem to be a Steam issue, as I had the same problem with Bastion despite no involvement of Steam at all. For me, the solution was to switch from the open source ATI driver to the proprietary AMD Catalyst driver, (at the time of writing: version 13.4 stable, or 13.8 Beta).

    If you're going down this route: ensure the driver supports your video card; make sure you have the kernel-syms package installed and that the kernel-default-devel, kernel-desktop, kernel-desktop-devel, kernel-devel, kernel-source, kernel-xen-devel and kernel-firmware packages are up to date and all the same version number; uninstall or blacklist at boot your Xorg ATI driver and reboot to ensure you're running on the VESA video driver. Then follow your preferred installation method from the instructions at SDB:AMD fglrx - openSUSE to install the current stable video driver, or direct download the Beta driver from AMD Catalyst™ Proprietary Display Driver - Linux x86 & Linux x86_64 and install from your hard drive if that's more to your liking.

    After I completed this, I was able to get the correct video display in Bastion. It was, however, unusably laggy in the opening menu screens...I would move the mouse, and it would take about two seconds for the pointer on the screen to move. Turning off fullscreen and dropping the resolution down to the minimum (1280x720) made that only happen about half the time, quite randomly. The game itself is actually usable, and hasn't yet suffered any lag on the lowest video settings, but I've only played a few minutes of it to check that it works.

    Good luck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •