I don't personally have a problem with CrossOver Linux on my openSUSE 12.3 x86_64 machine but it does look like I have some issues with it. When I run the CrossOver diagnostic tool, I get this output:
Code:
> /opt/cxoffice/bin/cxdiag
[MissingLibGphoto2]
"Level"="Recommend"
"Title"="Missing 32bit libgphoto2.so.2 library"
"Description"="Lets Windows applications access digital cameras."

[MissingLibHal]
"Level"="Suggest"
"Title"="Missing 32bit libhal.so.1 library"
"Description"="This may be needed for Windows applications to automatically detect CD-ROM and USB key insertion."

[MissingLibTiff]
"Level"="Suggest"
"Title"="Missing 32bit libtiff.so.4 library"
"Description"="This is needed by some applications that need to manipulate TIFF images in their user interface."

[Properties]
"display.depth"="24"

[Properties]
"opengl.vendor"="NVIDIA Corporation"

[Properties]
"opengl.version"="3.3.0 NVIDIA 310.32"

[Properties]
"opengl.renderer"="Quadro NVS 135M/PCIe/SSE2"
What I don't understand is why I am getting the missing libgphoto2 and libtiff. A checked my /usr/libs folder:
Code:
/usr/lib> ls libtiff* libgphoto2*
libgphoto2_port.so.10  libgphoto2_port.so.10.0.0  libgphoto2.so.6  libgphoto2.so.6.0.0  libtiff.so.5  libtiff.so.5.2.0  libtiffxx.so.5  libtiffxx.so.5.2.0

libgphoto2:
2.5.0.2

libgphoto2_port:
0.10.0
Is CrossOver not able to redirect automatically to the from libtiff.so.4 to libtiff.so.5? Should I make a symbolic link?

What is the best practice for ensuring that this software runs as needed? I also see that CodeWeavers doesn't officially support openSUSE either. I read on a CrossOver forum thread this:
Unfortunately we no longer support Crossover 12.x on Opensuse 12.x because of all the missing libraries in the distro and other issues like you're seeing. We gave up after Crossover 11.3 because trying to keep Crossover installing and running correctly on OpenSuse was like playing whack-a-mole and as soon as we would fix for one missing library another would disappear, be moved, or renamed.
More on that here: Support - Forums - General Forums - Crossover in opensuse 12.3 - Discussion of Windows on Mac and Linux

For me, everything seems to work without any problems, so far as I can tell but the diagnostic output says otherwise.

Any help on this matter would be greatly appreciated.