Results 1 to 8 of 8

Thread: KDE clock continuing to show incorrect time

  1. #1

    Default KDE clock continuing to show incorrect time

    I have installed, on my laptop, 64 Bit SUSE 12.2, KDE, on the second sdb usb-connected hard disk, in a multi-boot set-up with Windows 7on the sda disk.

    The computer will now only boot with the SUSE DVD in the drive, then goes to GRUB2, within SUSE, and gives me a choice of SUSE or Windows. I have tried without the
    DVD and with the BIOS booting sequence changed to DVD, sdb, sda, no go. I can live with that, can always, when the system is up, take out the SUSE DVD and put in another which I don't need to do very often, as long as I put the SUSE DVD back be fore restarting or shutting down.


    Right now, I have, so far, one small problem, setting the time. Date is fine but something is wrong with the clock set-up. I set it up, marking the time zone - I am in Toronto, Eastern Standard Time. Then it shows the correct time but.........after logging off and coming back it shows exactly 4 hours early..........drifting somewhere in the middle of the Atlantic.

    Someone suggested the time problem might be due to my somewhat unorthodox booting set-up, although Windows continues to show the correct time. That's why I have explained the booting set-up which, in itself, presents no problem for me.

    Any ideas? I thank you for your comments,

    pe1800


  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE clock continuing to show incorrect time

    Quote Originally Posted by pe1800 View Post
    I have installed, on my laptop, 64 Bit SUSE 12.2, KDE, on the second sdb usb-connected hard disk, in a multi-boot set-up with Windows 7on the sda disk.

    The computer will now only boot with the SUSE DVD in the drive, then goes to GRUB2, within SUSE, and gives me a choice of SUSE or Windows. I have tried without the
    DVD and with the BIOS booting sequence changed to DVD, sdb, sda, no go. I can live with that, can always, when the system is up, take out the SUSE DVD and put in another which I don't need to do very often, as long as I put the SUSE DVD back be fore restarting or shutting down.


    Right now, I have, so far, one small problem, setting the time. Date is fine but something is wrong with the clock set-up. I set it up, marking the time zone - I am in Toronto, Eastern Standard Time. Then it shows the correct time but.........after logging off and coming back it shows exactly 4 hours early..........drifting somewhere in the middle of the Atlantic.

    Someone suggested the time problem might be due to my somewhat unorthodox booting set-up, although Windows continues to show the correct time. That's why I have explained the booting set-up which, in itself, presents no problem for me.

    Any ideas? I thank you for your comments,

    pe1800

    First, I suggest you read through my blog on the subject: https://forums.opensuse.org/blogs/jd...12-3-12-2-116/

    The general rule is if you dual boot with Windows, keep your CMOS clock using local time, not UTC. And both Windows and openSUSE will update the Real Time Clock in your CMOS each time you do a time update. So both OS' need to be doing the same thing, either using Local Time or UTC time. openSUSE can be set to either and while Windows defaults to local time, I have a registry change shown that can switch Windows to using UTC. In KDE, the clock can be set to display time in UTC even when the correct time zone has been set, so check your KDE task bar clock to see that it is also showing time in your local time zone and not UTC.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: KDE clock continuing to show incorrect time

    If your Clock is setted to Local time and wan`t synchronize your Local time then you can do this got to Yast > Date and Time click on change then synchronize with NTP server and synchronize now-butten and it should work if the clock is setted to Local time,it worked for me.

  4. #4

    Default Re: KDE clock continuing to show incorrect time

    Thank you, problem is fixed. Between you and the other responder I was able to resolve the issue.

    Quote Originally Posted by jdmcdaniel3 View Post
    First, I suggest you read through my blog on the subject: https://forums.opensuse.org/blogs/jd...12-3-12-2-116/

    The general rule is if you dual boot with Windows, keep your CMOS clock using local time, not UTC. And both Windows and openSUSE will update the Real Time Clock in your CMOS each time you do a time update. So both OS' need to be doing the same thing, either using Local Time or UTC time. openSUSE can be set to either and while Windows defaults to local time, I have a registry change shown that can switch Windows to using UTC. In KDE, the clock can be set to display time in UTC even when the correct time zone has been set, so check your KDE task bar clock to see that it is also showing time in your local time zone and not UTC.

    Thank You,

  5. #5

    Default Re: KDE clock continuing to show incorrect time

    Thank you, problem is fixed. Between you and the other responder I was able to resolve the issue.

    Quote Originally Posted by NatsuPower View Post
    If your Clock is setted to Local time and wan`t synchronize your Local time then you can do this got to Yast > Date and Time click on change then synchronize with NTP server and synchronize now-butten and it should work if the clock is setted to Local time,it worked for me.

  6. #6

    Default Re: KDE clock continuing to show incorrect time

    Quote Originally Posted by pe1800 View Post
    Thank you, problem is fixed. Between you and the other responder I was able to resolve the issue.
    No problem we are here to help each other

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE clock continuing to show incorrect time

    Quote Originally Posted by pe1800 View Post
    Thank you, problem is fixed. Between you and the other responder I was able to resolve the issue.
    I am happy to hear you have fixed the time display problem.

    Thank You for using openSUSE,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8

    Default Re: KDE clock continuing to show incorrect time

    I learned something new, from this topic, but my problem was the other way around.

    It was on windows 7, were I had to manual adjust the clock to get it in sync.

    So I looked for a windows support group, and they had me use the dos prompt.
    Which did work, but often after a reboot, it was 1 hour off again.

    With 12.3 my problem seems to be gone though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •