Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: openSUSE 12.3

  1. #1
    Join Date
    Nov 2008
    Location
    Bulgaria
    Posts
    26

    Default openSUSE 12.3

    Can not start ntop. After start ntop I have the following problem:

    Mon Mar 18 22:05:59 2013 NOTE: Interface merge enabled by default
    Mon Mar 18 22:05:59 2013 Initializing gdbm databases
    Mon Mar 18 22:05:59 2013 **ERROR** ....open of /var/ntop/prefsCache.db failed: File open error
    Mon Mar 18 22:05:59 2013 Possible solution: please use '-P <directory>'
    Mon Mar 18 22:05:59 2013 **FATAL_ERROR** GDBM open failed, ntop shutting down...
    Mon Mar 18 22:05:59 2013 CLEANUP[t140707982616768]: ntop caught signal 2 [state=2]
    Mon Mar 18 22:05:59 2013 ntop is now quitting...
    Home PC - Phenom II X4 955 BE (4GHz) | ASRock 970 Extreme3 R2.0 | 2x4GB 1600 Kingston Hyper X | GTX 760 | RAID0 2xWD500GB Black | Fortron 500W | Dell P2210f | ZELMAN Z3 Plus |
    Laptop - Lenovo G50-30 | Registered Linux User 376002

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: openSUSE 12.3

    On Mon, 18 Mar 2013 20:16:02 +0000, fierce wrote:

    > Can not start ntop. After start ntop I have the following problem:


    Please post the contents of the terminal (including the prompt and
    command executed) in "code" tags - "#" key in the advanced editor.

    That will make this more readable and help us determine what is going on.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Nov 2008
    Location
    Bulgaria
    Posts
    26

    Default Re: openSUSE 12.3

    DENISLAV:~ # ntop
    Mon Mar 18 22:51:23 2013 NOTE: Interface merge enabled by default
    Mon Mar 18 22:51:23 2013 Initializing gdbm databases
    Mon Mar 18 22:51:23 2013 **ERROR** ....open of /var/ntop/prefsCache.db failed: File open error
    Mon Mar 18 22:51:23 2013 Possible solution: please use '-P <directory>'
    Mon Mar 18 22:51:23 2013 **FATAL_ERROR** GDBM open failed, ntop shutting down...
    Mon Mar 18 22:51:23 2013 CLEANUP[t140140627196096]: ntop caught signal 2 [state=2]
    Mon Mar 18 22:51:23 2013 ntop is now quitting...


    DENISLAV:~ # ntop -A
    Mon Mar 18 22:51:37 2013 NOTE: Interface merge enabled by default
    Mon Mar 18 22:51:37 2013 Initializing gdbm databases
    Mon Mar 18 22:51:37 2013 **ERROR** ....open of /var/ntop/prefsCache.db failed: File open error
    Mon Mar 18 22:51:37 2013 Possible solution: please use '-P <directory>'
    Mon Mar 18 22:51:37 2013 **FATAL_ERROR** GDBM open failed, ntop shutting down...
    Mon Mar 18 22:51:37 2013 CLEANUP[t140026020489408]: ntop caught signal 2 [state=2]
    Mon Mar 18 22:51:37 2013 ntop is now quitting...
    Home PC - Phenom II X4 955 BE (4GHz) | ASRock 970 Extreme3 R2.0 | 2x4GB 1600 Kingston Hyper X | GTX 760 | RAID0 2xWD500GB Black | Fortron 500W | Dell P2210f | ZELMAN Z3 Plus |
    Laptop - Lenovo G50-30 | Registered Linux User 376002

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: openSUSE 12.3

    On Mon, 18 Mar 2013 20:46:02 +0000, fierce wrote:

    > DENISLAV:~ # ntop Mon Mar 18 22:37:54 2013 NOTE: Interface merge
    > enabled by default Mon Mar 18 22:37:54 2013 Initializing gdbm databases
    > Mon Mar 18 22:37:54 2013 **ERROR** ....open of /var/ntop/prefsCache.db
    > failed: File open error Mon Mar 18 22:37:54 2013 Possible solution:
    > please use '-P ' Mon Mar 18 22:37:54 2013 **FATAL_ERROR** GDBM open
    > failed, ntop shutting down... Mon Mar 18 22:37:54 2013
    > CLEANUP[t139753361340608]: ntop caught signal 2 [state=2] Mon Mar 18
    > 22:37:54 2013 ntop is now quitting...


    You're still missing the CODE tags, but I think I might be able to make
    some sense of this. Just for future reference, it also would be good to
    pick a subject that wasn't generic - something about 'ntop' in the
    subject would probably help people determine if it's a message they want
    to read and try to help with.

    The error message is indicating that /var/ntop/prefsCache.db cannot be
    opened. I just tried this on my 12.2 system, and got the same error you
    did - the directory isn't created when installing the RPM, but if I start
    with:

    ntop -P .

    then it works fine for me using the current directory.

    Conclusion: Create /var/ntop and see if that helps. Or, as the error
    message suggests, use the -P option to specify a path where the
    configuration data should be stored.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: openSUSE 12.3

    On 03/18/2013 05:09 PM, Jim Henderson pecked at the keyboard and wrote:
    > On Mon, 18 Mar 2013 20:46:02 +0000, fierce wrote:


    CODE
    ----------------------
    >> DENISLAV:~ # ntop Mon Mar 18 22:37:54 2013 NOTE: Interface merge
    >> enabled by default Mon Mar 18 22:37:54 2013 Initializing gdbm databases
    >> Mon Mar 18 22:37:54 2013 **ERROR** ....open of /var/ntop/prefsCache.db
    >> failed: File open error Mon Mar 18 22:37:54 2013 Possible solution:
    >> please use '-P ' Mon Mar 18 22:37:54 2013 **FATAL_ERROR** GDBM open
    >> failed, ntop shutting down... Mon Mar 18 22:37:54 2013
    >> CLEANUP[t139753361340608]: ntop caught signal 2 [state=2] Mon Mar 18
    >> 22:37:54 2013 ntop is now quitting...

    -------------------
    /CODE
    > You're still missing the CODE tags,

    Is it clearer now? :-)
    Last edited by hcvv; 19-Mar-2013 at 02:33.

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: openSUSE 12.3

    On Mon, 18 Mar 2013 21:27:35 +0000, Ken Schneider wrote:

    >> You're still missing the CODE tags,

    > Is it clearer now? :-)


    No.

    I see from looking at it on the web side that the lines aren't broken up
    the way they are on the NNTP side.

    Code tags are handled by the gateway to prefix each line with a space
    (which is a standard way to tell a newsreader that the lines are not
    continuous, but should be treated as if they were new lines).

    There's more reason to use them than just for readability on the web
    interface.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,009
    Blog Entries
    1

    Default Re: openSUSE 12.3

    Code tags are handled by the gateway to prefix each line with a space
    (which is a standard way to tell a newsreader that the lines are not
    continuous, but should be treated as if they were new lines).

    There's more reason to use them than just for readability on the web
    interface.
    Thanks for explaining that Jim. I had always wondered what output enclosed within [CODE] [/CO...] tags appears like via nntp newsreaders.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: openSUSE 12.3

    Quote Originally Posted by deano_ferrari View Post
    Thanks for explaining that Jim. I had always wondered what output enclosed within [CODE] [/CO...] tags appears like via nntp newsreaders.
    And adding them afterwards is of no use. When the original terminal text is not used for the copy/paste, all white space will be reduced already, never to be restored again.

    And there are many reasons for the CODE tags:
    . white space (columns, etc);
    . fixed font (columns and important readability);
    . no smileys;
    . not URL interpreting;
    . clear boundary between story telling and computer facts.;
    . more ......
    Henk van Velden

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,732

    Default Re: openSUSE 12.3

    And indeed, lousy title. I skipped this thread yesterday from reading, preferring another one where I though that I knew something about the subject.
    Henk van Velden

  10. #10
    dd NNTP User

    Default Re: openSUSE 12.3

    On 03/18/2013 09:46 PM, fierce wrote:
    >
    > #ntop #ntop -A same result


    try this
    - as in a terminal become root and create the directory /var/ntop,
    then launch ntop with the -P switch pointing to tht directory

    Code:
    su -
    mkdir /var/ntop
    ntop -P /var/ntop
    then, as indicated by the documentation
    http://www.ntop.org/support/documentation/, point your
    browser at the running ntop web server at
    Code:
    http://[host]:[port]
    here that is
    Code:
    http://192.168.1.101:3000/
    --
    dd
    openSUSE®, the "German Engineered Automobile" of operating systems!
    http://tinyurl.com/DD-Caveat

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •