Results 1 to 2 of 2

Thread: KWallet & Networkmanager (No agents were available for this request.)

  1. #1
    Join Date
    Jun 2008
    Location
    Morecambe Bay
    Posts
    103

    Default KWallet & Networkmanager (No agents were available for this request.)

    I'm running openSUSE 12.2 (i586) (kernel:Linux 3.4.33-2.24-desktop i686) with KDE 4.8.5 (4.8.5) "release 2"

    I'm trying to connect to a VPN server via OpenVPN. I followed the server's instructions for the setup but when I doubleclick on the connection in Systems Settings -> Network Settings -> VPN I get this error message
    Code:
    No agents were available for this request.
    The settings dialog for the OpenVPN connection reopens and the password has disappeared.

    After googling I figured it must have something to do with kwallet, which is running in the background (the icon is in the taskbar) but I never get a popup asking me to save the password.
    I tried uninstalling, re-installing kwallet, deleting wallets etc, but nothing seems to work.

    Any help is greatly appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Morecambe Bay
    Posts
    103

    Wink Re: KWallet & Networkmanager (No agents were available for this request.)

    I have solved it. In my case I didn't have the network manager applet for the taskbar installed. Now that it's installed and I re-did my settings via the applet, kwallet asked to save the password. I'm connected via OpenVPN as I type. The name of the missing package was:

    Code:
    plasmoid-networkmanagement

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •