I have opensuse 11.2 on a vmware virtual machine (Vmware player 5.0.1 build-894247) and tried to install postgresql using the OSS repo here:

https://en.opensuse.org/Package_repositories#Oss

I run the following commands:

zypper ar Index of /pub/opensuse/discontinued/distribution/11.2/repo/oss OSS

zypper install OSS postgresql


And I get the following error:

Failed to provide Package postgresql-libs-8.3.14-0.2.1. Do you want to retry retrieval?

[SUSE-Linux-Enterprise-Server-11-SP2 11.2.2-1.234|cd:///?devices=/dev/sr1,/dev/sr0] Can't provide file './suse/x86_64/postgresql-libs-8.3.14-0.2.1.x86_64.rpm' from repository 'SUSE-Linux-Enterprise-Server-11-SP2 11.2.2-1.234'
History:
- Failed to mount cd:///?devices=/dev/sr1,/dev/sr0 on /var/adm/mount/AP_0x00000001: Mounting media failed (mount: no medium found on /dev/sr0)

- Can't provide ./suse/x86_64/postgresql-libs-8.3.14-0.2.1.x86_64.rpm

I have a Dell L321X with no CD drive. My fstab file:

/dev/sda1 swap swap defaults 0 0
/dev/sda2 / ext3 acl,user_xattr 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0






When I run:
dmesg | grep sr0

I get:
[ 3.717015] sr0: scsi3-mmc drive: 1x/1x writer dvd-ram cd/rw xa/form2 cdda tray
[ 3.717310] sr 2:0:0:0: Attached scsi CD-ROM sr0



Your help is appreciated. Thanks!