Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 51

Thread: Good video editor

  1. #11

    Default Re: Good video editor

    Quote Originally Posted by americast View Post
    When I run the command you gave, I am getting this error:

    Code:
    ffmpeg version 1.1.1 Copyright (c) 2000-2013 the FFmpeg developers
      built on Jan 30 2013 18:42:50 with gcc 4.7 (SUSE Linux)
      configuration: --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib --shlibdir=/usr/lib --disable-stripping --enable-pthreads --enable-shared --enable-avfilter --disable-static --enable-libfaac --enable-libmp3lame --enable-libxvid --enable-libx264 --enable-nonfree --enable-postproc --enable-shared --enable-libdc1394 --enable-libtheora --enable-libschroedinger --enable-libvpx --enable-gpl --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3 --enable-x11grab
      libavutil      52. 13.100 / 52. 13.100
      libavcodec     54. 86.100 / 54. 86.100
      libavformat    54. 59.106 / 54. 59.106
      libavdevice    54.  3.102 / 54.  3.102
      libavfilter     3. 32.100 /  3. 32.100
      libswscale      2.  1.103 /  2.  1.103
      libswresample   0. 17.102 /  0. 17.102
      libpostproc    52.  2.100 / 52.  2.100
    Option 'sameq' was removed. If you are looking for an option to preserve the quality (which is not what -sameq was for), use -qscale 0 or an equivalent quality factor option.
    Failed to set value '1' for option 'sameq'
    Error parsing global options: Invalid argument
    Thanx...
    Interesting. Your version ffmpeg is newer than mine. I don't get that error. Since both streams are being copied (not transcoded), it is possible that "-sameq" is unnecessary. Did you try without? Or, did you try with the recommended "-qscale 0" instead?

  2. #12

    Default Re: Good video editor

    Quote Originally Posted by americast View Post
    I tried using qscale 0 instead of sameq. It worked, but the avi file thus formed is still not getting detected by kdenlive. When I try to insert it, kdenlive says:

    Code:
    Clip is invalid, will be removed from project:
    Thanx...
    Try replacing "-vcodec copy" with "-vcodec h264". This will re-encode the video using the H.264 codec.

  3. #13
    Join Date
    May 2012
    Location
    Kolkata, India
    Posts
    161

    Default Re: Good video editor

    Quote Originally Posted by JJMT View Post
    Interesting. Your version ffmpeg is newer than mine. I don't get that error. Since both streams are being copied (not transcoded), it is possible that "-sameq" is unnecessary. Did you try without? Or, did you try with the recommended "-qscale 0" instead?
    Just now I tried without -sameq. It didn't work. I think there is some problem with kdenlive. In the config wizard, I am getting this:

    See link https://www.dropbox.com/s/zdhk132rn3cjuco/kden.png

    Thanx...

  4. #14
    Join Date
    May 2012
    Location
    Kolkata, India
    Posts
    161

    Default Re: Good video editor

    Quote Originally Posted by JJMT View Post
    Try replacing "-vcodec copy" with "-vcodec h264". This will re-encode the video using the H.264 codec.
    Getting this error:
    Code:
    ffmpeg version 1.1.1 Copyright (c) 2000-2013 the FFmpeg developers
      built on Jan 30 2013 18:42:50 with gcc 4.7 (SUSE Linux)
      configuration: --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib --shlibdir=/usr/lib --disable-stripping --enable-pthreads --enable-shared --enable-avfilter --disable-static --enable-libfaac --enable-libmp3lame --enable-libxvid --enable-libx264 --enable-nonfree --enable-postproc --enable-shared --enable-libdc1394 --enable-libtheora --enable-libschroedinger --enable-libvpx --enable-gpl --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3 --enable-x11grab
      libavutil      52. 13.100 / 52. 13.100
      libavcodec     54. 86.100 / 54. 86.100
      libavformat    54. 59.106 / 54. 59.106
      libavdevice    54.  3.102 / 54.  3.102
      libavfilter     3. 32.100 /  3. 32.100
      libswscale      2.  1.103 /  2.  1.103
      libswresample   0. 17.102 /  0. 17.102
      libpostproc    52.  2.100 / 52.  2.100
    Input #0, avi, from 'A Strong Man.mpeg':
      Metadata:
        encoder         : Lavf52.13.0
      Duration: 00:02:30.20, start: 0.000000, bitrate: 895 kb/s
        Stream #0:0: Video: mpeg4 (Simple Profile) (FMP4 / 0x34504D46), yuv420p, 1430x798 [SAR 1:1 DAR 715:399], 10 tbr, 10 tbn, 10 tbc
    [NULL @ 0x8e70840] Unable to find a suitable output format for 'copy'
    copy: Invalid argument
    Thanx..

  5. #15

    Default Re: Good video editor

    Quote Originally Posted by americast View Post
    Just now I tried without -sameq. It didn't work. I think there is some problem with kdenlive. In the config wizard, I am getting this:

    See link https://www.dropbox.com/s/zdhk132rn3cjuco/kden.png

    Thanx...
    Yup. That's bad. Which repository is your installation of ffmpeg from? If you've installed kdenlive from packman, you probably want to get ffmpeg from there as well.

  6. #16
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Good video editor

    Quote Originally Posted by JJMT View Post
    Yup. That's bad. Which repository is your installation of ffmpeg from? If you've installed kdenlive from packman, you probably want to get ffmpeg from there as well.
    And FYI

    Packman version

    Code:
    rpm -qi ffmpegName        : ffmpeg
    Version     : 1.0.5
    Release     : 1.1
    Architecture: x86_64
    Install Date: Sun 10 Mar 2013 05:41:47 GMT
    Group       : Productivity/Multimedia/Video/Editors and Convertors
    Size        : 3694777
    License     : LGPL-2.0+ and some code GPL-2.0+
    Signature   : RSA/SHA1, Sat 09 Mar 2013 19:30:57 GMT, Key ID 45a1d0671abd1afb
    Source RPM  : ffmpeg-1.0.5-1.1.src.rpm
    Build Date  : Fri 08 Mar 2013 21:51:28 GMT
    Build Host  : mmeal.managermeal.com
    Relocations : (not relocatable)
    Packager    : packman@links2linux.de
    Vendor      : http://packman.links2linux.de
    URL         : http://www.ffmpeg.org
    Summary     : Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder
    Are you sure you don't have the VLC repo
    That''ll fluff everything up good and proper
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #17
    Join Date
    May 2012
    Location
    Kolkata, India
    Posts
    161

    Default Re: Good video editor

    Quote Originally Posted by caf4926 View Post
    And FYI

    Packman version

    Code:
    rpm -qi ffmpegName        : ffmpeg
    Version     : 1.0.5
    Release     : 1.1
    Architecture: x86_64
    Install Date: Sun 10 Mar 2013 05:41:47 GMT
    Group       : Productivity/Multimedia/Video/Editors and Convertors
    Size        : 3694777
    License     : LGPL-2.0+ and some code GPL-2.0+
    Signature   : RSA/SHA1, Sat 09 Mar 2013 19:30:57 GMT, Key ID 45a1d0671abd1afb
    Source RPM  : ffmpeg-1.0.5-1.1.src.rpm
    Build Date  : Fri 08 Mar 2013 21:51:28 GMT
    Build Host  : mmeal.managermeal.com
    Relocations : (not relocatable)
    Packager    : packman@links2linux.de
    Vendor      : http://packman.links2linux.de
    URL         : http://www.ffmpeg.org
    Summary     : Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder
    Are you sure you don't have the VLC repo
    That''ll fluff everything up good and proper
    I have VLC repo.... Should I remove it?

  8. #18
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Good video editor

    There is also a recent slashdot thread that explores some aspects of video editors for GNU/Linux here: Video Editor OpenShot Wants To Kickstart Windows, OS X Versions - Slashdot

  9. #19
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Good video editor

    Quote Originally Posted by americast View Post
    I have VLC repo.... Should I remove it?
    Yes
    Then apply the switch on Packman
    It could be tricky
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #20
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Good video editor

    Quote Originally Posted by americast View Post
    I have VLC repo.... Should I remove it?
    There is a major risk that applictations packaged for the VLC repos will be incompatible with applications packaged for the packman repo.

Page 2 of 6 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •