Results 1 to 5 of 5

Thread: frozen bubble issues

  1. #1

    Default frozen bubble issues

    Re: Machine #1

    This is probably not a real high priority question, except that it is effecting other things besides the "Frozen Bubble" game. I am having two difficulties. I am posting it here because the FROZEN BUBBLE [Frozen Bubble - the official home] site says this is where I must go for help.
    if you use Linux and installed a package provided by your distribution, you have to contact the guys of your distribution. We don't know the intrinsics of every Linux distributions and neither the patches they have applied to Frozen-Bubble when packaging.
    Difficulty 1] I would like to be able to start the game in a non FULL Screen mode.
    Currently it starts in FULL Screen Mode and one presses the ESCape key to bring it out of that mode to a smaller window.
    There does not seem to be any choices here as this smaller window cannot be resized, to a more reasonable size. There is a file in my home folder called .frozenbubble that contains a file called RC. the contents of this file are:
    Code:
    $fullscreen = 1;
    
    $graphics_level = 3;
    
    $mynick = 'dabud';
    
    $music_disabled = undef;
    
    $mixer_enabled = 0;
    
    $mylatitude = undef;
    
    $mylongitude = undef;
    
    $KEYS = {
              
               'p2' => {
    
                        'left' => SDLK_x,
    
                        'right' => SDLK_v,
    
                        'fire' => SDLK_c,
    
                        'center' => SDLK_d
    
                      },
    
              'p1' => {
    
                        'left' => SDLK_LEFT,
    
                        'right' => SDLK_RIGHT,
    
                        'fire' => SDLK_UP,
    
                        'center' => SDLK_DOWN
    
                      },
              
                'misc' => {
    
                          'toggle_music' => SDLK_F11,
    
                          'send_malus_to_rp1' => SDLK_F1,
    
                          'send_malus_to_rp2' => SDLK_F2,
    
                          'chat' => SDLK_RETURN,
    
                          'lower_volume' => SDLK_KP_MINUS,
    
                          'send_malus_to_rp3' => SDLK_F3,
    
                          'send_malus_to_all' => SDLK_F10,
    
                          'send_malus_to_rp4' => SDLK_F4,
    
                          'next_playlist_elem' => SDLK_TAB,
    
                          'toggle_sound' => SDLK_F12,
    
                          'fs' => SDLK_f,
    
                          'save_record' => SDLK_PRINT,
    
                          'raise_volume' => SDLK_KP_PLUS
    
                        }
    
            };
    Is it possible to change something in here to fix this resize problem? I would like to be able to resize to any size, but if I am only able to get a specific size that would be OK.


    Difficulty 2] When ever I open FROZEN BUBBLE, it opens in FULL screen mode and I press ESCape to downsize it, all of the windows that I have open get shrunk to a smaller size and I have to resize them all. Its a bit of a pain to have to do this all the time , so I am wondering how I can change this.
    Thanks
    Machine # 1 - Asus Prime Z390A, i7-9700k 3.6GHz, 32.0 GB ram, openSUSE Leap 15.0 64-bit, KDE Plasma 5.12.8
    Machine # 2 - Asus P8Z77-V Deluxe, i7-3770k 3.5GHz, 16.0 GB ram, Debian 10 Buster 64-bit, LXDE

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,344
    Blog Entries
    15

    Default Re: frozen bubble issues

    On Mon 11 Mar 2013 01:16:01 AM CDT, LaQuirrELL wrote:


    RE: MACHINE #1
    This is probably not a real high priority question, except that it is
    effecting other things besides the "Frozen Bubble" game. I am having
    _*two_difficulties*_. I am posting it here because the FROZEN BUBBLE
    ['Frozen Bubble - the official home'
    (http://www.frozen-bubble.org/troubleshooting/)] site says this is where
    I must go for help.
    Hi
    You can add the command line switch;
    Code:
    frozen-bubble --no-fullscreen
    
    More options....
    frozen-bubble --help
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.28-2.20-desktop
    up 1 day 20:46, 3 users, load average: 0.12, 0.10, 0.14
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


  3. #3

    Default Re: frozen bubble issues

    On 03/10/2013 09:16 PM, LaQuirrELL pecked at the keyboard and wrote:
    > RE: MACHINE #1
    > This is probably not a real high priority question, except that it is
    > effecting other things besides the "Frozen Bubble" game. I am having
    > _*two_difficulties*_. I am posting it here because the FROZEN BUBBLE
    > ['Frozen Bubble - the official home'
    > (http://www.frozen-bubble.org/troubleshooting/)] site says this is where
    > I must go for help.
    >> if you use Linux and installed a package provided by your distribution,
    >> you have to contact the guys of your distribution. We don't know the
    >> intrinsics of every Linux distributions and neither the patches they
    >> have applied to Frozen-Bubble when packaging.

    > *Difficulty 1*] I would like to be able to start the game in a non FULL
    > Screen mode.
    > Currently it starts in FULL Screen Mode and one presses the ESCape
    > key to bring it out of that mode to a smaller window.
    > There does not seem to be any choices here as this smaller window
    > cannot be resized, to a more reasonable size. There is a file in my
    > home folder called .frozenbubble that contains a file called RC. the
    > contents of this file are:
    >
    > Code:
    > --------------------
    > $fullscreen = 1;
    >
    >


    Change this to a 0 (zero) and is should start without being full screen.

  4. #4

    Default Re: frozen bubble issues

    ty for reply malcolmlewis and kensch

    I have tried both of your suggestions, but unfortunately they did not work. On the gui window that is. When I tried:
    You can add the command line switch;
    Code:
         Code:
    
         
    frozen-bubble --no-fullscreen  
    More options.... frozen-bubble --help
    the line in the RC file changed to 0, but the game still opens in FULL SCREEN mode.

    And that still is not even addressing the second problem. [See Difficulty 2]

    Difficulty 2 When ever I open FROZEN BUBBLE, it opens in FULL screen mode and I press ESCape to downsize it, all of the windows that I have open get shrunk to a smaller size and I have to resize them all every time. Its a bit of a pain to have to do this all the time , so I am wondering how I can change this.
    Overall, I would like:
    the game not to open in FULL SCREEN mode
    and I would like to be able to adjust the game window size
    and
    I want to not have to adjust my other window sizes after I close the game .
    Thank You
    Machine # 1 - Asus Prime Z390A, i7-9700k 3.6GHz, 32.0 GB ram, openSUSE Leap 15.0 64-bit, KDE Plasma 5.12.8
    Machine # 2 - Asus P8Z77-V Deluxe, i7-3770k 3.5GHz, 16.0 GB ram, Debian 10 Buster 64-bit, LXDE

  5. #5

    Default Re: frozen bubble issues

    In case anyone else need the info, Frozen Bubble game works with opensuse 12.2, but there are no adjustments that can be made on its playing area. Its either FULLSCREEN or tiny screen. The cli --no-fullscreen does not work. So, Difficulty #1 is unsolvable at this time.

    Difficulty #2 was solved by upgrading to KDE 4.9 or up. It was a bug/feature according to KDE forums.

    So, while not the best outcome for me, at least I know the immediate answers.

    thanks to ALL
    Machine # 1 - Asus Prime Z390A, i7-9700k 3.6GHz, 32.0 GB ram, openSUSE Leap 15.0 64-bit, KDE Plasma 5.12.8
    Machine # 2 - Asus P8Z77-V Deluxe, i7-3770k 3.5GHz, 16.0 GB ram, Debian 10 Buster 64-bit, LXDE

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •