Results 1 to 3 of 3

Thread: A bug, I think : KDE 4.10.1 Device Notifier

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    974

    Default A bug, I think : KDE 4.10.1 Device Notifier

    I just upgraded my 12.2 to KDE 4.10.1

    I see the following issue:

    I inserted an SD card into internal Card reader,
    Device Notifier opened as expected, offered three actions, I chose download with Digikam
    Digikam opened and download worked as expected.
    I closed the Digikam Import window, Digikam main window still open
    I selected the Device Notifier icon, it pops up as expected
    As soon as I move the mouse pointer off the system tray, moving toward the Unmount icon, the pop-up closes.

    I am able to unmount the SD card from within Dolphin.

    Can someone confirm this behavior before I enter a bug?
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: A bug, I think : KDE 4.10.1 Device Notifier

    Quote Originally Posted by cmcgrath5035 View Post
    I just upgraded my 12.2 to KDE 4.10.1

    I see the following issue:

    I inserted an SD card into internal Card reader,
    Device Notifier opened as expected, offered three actions, I chose download with Digikam
    Digikam opened and download worked as expected.
    I closed the Digikam Import window, Digikam main window still open
    I selected the Device Notifier icon, it pops up as expected
    As soon as I move the mouse pointer off the system tray, moving toward the Unmount icon, the pop-up closes.

    I am able to unmount the SD card from within Dolphin.

    Can someone confirm this behavior before I enter a bug?
    I just did this with a thumb drive and it worked as expected, must only be SD card or maybe your particular reader.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    974

    Default Re: A bug, I think : KDE 4.10.1 Device Notifier

    Thanks for the additional info.

    I am somewhat suspicious of USB3 drivers, maybe.

    Motherboard has both USB2 and USB3.
    I have tried a USB2 thumb drive in USB2 port, it seems OK.
    Same Thumbdrive in USB3 port mounts OK, but exhibits the same behavior when I try to unmount thru device notifier.
    The SD card reader is USB3.

    As first reported, the USB memories (SD or Thumb), behave normally when controlled via Dolphin

    I am fairly certain this is the Card Reader Device on the USB bus:
    Code:
    carl@PVE-LinuxSRV5:~> lsusb
    ....
    ....
    Bus 007 Device 002: ID 0bda:0301 Realtek Semiconductor Corp.
    ....
    ....
    I'll wait for some additional input from someone with an SD card reader

    For anyone who comments, USB2 vs. USB3 connection of the card reader may be important info.

    As an aside - USB3 Card readers provide SIGNIFICANT SD card download improvement.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •