Results 1 to 4 of 4

Thread: KDE 4.10 breaks Stattransfer's GUI

  1. #1

    Default KDE 4.10 breaks Stattransfer's GUI

    I use Stattransfer Linux which is a file conversion program. It has a GUI version with a very simple GUI requiring only kernel 2.6 or abov, glibc 2.33 or higher and gtk 2.6.4 or higher. This has worked perfectly for me under KDE 4.85, 4.9, and 4.95. I updated to KDE 4.10 and the GUI is broken (the underlying command line version still works). I downgraded back to 4.95 and the GUI for the program is still broken. It throws the following error code:
    Code:
    *** glibc detected *** ./stattransfer: free(): invalid pointer: 0x00000000029c67c8 ***
    ======= Backtrace: =========
    /lib64/libc.so.6(+0x78b66)[0x7f428ba53b66]
    /usr/lib64/gtk-2.0/2.10.0/engines/liboxygen-gtk.so(_ZN6Oxygen3Gtk2RC4initEv+0x126)[0x7f42861c3336]
    /usr/lib64/gtk-2.0/2.10.0/engines/liboxygen-gtk.so(_ZN6Oxygen10QtSettings10initializeEj+0x160)[0x7f42861c2b20]
    /usr/lib64/gtk-2.0/2.10.0/engines/liboxygen-gtk.so(_ZN6Oxygen5Style10initializeEj+0x35)[0x7f42861d4285]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x201846)[0x7f428e426846]
    /usr/lib64/libgobject-2.0.so.0(g_type_module_use+0x81)[0x7f428d2b0a41]
    /usr/lib64/libgtk-x11-2.0.so.0(gtk_theme_engine_get+0x35)[0x7f428e426955]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x18a5fb)[0x7f428e3af5fb]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x18b365)[0x7f428e3b0365]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x18b528)[0x7f428e3b0528]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x18a072)[0x7f428e3af072]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x18b365)[0x7f428e3b0365]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x18b528)[0x7f428e3b0528]
    /usr/lib64/libgtk-x11-2.0.so.0(gtk_rc_reparse_all_for_settings+0x12f)[0x7f428e3b0b3f]
    /usr/lib64/libgtk-x11-2.0.so.0(gtk_settings_get_for_screen+0xb5)[0x7f428e3cda35]
    /usr/lib64/gtk-2.0/modules/libcanberra-gtk-module.so(+0x3ed6)[0x7f42870ebed6]
    /usr/lib64/gtk-2.0/modules/libcanberra-gtk-module.so(gtk_module_init+0x48)[0x7f42870ec1b8]
    /usr/lib64/libgtk-x11-2.0.so.0(+0x156be1)[0x7f428e37bbe1]
    /usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0x190)[0x7f428d28d700]
    /usr/lib64/libgobject-2.0.so.0(+0x21770)[0x7f428d29e770]
    /usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0xdac)[0x7f428d2a66dc]
    /usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x82)[0x7f428d2a6872]
    /usr/lib64/libgobject-2.0.so.0(+0x150a5)[0x7f428d2920a5]
    /usr/lib64/libgobject-2.0.so.0(g_object_notify+0x17b)[0x7f428d29398b]
    /usr/lib64/libgdk-x11-2.0.so.0(gdk_display_open_default_libgtk_only+0x85)[0x7f428df91765]
    /usr/lib64/libgtk-x11-2.0.so.0(gtk_init_check+0x14)[0x7f428e361f64]
    ./stattransfer[0x56c413]
    ./stattransfer[0x6bd8a8]
    ./stattransfer[0x6bdb5a]
    ./stattransfer[0x48f21a]
    /lib64/libc.so.6(__libc_start_main+0xf5)[0x7f428b9fc455]
    ./stattransfer[0x41c9ea]
    I'm trying to figure out what's broken and replace it. The vendor, unfortunately has no clue. I'm wondering if this code means something to one of the gurus here.

    By the way, KDE 4.10 has been a nightmare. I've had exactly the same problem as this one reported on the KDE forum http://forum.kde.org/viewtopic.php?f=15&t=110059 This is why I went back to 4.95.

  2. #2
    Join Date
    Feb 2011
    Location
    Zagreb, Croatia
    Posts
    120

    Default Re: KDE 4.10 breaks Stattransfer's GUI

    According to trace you posted, looks more like oxygen-gtk problem than KDE. Try using another GTK style and see does that happen there also

  3. #3

    Default Re: KDE 4.10 breaks Stattransfer's GUI

    Thank you so much. You are a lifesaver. I changed the GTK theme to Clearlooks and the GUI now works perfectly again.

  4. #4
    Join Date
    Feb 2011
    Location
    Zagreb, Croatia
    Posts
    120

    Default Re: KDE 4.10 breaks Stattransfer's GUI

    Glad it works now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •