Results 1 to 5 of 5

Thread: Another day, another problem with opensuse...(sigh) kmail again...

  1. #1
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Another day, another problem with opensuse...(sigh) kmail again...

    Oh well, only a few days to go before 12.3 comes out, and 12.2 not working properly yet......

    Today's annoyance comes courtesy of kmail and or our old and reliably irritating friend akonadi




    I do have of course, 'semantic desktop' enabled.. (BTW I don't know what speakers of other languages make of it, but as a native english speaker, the word 'semantic' makes me reach for my gun, being ironically an more-or-less meaningless word in this context, but still.............)

    Anyhow, and despite Knurpht's kind and patient advice, this is still a daily, or every boot/log-in problem:

    https://forums.opensuse.org/english/...de-4-10-a.html


    And this annoyance is also still with me....


    https://forums.opensuse.org/english/...hromium-2.html

    As I mentioned in the thread, I am not expert enough to present a meaningful bug-report on this, and it seems that I am in a very small group who have the problem.



    Also during the last week, Facebook's sidebar stopped working, leaving me unable to use messaging.. this suddenly started working again after a number of updates from Chromium (chromium repo)
    Folks on IRC #chromium-support tell me that the version supplied by Index of /repositories/network:/chromium/openSUSE_12.2 is, in fact 'canary' ie a pre-beta unstable, testing only release. I was surprised to learn this. Should I be using chromium from a different source?

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  2. #2
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Another day, another problem with opensuse...(sigh) kmail again...

    Quote Originally Posted by wakou View Post
    Oh well, only a few days to go before 12.3 comes out, and 12.2 not working properly yet......
    I do have of course, 'semantic desktop' enabled.. (BTW I don't know what speakers of other languages make of it, but as a native english speaker, the word 'semantic' makes me reach for my gun, being ironically an more-or-less meaningless word in this context, but still.............)
    Do you have Nepomuk set to index Email, Files and of course the top check box Semantic Desktop? Also, is your Akonadi Server actually configured and running. I had a problem after upgrading to KDE 4.10 that the mysql.service was not set to start up at login, I had to enable it in Yast system services, maybe this will help.

    The kmail problem from your other thread seems to be the new normal. What I mean is Kwallet will ask me at every boot for the master password for the Kmail account so it can check my mail in the background. I never see a Kwallet window etc.... either but all seems to be working fine. I find it annoying that it has to ask every time I reboot but I guess there is no better way at the moment.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,581
    Blog Entries
    14

    Default Re: Another day, another problem with opensuse...(sigh) kmail again...

    Quote Originally Posted by anika200 View Post
    Do you have Nepomuk set to index Email, Files and of course the top check box Semantic Desktop? Also, is your Akonadi Server actually configured and running. I had a problem after upgrading to KDE 4.10 that the mysql.service was not set to start up at login, I had to enable it in Yast system services, maybe this will help.

    The kmail problem from your other thread seems to be the new normal. What I mean is Kwallet will ask me at every boot for the master password for the Kmail account so it can check my mail in the background. I never see a Kwallet window etc.... either but all seems to be working fine. I find it annoying that it has to ask every time I reboot but I guess there is no better way at the moment.
    @Both: there's loads of posts in the forums explaining how to avoid this. Simply activate the wallet, but don't enter a password. This way, wallet will avoid storage of passwords as plain text in config files, yet doesn't ask for the wallet password on login. Yes, I'm aware that this breaks the wallet security, but you cannot have both the security and not having to enter a password. Choice to the user. If you already have a password on the wallet, you can change that from the walletmanager itself.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Another day, another problem with opensuse...(sigh) kmail again...

    Quote Originally Posted by Knurpht View Post
    @Both: there's loads of posts in the forums explaining how to avoid this. Simply activate the wallet, but don't enter a password. This way, wallet will avoid storage of passwords as plain text in config files, yet doesn't ask for the wallet password on login. Yes, I'm aware that this breaks the wallet security, but you cannot have both the security and not having to enter a password. Choice to the user. If you already have a password on the wallet, you can change that from the walletmanager itself.

    Knurpht, it is not the entering a password that is the problem, I realise that this is necessary. But when I boot up, I have to :



    1. Dismiss the 'kmail wants a password' dialogue. (It does not do anything if I enter a password here, the wallet does NOT open)
    2. Go to configure desktop, and DISABLE kwallet
    3. Apply
    4. Open kwallet manager
    5. Dismiss 'kmail wants a pass as the kwallet is disabled' dialogues, one for each email account
    6. ENable kwallet
    7. Open a wallet via kwallet manager, and enter pass
    8. Close manager.


    This a more than slightly annoying way to check my emails!

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

  5. #5
    Join Date
    Feb 2009
    Location
    UK
    Posts
    1,085

    Default Re: Another day, another problem with opensuse...(sigh) kmail again...

    Quote Originally Posted by anika200 View Post
    Do you have Nepomuk set to index Email, Files and of course the top check box Semantic Desktop? Also, is your Akonadi Server actually configured and running. I had a problem after upgrading to KDE 4.10 that the mysql.service was not set to start up at login, I had to enable it in Yast system services, maybe this will help..
    Ty Anika.




    I also enabled mysql in yast>system services... I still get the error message when sending mail....


    Quote Originally Posted by anika200 View Post
    The kmail problem from your other thread seems to be the new normal. What I mean is Kwallet will ask me at every boot for the master password for the Kmail account so it can check my mail in the background. I never see a Kwallet window etc.... either but all seems to be working fine. I find it annoying that it has to ask every time I reboot but I guess there is no better way at the moment
    AFAIR Anika, it has always been this way, ie enter a pass to open the wallet on first use per session, and is not really a problem, my situation, as detailed above is more broken !

    Tumbleweed/KDE/Ati Radeon R9 270/AMD FX-6300/8Gb DDR3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •