Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: KDE 4.8.5 12.2 Screen blanking. ARG!

  1. #1
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default KDE 4.8.5 12.2 Screen blanking. ARG!

    I recently did a zypper dup to 12.2 from 12.1
    Somewhere along the process this intermittent problem has surfaced.
    My screen is blanking after a very short time.
    I gone into configure desktop and deselected that process in both on AC and on Battery but it still is happening randomly.
    When I did a reboot just now the battery icon showed up in the system tray. I went back in and verified the screen blanking in Battery and verified it was off on AC.
    This is a desktop machine not a laptop. Last night it was blanking the screen while I was trying to watch a stream off Crunchyroll. I did a reboot and it stopped.
    How can I stop this behavior from occurring completely and permanently?

    I am turning to the forums first and I am hoping this is a openSUSE issue not a KDE issue and that it can be fixed
    Tumbleweed

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    Quote Originally Posted by FlameBait View Post
    I recently did a zypper dup to 12.2 from 12.1
    Somewhere along the process this intermittent problem has surfaced.
    My screen is blanking after a very short time.
    I gone into configure desktop and deselected that process in both on AC and on Battery but it still is happening randomly.
    When I did a reboot just now the battery icon showed up in the system tray. I went back in and verified the screen blanking in Battery and verified it was off on AC.
    This is a desktop machine not a laptop. Last night it was blanking the screen while I was trying to watch a stream off Crunchyroll. I did a reboot and it stopped.
    How can I stop this behavior from occurring completely and permanently?

    I am turning to the forums first and I am hoping this is a openSUSE issue not a KDE issue and that it can be fixed
    did you turn off the screensaver?
    I think be default it blanks the screen.

    configure desktop > display and monitor . . .

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    Check these settings
    Obviously make sure you also turn off screensaver
    https://dl.dropbox.com/u/10573557/SU...rsettings.jpeg
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    Quote Originally Posted by caf4926 View Post
    Check these settings
    Obviously make sure you also turn off screensaver
    https://dl.dropbox.com/u/10573557/SU...rsettings.jpeg
    Yea they are all off and I double checked the screen saver too.
    doing that and a reboot seems to have stopped it for now.

    The screensaver screen locker all that stuff disabled to begin with just started out of the blue.
    Tumbleweed

  5. #5
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default It's back!

    OK. No reboots but this screen blanking behavior is back after just normal operations and the system sitting over night running. I checked all the setting they are all disabled.
    to say the least I don;'t like this as I can't watch videos which is one of the main things I do besides the internet on this machine.
    Is there a configuration file somewhere I can look at and edit?
    Tumbleweed

  6. #6
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    OK I found a thread on this @ https://forums.opensuse.org/english/...ut-solved.html

    I added consoleblank=0 to /boot/grub/menu.lst as a attempt to stop this in 12.2

    I never got bit by this in 11.4 or 12.1 but as we know doing upgrades with zypper dup can leave these small issues to deal with. I can't just move the stuff on this machine easily because of the multiple drive (six devices) set up would make it hell with my limited knowledge and multiple partitions so zypper dup is the way I go. Clean installs are always the way to go if you can.
    Tumbleweed

  7. #7

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    I was fighting that problem for a long time, very bizarre I must say.
    What finally did it (I hope, been a week at least without blanking) is to edit /etc/X11/xorg.conf and to set DPMS to false.

    Like this :
    Code:
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "false"
    EndSection
    Of course, along with that you have to also disable screensaver and everything in power options.
    Also check this file : .kde4/share/config/kscreensaverrc , and put this in the first line :
    Code:
    DPMS-dependent=false
    Good luck.

  8. #8
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    Quote Originally Posted by gzenum View Post
    I was fighting that problem for a long time, very bizarre I must say.
    What finally did it (I hope, been a week at least without blanking) is to edit /etc/X11/xorg.conf and to set DPMS to false.

    Like this :
    Code:
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "false"
    EndSection
    Of course, along with that you have to also disable screensaver and everything in power options.
    Also check this file : .kde4/share/config/kscreensaverrc , and put this in the first line :
    Code:
    DPMS-dependent=false
    Good luck.
    I've got an Nvida card with the Nvidia blob

    I was gone for over 4 hours and when I came back I turned on the monitor and it wasn't blanked so I "might" have licked it.
    I will take your xorg.conf into advisement gzenum
    Tumbleweed

  9. #9

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    Yeah, never mind the ATI and the rest of the lines , what you need to do is to locate and edit that file, then look for :

    Section "Monitor"

    After that , whatever is in there leave it and just put this :
    Option "DPMS" "false"

    in the line above EndSection

    btw I had the exact same problem like you, it was completely random, can be 15 minutes, 1hr, 2hrs, 4hrs, 10hrs, 2 days .... completely crazy and very annoying.

    I think its been maybe 2 weeks now (can't tell for sure, but 10 days minimum) since I edited that xorg.cong file and it finally stopped.
    Before that edit with everything else tried to stop that blanking, record was maybe 3 days tops.
    So I guess it's good now

  10. #10
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: KDE 4.8.5 12.2 Screen blanking. ARG!

    Quote Originally Posted by gzenum View Post
    Yeah, never mind the ATI and the rest of the lines , what you need to do is to locate and edit that file, then look for :

    Section "Monitor"

    After that , whatever is in there leave it and just put this :
    Option "DPMS" "false"

    in the line above EndSection

    btw I had the exact same problem like you, it was completely random, can be 15 minutes, 1hr, 2hrs, 4hrs, 10hrs, 2 days .... completely crazy and very annoying.

    I think its been maybe 2 weeks now (can't tell for sure, but 10 days minimum) since I edited that xorg.cong file and it finally stopped.
    Before that edit with everything else tried to stop that blanking, record was maybe 3 days tops.
    So I guess it's good now

    Where would you put that here as there are two sections "Monitor" and "Screen" I have two monitors but only one is defined.

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings# nvidia-settings:  version 290.10  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Wed Nov 16 18:46:42 PST 2011
    
    
    
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    
    Section "Files"
    EndSection
    
    
    Section "InputDevice"
    
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "InputDevice"
    
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    
    Section "Monitor"
    
    
        # HorizSync source: edid, VertRefresh source: edid
    #    DisplaySize     508 285
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "LG Electronics E2340"
        HorizSync       30.0 - 83.0
        VertRefresh     56.0 - 75.0
        Option         "DPMS"
         EndSection
    
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GT"
    EndSection
    
    
    Section "Screen"
    
    
    # Removed Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1: nvidia-auto-select +1920+0"
    # Removed Option "metamodes" "CRT-0: 1920x1080 +0+0, CRT-1: 1920x1080 +1920+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "CRT-0: 1920x1080 +0+0, CRT-1: 1920x1080 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    Tumbleweed

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •