Quote Originally Posted by Januuid View Post
I'm no expert and I recently installed 12.3 of openSUSE and like it very much.
My desktop environment is KDE4 and KWIN as login/window manager.
I have a Nvidia gtx560ti as graphics card.

I firstly disabled the screensaver the normal way via settings in configuration menu's in KDE, but the screen still blanked when I watch a youtube clip that lasts longer than 10 minutes and not touching the mouse or doing other stuff on the computer while watching.
I tried to turn off everything that has something to do with powermanagement and screensaver.. (in desktop session and/or service manager)
KDE activities work well in your situation.

Create a new (empty) desktop activity that you will use for watching video and give it a name (I use Flash Video).
Then go into . . .

configure desktop > power management > activity settings

and click on the new activity you just created

set it like this



then whenever you want to watch a video just select that activity beforehand.

of course you could set up any activity like this and it may also be a solution also for the OPs as well