Results 1 to 9 of 9

Thread: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) Clock OSS 12.2 KDE

  1. #1
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) Clock OSS 12.2 KDE

    I'm not sure where to set the clock or point the clock parameter in TB, but times for receiving messages have always read eight hours ahead of my actual time since installing 12.2 which I have set with UTC. The clocks in UTC and local time are in sync and correct, so I'm not sure what TB is pointing at. Could someone please tell me where is the setting in TB for pointing it at the correct time? Thanks in advance!
    Last edited by HealingMindNOS; 27-Feb-2013 at 15:45. Reason: typo

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,781
    Blog Entries
    3

    Default Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) Clock OSS 12.2 KDE

    I'm not sure where you are looking. Is this from a header in the message itself?
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) ClockOSS 12.2 KDE

    On 2013-02-27 23:46, HealingMindNOS wrote:
    >
    > I'm not sure where to set the clock or point the clock parameter in TB,
    > but times for receiving messages have always read *eight hours ahead* of
    > my actual time since installing 12.2 which I have set with UTC. The
    > clocks in UTC and local time are in sync and correct, so I'm not sure
    > what TB is pointing at. Could someone please tell me where is the
    > setting in TB for pointing it at the correct time? Thanks in advance!


    Thunderbird should display the time and date as specified by the
    variable "LC_TIME". Check the value with the CLI command "locale". The
    desktop time format is ignored.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,781
    Blog Entries
    3

    Default Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) Clock OSS 12.2 KDE

    I don't normally use thunderbird, though I do have it installed.

    To test, I examined a few messages in thunderbird.

    The time/date shown with each message in thunderbird is same time/date as on the "Date:" header line in the raw message, except that it has been converted to the local timezone.

    To examine a raw message, enter CTRL-U while thunderbird has that message open.

    Example: A message that I am looking at has a "Date:" header
    Code:
    Date: Tue, 26 Feb 2013 16:43:58 -0500

    That's Eastern time (New York time), as the "-500" indicates.

    Thunderbird is showing for that message: "02/26/2013 03:43 PM"

    My timezone is: US/Central
    The system clock is set to UTC, but system time zone is US/Central, as shown by the output of the "date" command.
    Code:
    % date
    Wed Feb 27 22:09:48 CST 2013
    Carlos mentions local. That is set by
    Code:
    LC_TIME="en_US.UTF-8"
    which affects the formatting of the time, but not the time zone used.

    Maybe the originator of this thread should show:
    1. Output of the "date" command (put in a code box)
    2. The date of a thunderbird message (copy/paste from the display)
    3. The "Date:" header of that message (put in a code box).

    That will help us to see what, if anything, might be wrong.

    To put lines in a code box, select those lines with the mouse, then click the # button.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) ClockOSS 12.2 KDE

    On 2013-02-28 05:16, nrickert wrote:
    > Carlos mentions local. That is set by
    >
    > Code:
    > --------------------
    >
    > LC_TIME="en_US.UTF-8"
    >
    > --------------------
    >
    > which affects the formatting of the time, but not the time zone used.


    You are right. It would be the TZ variable, then, if defined. Else, the
    system setting for what is "local" time. Ie, the same as the "date"
    command in the CLI as you used.

    Anyway, AFAIK thunderbird would ignore KDE definition of the desktop
    clock, as it is a GTK app, and these tend to use the user variables instead.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4, with Evergreen, x86_64 "Celadon" (Minas Tirith))

  6. #6
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) Clock OSS 12.2 KDE

    ]1:
    [CODE randolph@linux-ppnb:~> date
    Fri Mar 1 11:05:09 UTC 2013
    [/CODE]

    Thanks to all for your replies. The out of sync times of which I refer are in the subject window. Upon further examination of the headers, it seems that TB is latching onto local times of origin of each message and displaying them in the subject window in order of their time zone/origins.

    I sent a message to myself to see that I rec'd it in sync to my PC's clock. Then there are messages that I already received which I displayed according to their dates. The following are delivery dates from 3 message headers displayed after my message.

    2: Delivery dates:
    Fri, 01 Mar 2013 11:16:45 +0000 <-correct time (a message I sent to myself)
    Fri, 01 Mar 2013 06:18:26 -0500
    Fri, 01 Mar 2013 06:28:18 -0500
    Fri, 01 Mar 2013 07:01:57 -0500

    3: Here is the "last" message displayed according to date, although my test message is the last one I actually received:

    Code:
    Return-Path: <2013030114441076561a22136f4231bc2fac5a449a511a-C95VXETQ2XG34@bounces.amazon.com> Delivery-Date: Fri, 01 Mar 2013 09:44:12 -0500 Received-SPF: pass (mxus0: domain of bounces.amazon.com designates 54.240.15.73 as permitted sender) client-ip=54.240.15.73; envelope-from=2013030114441076561a22136f4231bc2fac5a449a511a-C95VXETQ2XG34@bounces.amazon.com; helo=a15-73.smtp-out.amazonses.com; Received: from a15-73.smtp-out.amazonses.com (a15-73.smtp-out.amazonses.com [54.240.15.73])     by mx.perfora.net (node=mxus0) with ESMTP (Nemesis)     id 0LyWZ4-1UqYdm0gUA-015pMU for randolph@h.com; Fri, 01 Mar 2013 09:44:12 -0500 Return-Path: 2013030114441076561a22136f4231bc2fac5a449a511a-C95VXETQ2XG34@bounces.amazon.com Date: Fri, 1 Mar 2013 14:44:10 +0000 From: AmazonLocal Deals <LocalDeals@amazon.com> To: "randolph@h.com" <randolph@h.com> Message-ID: <0000013d266908fc-32e60644-13fe-459d-acd3-cf3ac8596a72-000000@email.amazonses.com> Subject: Challenge Nation 5K Race -- and more great deals MIME-Version: 1.0 Content-Type: multipart/mixed;      boundary="----=_Part_5227093_11972610.1362149050186" Bounces-to: 2013030114441076561a22136f4231bc2fac5a449a511a-C95VXETQ2XG34@bounces.amazon.com X-AMAZON-MAIL-RELAY-TYPE: subscription X-AMAZON-RTE-VERSION: 2.0 X-Original-MessageID: <urn.correios.msg.2013030114441076561a22136f4231bc2fac5a449a511a@1362149050195.massmail-sender-na-6023.iad6.amazon.com> DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/simple;     ; d=amazon.com; t=1362149050;     h=Date:From:To:Message-ID:Subject:MIME-Version:Content-Type;     bh=hlGGJc8Cm95lh1tJxs2bJbn9YEx075eTzQBKs+JEhR8=;     b=ObQdgufr8/tKdNA2XGt5tBQoFKNuRihyH1TDVoNNeWyHDvjVpvtKwCQLUozfsdfU     vL6M0HQtbN4fYwwVuYrYahOqhp1o6/oJfOcF4hafk3MkGR24PY5qtAQzBfvBt1YfOMN     IQiBLvmzHPi0FL/EtRmZNjdD049skmJV6/CW+NOg= X-SES-Outgoing: 54.240.15.73 X-UI-Loop: V01:pVZPYlWKlJM=:+pgXiz0iOfhTes27bnVKzQO26OoXW0n+dRlriIqi39M= X-UI-Junk: AutoNotJunk -999 (UWL);   V01:p6jL26pw:5KUDi0M8Gek+BkzOH5BsLuzKK8s2DgfgHW4ZboP75VZRyyzEyts   3fpZ4PCvpAYHNJi9nJZx3IlcaCHL1uZGR3ctUei+6DPsRXIvRdJK4ArvNE3R+2Nb   7u6EOA12O0Tg/IRW+45y58WFPHASMM00kNgc9MydXtrT9ePhjzvUu8xndmSS69SE   If3Fsw6jnv383h+UaYFy3FPjvLbvpCPVJkqNnyS05j70tS+Tj2bgkiBv+mtXhL/I   y1D/+tUFBafieJUJkNwLpm55F9bPOykqqueyx8MitgFVOivUkqwG3GbBv1PlyM7Z   ZhRy/jdXjoyf3 X-Nemesis-Spam: whitelist
    Is there a setting that allows my subject window to display messages according to my time when I rec'd messages rather than the originating servers of those messages?

    Quote Originally Posted by nrickert View Post


    Maybe the originator of this thread should show:
    1. Output of the "date" command (put in a code box)
    2. The date of a thunderbird message (copy/paste from the display)
    3. The "Date:" header of that message (put in a code box).

    That will help us to see what, if anything, might be wrong.

    To put lines in a code box, select those lines with the mouse, then click the # button.
    Last edited by HealingMindNOS; 01-Mar-2013 at 12:35. Reason: typo

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,781
    Blog Entries
    3

    Default Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) Clock OSS 12.2 KDE

    Quote Originally Posted by HealingMindNOS View Post
    ]Is there a setting that allows my subject window to display messages according to my time when I rec'd messages rather than the originating servers of those messages?
    I don't know of a setting to do that. However, I am not a Thunderbird expert, as I normally use different mail software.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,781
    Blog Entries
    3

    Default Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) Clock OSS 12.2 KDE

    I found a discussion elsewhere that is similar:
    Thunderbird Received Date

    It doesn't really answer your question, and it might be out of date by now. But you might be interested in the discussion.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Thunderbird 17.0.3 Clock not in sync with Desktop (UTC) ClockOSS 12.2 KDE

    On 03/01/2013 08:36 PM, HealingMindNOS wrote:

    >
    > Thanks to all for your replies. The out of sync times of which I refer are in the subject window. Upon further examination of the headers, it seems that TB is latching onto local times of origin of each message and displaying them in the subject window in order of their time zone/origins.


    Not for me. I'm using right now thunderbird 17.0.3, and the time
    displayed is in my local time, not that of the email originator.

    >
    > I sent a message to myself to see that I rec'd it in sync to my PC's clock. Then there are messages that I already received which I displayed according to their dates. The following are delivery dates from 3 message headers displayed after my message.
    >
    > 2: Delivery dates:
    > Fri, 01 Mar 2013 11:16:45 +0000 <-correct time (a message I sent to myself)
    > Fri, 01 Mar 2013 06:18:26 -0500
    > Fri, 01 Mar 2013 06:28:18 -0500
    > Fri, 01 Mar 2013 07:01:57 -0500


    All the times are correct, different time zones. More or less the same
    moment.

    > 3: Here is the "last" message displayed according to date, although my test message is the last one I actually received:
    >


    You are not using the CODE section right, it is unreadable, it is wrapped.

    I had to edit it.

    Code:
    
    > Return-Path: <2013030114441076561a22136f4231bc2fac5a449a511a-C95VXETQ2XG34@bounces.amazon.com>
    >
    > Delivery-Date: Fri, 01 Mar 2013 09:44:12 -0500
    > Received-SPF: pass (mxus0: domain of bounces.amazon.com designates 54.240.15.73 as permitted sender) client-ip=54.240.15.73; envelope-from=2013030114441076561a22136f4231bc2fac5a449a511a-C95VXETQ2XG34@bounces.amazon.com; helo=a15-73.smtp-out.amazonses.com;
    > Received: from a15-73.smtp-out.amazonses.com (a15-73.smtp-out.amazonses.com [54.240.15.73])     by mx.perfora.net (node=mxus0) with ESMTP (Nemesis)     id 0LyWZ4-1UqYdm0gUA-015pMU for randolph@h.com;  Fri, 01 Mar 2013 09:44:12 -0500
    > Return-Path: 2013030114441076561a22136f4231bc2fac5a449a511a-C95VXETQ2XG34@bounces.amazon.com Date: Fri, 1 Mar 2013 14:44:10 +0000
    > From: AmazonLocal Deals <LocalDeals@amazon.com>
    > To: "randolph@h.com" <randolph@h.com>
    If you want to track when an email was sent, check the "Received"
    headers, they track the sites it passed and when. Plus the "Date" header
    which reflects the time it was sent by the sender software.


    --
    Cheers/Saludos
    Carlos E. R. (12.3 Dartmouth test at Minas-Anor

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •