Results 1 to 3 of 3

Thread: Safeboot into Grub level 3

  1. #1

    Default Safeboot into Grub level 3

    I'm having to do a machine rebuild of a W7 and openSuse12.2 and last time I installed Suse it wouldn't boot up on restart (something to do with Nvidia drivers). I ended up going through Grub Level 3 by editing some script in safe mode but can't remember what I did. This allowed me to run zypper patch a couple of times and the system worked fine after that. Can anyone help me out. I found the info I needed on here but can't find the blasted post now.

  2. #2
    Join Date
    Sep 2008
    Location
    Toronto,Canada
    Posts
    549

    Default Re: Safeboot into Grub level 3

    Quote Originally Posted by Devil20 View Post
    I'm having to do a machine rebuild of a W7 and openSuse12.2 and last time I installed Suse it wouldn't boot up on restart (something to do with Nvidia drivers). I ended up going through Grub Level 3 by editing some script in safe mode but can't remember what I did. This allowed me to run zypper patch a couple of times and the system worked fine after that. Can anyone help me out. I found the info I needed on here but can't find the blasted post now.
    you could select to boot in text mode and then run zypper or yast from the terminal to update your packages(hopefully it will fix your video drivers). Or add the nomodeset as a boot parameter which I think it will choose the drivers in a different order(fbdev,vesa,etc) the way I understand it and not going directly to the nvidia mode which are not working initially and hopefully after update the new drivers are booting fine. Other more knowledgeable than me might give you a better explanation, but I think I gave you few ways to attempt it. maybe try it in a virtual machine first?

  3. #3

    Default Re: Safeboot into Grub level 3

    Quote Originally Posted by dmera View Post
    you could select to boot in text mode and then run zypper or yast from the terminal to update your packages(hopefully it will fix your video drivers). Or add the nomodeset as a boot parameter which I think it will choose the drivers in a different order(fbdev,vesa,etc) the way I understand it and not going directly to the nvidia mode which are not working initially and hopefully after update the new drivers are booting fine. Other more knowledgeable than me might give you a better explanation, but I think I gave you few ways to attempt it. maybe try it in a virtual machine first?

    OK. Good idea. I'll give that a go first. Thanks Dmera.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •