Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Setting the clock to local time, not UTC

  1. #1
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    157

    Default Setting the clock to local time, not UTC

    I've been trying to set my clock to display local (New York) time, but it insists on displaying UTC, which is 4 hours earlier. I actually did get the problem corrected at one point, but the clock eventually reverted to UTC again. How can I get it to stick with local time? (I'm running Windows in another partition, so whatever I do should be able to survive a system switch.)

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,213
    Blog Entries
    15

    Default Re: Setting the clock to local time, not UTC

    On Wed 27 Feb 2013 03:56:01 AM CST, pwabrahams wrote:


    I've been trying to set my clock to display local (New York) time, but
    it insists on displaying UTC, which is 4 hours earlier. I actually did
    get the problem corrected at one point, but the clock eventually
    reverted to UTC again. How can I get it to stick with local time?
    (I'm running Windows in another partition, so whatever I do should be
    able to survive a system switch.)


    Hi
    You can uncheck the box via YaST -> System -> Date/Time

    I set my BIOS clock to UTC, you can use the command;
    Code:
    date --utc
    There is a registry tweak for windows which I used to set the time to
    UTC;
    Code:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
    "RealTimeIsUniversal"=dword:00000001
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.28-2.20-desktop
    up 2 days 2:06, 4 users, load average: 0.00, 0.03, 0.05
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


  3. #3

    Default Re: Setting the clock to local time, not UTC

    also, it looks like you can configure network time by clicking change and selecting synchronize with ntp server (with ntp enabled as daemon and utc enabled i believe the computer will keep hardware time correct unless i'm mistaken)

  4. #4
    Join Date
    Sep 2012
    Posts
    5,230

    Default Re: Setting the clock to local time, not UTC

    Quote Originally Posted by pwabrahams View Post
    it insists on displaying UTC
    What is "it" you are talking about? Computer clock itself does not display anything. You should be using some program to display time. So tell which program you use, how you invoke it and its output. Or better copy and paste all of this.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Setting the clock to local time, not UTC

    There is some article about this by jmcdaniels, but I can not find it
    IIRC there is a bug in the setting of the hardware clock to UTC/local time. It does not stick.
    I will try to find the article.

    And indeed, when you multiboot with a Windows system, you should set that setting to "local" (allthough it seems to be possible to cure newer Windows verions into using UTC from the hardweare clock).
    Henk van Velden

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Setting the clock to local time, not UTC

    On 2013-02-27 10:36, hcvv wrote:
    >
    > There is some article about this by jmcdaniels, but I can not find it
    > IIRC there is a bug in the setting of the hardware clock to UTC/local
    > time. It does not stick.
    > I will try to find the article.



    What is UTC or GMT Time & a possible issue with openSUSE 12.2 and its
    solution.


    SDB:Configuring the clock


    > And indeed, when you multiboot with a Windows system, you should set
    > that setting to "local" (allthough it seems to be possible to cure newer
    > Windows verions into using UTC from the hardweare clock).


    Yes, with W7. I recommend that method.


    To the OP: report the time you get with these two commands:

    Code:
    date
    hwclock --debug
    Paste that here inside code tags. Advanced editor, '#' button.
    Posting in
    Code Tags - A Guide


    If the time shown by those commands is correct, your system is correct,
    don't touch it. The problem is with KDE or whatever you use.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Setting the clock to local time, not UTC

    Take a look at this one: https://forums.opensuse.org/blogs/jd...-solution-116/
    Maybe it helps.
    Henk van Velden

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Setting the clock to local time, not UTC

    On 2013-02-27 13:46, hcvv wrote:
    >
    > Take a look at this one: http://tinyurl.com/crw99kg
    > Maybe it helps.


    That's the one I posted ;-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,384

    Default Re: Setting the clock to local time, not UTC

    Quote Originally Posted by robin_listas View Post
    On 2013-02-27 13:46, hcvv wrote:
    >
    > Take a look at this one: What is UTC or GMT Time & a possible issue with openSUSE 12.2 and its solution. - Blogs - openSUSE Forums
    > Maybe it helps.


    That's the one I posted ;-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)
    I searched for it all the time and when I found it I posted it without looking further. But I admit you were first.

    BTW I can not find any Search functionality in the Articles section
    Henk van Velden

  10. #10
    dd NNTP User

    Default Re: Setting the clock to local time, not UTC

    On 02/27/2013 03:06 PM, hcvv wrote:
    >
    > BTW I can not find any Search functionality in the Articles section


    try googles site specifier

    site:forums.opensuse.org/blogs/ [search terms]

    like
    https://www.google.com/search?q=site.../blogs+GMT+UTC

    --
    dd


Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •