Results 1 to 4 of 4

Thread: Updating Wine and debug

  1. #1

    Default Updating Wine and debug

    I am still running 11.4 and don't want to switch to 12.? just yet. When ever questions are asked on winehq they always suggest updating. I've tried several time but can't. I currentlly have wine 1.4 running ok with q4wine driving it. Handy app that as the "screen size" can be preset for each application and windows apps launched from it as well. I only use windows optical design applications so don't really want use virtual machine. There aren't any os optical packages.

    The wine "repository" is Index of /repositories/Emulators:/Wine/openSUSE_11.4 In quotes as Yast wont accept this as a repository. My yast is broken from the desktop but yast2 at the console in su mode brings it up.

    The repo shows 2 wine versions wine-1.5............x86_64.rpm and wine-32bit-1.5..............x86_64.rpm. If I download these and try to install them I find each one needs the other so they fail out on dependencies as the other isn't installed which ever way it's done. The build service shows a tick for 11.4 so they should/maybe ok. Any idea how I get round this?

    I am having a problem with one application under wine that looks to be down to a dll problem etc. There seems to be a wine debug option that can be started by setting an environment variable. No luck so far and I wonder if any one has any experience of using this. I'm after a trace of the windows apps external calls as that should show which call is having problems.

    John
    -

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,872
    Blog Entries
    15

    Default Re: Updating Wine and debug

    On Sun 24 Feb 2013 03:56:02 PM CST, John 82 wrote:


    I am still running 11.4 and don't want to switch to 12.? just yet. When
    ever questions are asked on winehq they always suggest updating. I've
    tried several time but can't. I currentlly have wine 1.4 running ok with
    q4wine driving it. Handy app that as the "screen size" can be preset for
    each application and windows apps launched from it as well. I only use
    windows optical design applications so don't really want use virtual
    machine. There aren't any os optical packages.

    The wine "repository" is 'Index of
    /repositories/Emulators:/Wine/openSUSE_11.4'
    (http://tinyurl.com/6y5mlto) In quotes as Yast wont accept this as a
    repository. My yast is broken from the desktop but yast2 at the console
    in su mode brings it up.

    The repo shows 2 wine versions wine-1.5............x86_64.rpm and
    wine-32bit-1.5..............x86_64.rpm. If I download these and try to
    install them I find each one needs the other so they fail out on
    dependencies as the other isn't installed which ever way it's done. The
    build service shows a tick for 11.4 so they should/maybe ok. Any idea
    how I get round this?

    I am having a problem with one application under wine that looks to be
    down to a dll problem etc. There seems to be a wine debug option that
    can be started by setting an environment variable. No luck so far and I
    wonder if any one has any experience of using this. I'm after a trace of
    the windows apps external calls as that should show which call is having
    problems.

    John
    -


    Hi
    As root user, cd to the directory the files reside in and run;
    Code:
    zypper in <rpm_1_blah.rpm> <rpm_2_blah.rpm>
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.28-2.20-desktop
    up 2:06, 4 users, load average: 0.15, 0.25, 0.34
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


  3. #3

    Default Re: Updating Wine and debug

    Thanks I will try that by placing the rpm's locally. Zypper seems to recognise the place I keep a few rpm's as a depository.

    Anyone any ideas on the wine debug aspect? I have set WINEDEBUG is so many ways and tried obvious ways of getting wine to dump to a file and no signs of any output. I beginning to think that it doesn't actually do it.

    John
    -

  4. #4

    Default Re: Updating Wine and debug

    Quote Originally Posted by John_82 View Post
    Thanks I will try that by placing the rpm's locally. Zypper seems to recognise the place I keep a few rpm's as a depository.

    Anyone any ideas on the wine debug aspect? I have set WINEDEBUG is so many ways and tried obvious ways of getting wine to dump to a file and no signs of any output. I beginning to think that it doesn't actually do it.

    John
    -
    I have solved the tracing problem. There is an entry on this on

    FAQ - The Official Wine Wiki

    John
    -

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •