Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Cannot update the system

  1. #1
    Join Date
    Feb 2011
    Location
    Bangalore, India
    Posts
    103

    Default Cannot update the system

    Hi,

    While I try to update my system.. I keep having issues with the OSS repository. I keep getting the following error

    linux-681c:/home/melvin # zypper update
    Retrieving repository 'OSS_OFFICIAL' metadata [/]
    Download (curl) error for 'http://download.opensuse.org/distribution/12.1/repo/oss/suse/setup/descr/packages.gz':
    Error code: User abort
    Error message: transfer closed with 2974796 bytes remaining to read

    Abort, retry, ignore? [a/r/i/?] (a): r
    Retrieving repository 'OSS_OFFICIAL' metadata [\]
    Download (curl) error for 'http://download.opensuse.org/distribution/12.1/repo/oss/suse/setup/descr/packages.gz':
    Error code: User abort
    Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable

    Abort, retry, ignore? [a/r/i/?] (a): r
    Retrieving repository 'OSS_OFFICIAL' metadata [\]
    Download (curl) error for 'http://download.opensuse.org/distribution/12.1/repo/oss/suse/setup/descr/packages.gz':
    Error code: User abort
    Error message: transfer closed with 3467116 bytes remaining to read

    Abort, retry, ignore? [a/r/i/?] (a): r
    Retrieving repository 'OSS_OFFICIAL' metadata [|]
    Download (curl) error for 'http://download.opensuse.org/distribution/12.1/repo/oss/suse/setup/descr/packages.gz':
    Error code: User abort
    Error message: Failed to connect to 2001:67c:2178:8::13: Network is unreachable
    Note: OSS OFFICI.AL is the alias name I have given to the repository... earlier I couldn't add the OSS repository in YaST > software repositories because the same path kept failing everytime I tried to add the OSS repository

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Cannot update the system

    You have a network problem

    I'm guessing you can navigate the repos in a browser?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Cannot update the system

    On 2011-11-30 11:56, melvinjose wrote:

    >> Retrieving repository 'OSS_OFFICIAL' metadata [\]
    >> Download (curl) error for
    >> 'http://download.opensuse.org/distribution/12.1/repo/oss/suse/setup/descr/packages.gz':
    >> Error code: User abort
    >> Error message: Failed to connect to 2001:67c:2178:8::13: Network is
    >> unreachable


    That's an IPv6 address, most probably you can not use those.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4
    Join Date
    Feb 2011
    Location
    Bangalore, India
    Posts
    103

    Default Re: Cannot update the system

    Quote Originally Posted by caf4926 View Post
    You have a network problem

    I'm guessing you can navigate the repos in a browser?
    All the other repositories got added.. the issue is with the OSS repository....

    However I can access Index of /distribution/12.1/repo/oss/suse/setup/descr in my browser... no issues..

    Is there any setting to be changed with regard to IPv6?

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Cannot update the system

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Feb 2011
    Location
    Bangalore, India
    Posts
    103

    Default Re: Cannot update the system

    This is what I thought I'll have to do after I read robin's post.... woooooooooo.. looks like I'm catching up in my common sense...

  7. #7
    Join Date
    Feb 2011
    Location
    Bangalore, India
    Posts
    103

    Default Re: Cannot update the system

    common sense didn't work. There is a file called packages.gz in the repository. The size is around 7MB. The download fails halfway with this file..

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Cannot update the system

    On 2011-12-04 01:06, melvinjose wrote:
    >
    > common sense didn't work. There is a file called packages.gz in the
    > repository. The size is around 7MB. The download fails halfway with this
    > file..


    Does it print any error?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9
    Join Date
    Jun 2008
    Location
    Managua
    Posts
    400

    Default Re: Cannot update the system

    Hi I am having the same issue with openSUSE 12.2 64 bit when I want to install something yast hang at 'http://download.opensuse.org/distribution/12.1/repo/oss/suse/setup/descr/packages.gz': when opening the software management, it is always with the repo oss in the same file packages.gz, is there a solution for this topic

    I have disabled ipv6

    it is only with the oss repos, if I disable the oss the other repos refresh fine

    thanks

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Cannot update the system

    On 2013-02-22 22:46, Easgs wrote:
    >
    > Hi I am having the same issue with openSUSE 12.2 64 bit when I want to
    > install something yast hang at
    > 'http://download.opensuse.org/distribution/12.1/repo/oss/suse/setup/descr/packages.gz':
    > when opening the software management, it is always with the repo oss in
    > the same file packages.gz, is there a solution for this topic


    Can you manually download that file?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •