If you run calibre 8.5 or 9.15 and you do zypper up, the install of the new version 9.16 will fail with the following error:
Subprocess failed. Error: RPM fallito: warning: /etc/bash_completion.d/calibre saved as /etc/bash_completion.d/calibre.rpmsave
error: unpacking of archive failed on file /usr/share/calibre/fonts/liberation: cpio: rename failed - Is a directory
error: calibre-0.9.16-119.2.x86_64: install failed
error: calibre-0.8.63-1.1.1.x86_64: erase skipped

A bug has been filed (Bug 801390)
It is possible to work around and to install the working package by completely removing all old version packages and then to reinstall the calibre package from the Extra repo.
One user reported it was necessary to remove by hand the directory /usr/share/calibre/fonts/liberation
I did not have to, just removing and installing again did the trick.