Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: Playing an album entirely with amarok or banshee

Hybrid View

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Playing an album entirely with amarok or banshee

    Hi,

    I have my collection of CDs ripped to mp3, and I want to play them a CD
    at a time.

    And I can't.

    Both want to organize by artists or something.

    For example, I have a CD by "Carreras, Domingo and Pavarotti". It is a
    single album, but it appears as 3 in banshee. I can select the three and
    play "them", but they are sorted by artist instead of the track number
    in the album.


    I would like a player that organizes the list by albums and allows me to
    play the selected album in track order, the same as if I insert the CD
    in the reader.

    Can it be done?

    Perhaps ignoring the collection as scanned by those programs and select
    the directory on disk instead... :-?


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: Playing an album entirely with amarok or banshee

    Amarok does this. And correctly with all the CD's I ripped to FLAC or mp3 myself. Just pick the Album view. Things that go wrong f.e.: Concert for Bangla Desh, 2 CDs, both have the same album title, tracks from both CDs numbered 1,2,3,4 etc. In Amarok it shows up as one alblum, track 1,1,2,2,3,3, etc. If you know the concert you'll understand what's wrong with it. I overcome this issue by adding I, II etc to the title using easytag or amarok itself.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: Playing an album entirely with amarok or banshee

    Checked a couple of things, here you go Amarok:

    - Select the Album - Artist view
    - In the sorting, level one, check "Album"
    - In the sorting, level 2 check "None".
    - In the sorting, level 3 check "None".

    Now the albums will show alphabetically and the tenor trio should not be torn apart . My (wild) guess is, that it's sort of the same in Banshee.

    EDIT: I guess you already know about double clicking or dragging an entire album to the playlist.
    Last edited by Knurpht; 18-Feb-2013 at 08:18.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing an album entirely with amarok or banshee

    On 2013-02-18 16:16, Knurpht wrote:
    >
    > Amarok does this. And correctly with all the CD's I ripped to FLAC or
    > mp3 myself. Just pick the Album view.


    And how do I do that?

    I see no "album view" in the view menu or anywhere else. That's the problem.

    Things that go wrong f.e.: Concert
    > for Bangla Desh, 2 CDs, both have the same album title, tracks from both
    > CDs numbered 1,2,3,4 etc. In Amarok it shows up as one alblum, track
    > 1,1,2,2,3,3, etc. If you know the concert you'll understand what's wrong
    > with it. I overcome this issue by adding I, II etc to the title using
    > easytag or amarok itself.


    I corrected that by giving slightly different album name when ripping
    (album 1, album2, etc). Or by numbering the tracks of the second CD at
    an offset. I have version 2.5.0, if that makes a difference.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing an album entirely with amarok or banshee

    On 2013-02-18 16:48, Carlos E. R. wrote:
    > On 2013-02-18 16:16, Knurpht wrote:
    >>
    >> Amarok does this. And correctly with all the CD's I ripped to FLAC or
    >> mp3 myself. Just pick the Album view.

    >
    > And how do I do that?
    >
    > I see no "album view" in the view menu or anywhere else. That's the problem.


    I found it.

    On the left panel, the line that says "search collection". At the right
    side there are three very little icons. First one is "Edit filter".
    Second one is "merged view". Third one is "sorting options". Here,
    select "Album/artist". Choose this one, and the albums appear on the
    left panel.

    Also, select for second and third level "none" and then the track
    tittles appear under the albums.

    It is also possible to select "genre" for first level and "album" for
    the second. But selecting anything for the third level destroys it.

    Finally, I can select full CDs to play!


    (I had this easier years ago with kde amarok).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: Playing an album entirely with amarok or banshee

    Quote Originally Posted by robin_listas View Post
    On 2013-02-18 16:48, Carlos E. R. wrote:
    > On 2013-02-18 16:16, Knurpht wrote:
    >>
    >> Amarok does this. And correctly with all the CD's I ripped to FLAC or
    >> mp3 myself. Just pick the Album view.

    >
    > And how do I do that?
    >
    > I see no "album view" in the view menu or anywhere else. That's the problem.


    I found it.

    On the left panel, the line that says "search collection". At the right
    side there are three very little icons. First one is "Edit filter".
    Second one is "merged view". Third one is "sorting options". Here,
    select "Album/artist". Choose this one, and the albums appear on the
    left panel.

    Also, select for second and third level "none" and then the track
    tittles appear under the albums.

    It is also possible to select "genre" for first level and "album" for
    the second. But selecting anything for the third level destroys it.

    Finally, I can select full CDs to play!


    (I had this easier years ago with kde amarok).

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)
    Took some time here too, I have only the first level used.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing an album entirely with amarok or banshee

    On 2013-02-19 16:36, Knurpht wrote:
    > Took some time here too, I have only the first level used.


    I would like to get it working with banshee as well, because as I use
    XFCE, a gnome application is lighter. But amarok is a very nice application.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  8. #8

    Default Re: Playing an album entirely with amarok or banshee

    On 2013-02-19, Carlos E. R. <robin_listas@no-mx.forums.opensuse.org> wrote:
    > On 2013-02-19 16:36, Knurpht wrote:
    >> Took some time here too, I have only the first level used.

    >
    > I would like to get it working with banshee as well, because as I use
    > XFCE, a gnome application is lighter. But amarok is a very nice application.


    I use Banshee and successfully play albums in the correct track order. If you right-click `Music' and select
    Preferences, under the `Source Specific' tab you can specify the hierarchy (I use Album Artist/Album). Under the tools
    menu, you can `Fix MetaData' which should sort out dependencies associated with multiple artists (although I never have
    had to use this).

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Playing an album entirely with amarok or banshee

    On 2013-02-20 14:36, flymail wrote:
    > On 2013-02-19, Carlos E. R. <> wrote:



    >> I would like to get it working with banshee as well, because as I use
    >> XFCE, a gnome application is lighter. But amarok is a very nice application.

    >
    > I use Banshee and successfully play albums in the correct track order. If you right-click `Music' and select
    > Preferences, under the `Source Specific' tab you can specify the hierarchy (I use Album Artist/Album).


    Ok, done that. The CD I mentioned previously appears as four items, one
    for each artist in the CD. It should be a single entry.

    > Under the tools
    > menu, you can `Fix MetaData' which should sort out dependencies associated with multiple artists (although I never have
    > had to use this).


    Done that, no change.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  10. #10

    Default Re: Playing an album entirely with amarok or banshee

    On 2013-02-20, Carlos E. R. <robin_listas@no-mx.forums.opensuse.org> wrote:
    > Ok, done that. The CD I mentioned previously appears as four items, one
    > for each artist in the CD. It should be a single entry.
    >
    >> Under the tools
    >> menu, you can `Fix MetaData' which should sort out dependencies associated with multiple artists (although I never have
    >> had to use this).

    >
    > Done that, no change.
    >


    Ok now I think I understand the problem you are having. Assuming your collection is in mp3 format, you need to edit the
    tags for Banshee to deal with multiple artists (it doesn't seem to be as smart as Amarok). If you ctrl/shift-select all
    tracks belonging to a single album, and use right-click to edit track information, you can tick the check-box for
    flagging a compilation and harmonise the artist field. If Banshee doesn't correctly order them (I don't possess such an
    album to test this), you can over-rule the track ordering in the same dialog box.

    An alternative solution is the edit the tags using a devoted tag editor such as easytag, which is listed in Packman's
    repo.

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •