Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Updated to KDE 4.10, plasma crashes at login with system tray plugin

  1. #1
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Updated to KDE 4.10, plasma crashes at login with system tray plugin

    Hi,

    I have just updated to KDE 4.10. I love it, except that plasma crashes at login if I have system tray in my panel.
    If I remove the entry with "plugin=systemtray" from ~/.kde4/share/config/plasma-desktop-appletsrc then I can login, and sometimes I can add systemtray back without crash. But in this case logout - login and it again crashes.

    It seems to be this bug: https://bugs.kde.org/show_bug.cgi?id=311751 and I was wondering if other people who upgraded to 4.10 are having the same issue .. because I haven't seen any other thread about this. Is there a workaround?

    Best,
    Joon

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    No
    Not seeing this

    Test a new user. See if it is the same...
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,644
    Blog Entries
    14

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    Not seeing this either. But I've seen some reports on odd systray behaviour, in many cases related to "external" apps, i.e. Skype, Mumble. Do you have any of such?

    IME editing / commenting out single lines from KDE config files doesn't always bring the desired result. If you're sure it's plasma that crashes, remove all the plasm* files from your .kde4/share/config folder whilst not being logged in. That will leave all application settings intact, just restore the desktop appearance to default.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    Quote Originally Posted by Knurpht View Post
    Not seeing this either. But I've seen some reports on odd systray behaviour, in many cases related to "external" apps, i.e. Skype, Mumble. Do you have any of such?
    In fact I have several. Such as autokey, nabi (IME), spideroak. I should try that as well - but I have never had any problems til KDE 4.9 with current setting.

    Quote Originally Posted by Knurpht View Post
    IME editing / commenting out single lines from KDE config files doesn't always bring the desired result. If you're sure it's plasma that crashes, remove all the plasm* files from your .kde4/share/config folder whilst not being logged in. That will leave all application settings intact, just restore the desktop appearance to default.
    I did not comment out single line - I took out the whole

    Code:
    [Containments][1][Applets][34][LayoutInformation]
    Order=6
    
    [Containments][1][Applets][35]
    geometry=2128,4,274,45
    immutability=1
    plugin=systemtray
    zvalue=40
    Sorry for lack of description. Anyway, I just tried restarting plasma with systemtray with
    Code:
    kbuildsycoca4 && kquitapp plasma-desktop && kstart plasma-desktop
    and it restarted normally. So hopefully it was caused by some wrong settings in that contianmetns part in
    Code:
    plasma-desktop-appletsrc
    and it is now fixed. I will post again after I do logout/login later. Thanks!

  5. #5
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    In fact I have several. Such as autokey, nabi (IME), spideroak.
    I have spideroak running here in with KDE upgraded to 4.10 and I do not have any issues, so you can probably rule out spideroak.
    autokey?? I never could get that to run properly. I would like to know your secret on that one.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  6. #6
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    Relogin worked fine. I think when I firstly edited plasma-desktop-appletsrc, I did not properly removed the whole container part. Thanks for your input.

  7. #7
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    Quote Originally Posted by anika200 View Post
    autokey?? I never could get that to run properly. I would like to know your secret on that one.
    I remember there were some repos which had autokey, but now the search only returns source packages: software.opensuse.org:

    But building it from the source is not hard at all. The following is from my note:

    Install dependencies:
    Code:
    $ sudo zypper install python-xlib python-notify python-pyinotify python-qscintilla wmctrl
    1. download autokey source from autokey - Desktop automation utility for Linux and X11 - Google Project Hosting
    2. extract the files
    3. cd to the directory
    4. build and install it:

    Code:
    $ sudo python setup.py install
    It should work. If not, please let me know.

    -Joon

  8. #8
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    Oh actually, there are packages - you are supposed to install the sub packages:

    Code:
    autokey-common
    and one of the
    Code:
    autokey-gtk
    autokey-qt
    depending on your DE. I would use the ones in devel:languagesython repo.

    -Joon

  9. #9
    Join Date
    Sep 2012
    Location
    Maryland, US
    Posts
    623

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    It should work. If not, please let me know.
    Works, Thanks

    The only issue I have now is that it does not recognize Dvorak keyboard layout. You have to put in aho for the shortcut to adr, no big deal though. I am happy with it.
    Kernel: 4.12.14-lp150.12.7-default x86_64 bits:
    64 Desktop: Gnome 3.26.2
    Distro: openSUSE Leap 15.0

  10. #10
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Updated to KDE 4.10, plasma crashes at login with system tray plugin

    Quote Originally Posted by anika200 View Post
    Works, Thanks

    The only issue I have now is that it does not recognize Dvorak keyboard layout. You have to put in aho for the shortcut to adr, no big deal though. I am happy with it.
    Glad it worked out for you.
    It's strange that you have issues with Dvorak though .. I'm using Colemak and mine works as follows:

    abbreviation: if I have .mail for myemail@gmail.com, then when I type .mail in any keyboard layout (qwerty, colemak), it correctly inputs the email address.

    hotkey: The key location changes depending on the layout I'm in. For example, for ctrl+p, I press ctrl+p in colemak, which is r key in qwerty. (Hope you see what I mean - sorry for lack of better description)

    Does it work differently for you?

    -Joon

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •