Results 1 to 8 of 8

Thread: Can't Install a Prog (gEDA) that is in the openSUSE repository

  1. #1

    Default Can't Install a Prog (gEDA) that is in the openSUSE repository

    Hola!

    I'm new to openSUSE after years of Fedora. EDITTOADD: I'm using 12.2

    I am trying to install a design program, and I have had no luck, despite a lot of googling, trying different things and banging my head. What drives me nuts is I know that it is available for openSUSE because it in the openSUSE repo:

    http://download.opensuse.org/reposit...2/x86_64/geda*



    The instructions for the program say: (from geda:suse_rpm_installation [gEDA Project Wiki] )
    Installing Packages from the SuSE Build Service

    1. Start Yast and go to “Change Installation Source”
    2. Add a HTTP source with the following properties:

      • Servername: software.opensuse.org
      • Directory: /download/repositories/science/openSUSE_11.0/ (Choose the directory for your distribution)

    3. Start “Install Software” in Yast, goto “Search” and look for gEDA. All packages appear.
    4. Install the packages as usual.

    For more informations read the generic installation notes of the OpenSuSE Build Service

    You can also browse through repositories first: openSUSE_11.0 repo, openSUSE_11.1 repo. openSUSE_11.2 repo.





    When I try to use yast to install, not only is it not in there, I can't get the repos added.

    Anyone have any ideas?

  2. #2

    Default Re: Can't Install a Prog (gEDA) that is in the openSUSE repository

    On 2013-02-14, Fleaz <Fleaz@no-mx.forums.opensuse.org> wrote:
    >
    > Hola!
    >
    > I'm new to openSUSE after years of Fedora. EDITTOADD: I'm using 12.2
    >
    > I am trying to install a design program, and I have had no luck,
    > despite a lot of googling, trying different things and banging my head.
    > What drives me nuts is I know that it is available for openSUSE because
    > it in the openSUSE repo:
    >
    > http://tinyurl.com/ah9s5uo
    >
    > The instructions for the program say: (from 'geda:suse_rpm_installation
    > [gEDA Project Wiki]'
    > (http://wiki.geda-project.org/geda:suse_rpm_installation) )
    > <SNIP>
    > When I try to use yast to install, not only is it not in there, I can't
    > get the repos added.
    >
    > Anyone have any ideas?


    The wiki-page is clearly out of date because it's only covering openSUSE versions up to 11.2 (which I think is over 3
    years old!).

    Your best bet for installing such packages (I don't know this one) is using openSUSE's own online software repository
    at: http://software.opensuse.org/search?...=openSUSE:12.2 for which I can already see a large number of results
    searching for `geda'. Good luck!

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,854

    Default Re: Can't Install a Prog (gEDA) that is in the openSUSE repository

    That first URL (with the * at the end) does not work.

    I did a search in the software.opensuse.org search page using geda and got this:
    software.opensuse.org: Search
    I do not know which of those you need (not gedafe I assume), but clicked on geda-gaf and then below 12.2 on the "Show unstable packages". There it is shown in the science repo. You can use the 1 Click Install there. It will (if everything goes allright) add the science repo to your repo list and install the package. It will also install any dependancies.

    When this is not what you mean or you get problems, please come back here.
    Henk van Velden

  4. #4

    Default Re: Can't Install a Prog (gEDA) that is in the openSUSE repository

    Thank you for the responses. I finally got the science repository to add to yast. Most likely, I was doing something wrong.

    Still, the posts have taught me a couple of things about openSUSE, so they were not for nothing.

    Thanks again,

    Fleaz

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,854

    Default Re: Can't Install a Prog (gEDA) that is in the openSUSE repository

    You are welcome.

    As an extra, the general idea here is that you shouldn't have to much repos active in your system. And as all 1-click installs potentialy add a repo, this could lead to long lists. Good repo management then involves in going to YaST > Software > Repo management, select those repos (other then the standard OSS, non-OSS, their Updates and Packman) one by one and uncheck the Enable box. Thus they are unharmfull in daily life. If you e.g. need a new version of geda, you enable the repo. install the new verson and disable again. Thus you will not be surprised by automatic new versions, nor by (more important) dependancy problems.
    Henk van Velden

  6. #6
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Can't Install a Prog (gEDA) that is in the openSUSE repository

    Quote Originally Posted by Fleaz View Post
    Hola!

    I'm new to openSUSE after years of Fedora. EDITTOADD: I'm using 12.2

    I am trying to install a design program, and I have had no luck, despite a lot of googling, trying different things and banging my head. What drives me nuts is I know that it is available for openSUSE because it in the openSUSE repo:

    http://download.opensuse.org/reposit...2/x86_64/geda*
    Generally you need to use repos that are of same version as your OS which is 12.2 in your case.
    Find the url for .repo file which in your case is http://download.opensuse.org/reposit...2/science.repo
    Then you can run the following commands in terminal.
    Code:
    su -
    zypper ar -f http://download.opensuse.org/repositories/science/openSUSE_12.2/science.repo
    zypper in geda*
    Checkout :- SDBypper usage 12.2 - openSUSE
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  7. #7

    Default Re: Can't Install a Prog (gEDA) that is in the openSUSE repository

    Quote Originally Posted by Fleaz View Post
    Thank you for the responses. I finally got the science repository to add to yast. Most likely, I was doing something wrong.

    Still, the posts have taught me a couple of things about openSUSE, so they were not for nothing.

    Thanks again,

    Fleaz



    Hello,
    Can you tell me which available version did you download for OpenSuse 12.2, as I cant find the eligible version?

  8. #8
    Join Date
    Jan 2010
    Location
    Russia
    Posts
    100

    Default Re: Can't Install a Prog (gEDA) that is in the openSUSE repository

    Quote Originally Posted by humailnafees View Post
    Hello,
    Can you tell me which available version did you download for OpenSuse 12.2, as I cant find the eligible version?
    openSUSE 12.2 now unsupported (see wiki page for details), but you can branch packages in OBS and build for openSUSE 12.2 target.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •