Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Unusable openSUSE VM after upgrade.

  1. #1
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    275

    Default Unusable openSUSE VM after upgrade.

    Hallo,
    My setup is the following:
    Host: Windows XP 64bit, on a dual Xeon E5130 CPU with 8GB RAM and NVidia Quadro FX3500 card
    Guest: openSUSE 12.2, 32 bit
    Hyper-visor: VMWare Player 5.x
    Guest Conf: 2vCPUs, 3GB RAM
    Problem: Extremely slow KDE.


    I run my openSUSE 12.1 from day 1 of it's release with reasonable speeds under VMWare Player 4 & 5.
    The previous Friday, I decided to upgrade the 12.1 to 12.2 via zypper.
    Everything was fine, except of the speed.
    First I thought that the problem was 4.8, so I upgraded to 4.9, the same version of KDE as I had in 12.1.
    Nothing. When I change windows, I can see how are painted in the screen! It needs over 2 seconds to render the title bar on a full screen application!
    So, I need your help to find what option causes my PC to be that slow. Downgrading from 12.2 to (eg) 12.1 is not possible.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unusable openSUSE VM after upgrade.

    On 2013-02-14 13:46, tpe wrote:
    >
    > Hallo,


    To move a thread, you ask a moderator to move it. You do not post again
    the same thing on a different thread. Now there are two with the same
    questions and some answers.

    Now you have to ask a moderator to merge both threads instead.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,378
    Blog Entries
    2

    Default Re: Unusable openSUSE VM after upgrade.

    Especially if you are running VMs, you should have copied the VM so you're upgrading only a copy without destroying the original. Sounds like you didn't do that so you might be SOL (not all upgrades work as expected). The only thing copying costs you is the amount of disk space being used.

    You're likely in the realm of normal troubleshooting, which means inspecting your syslog (/var/log/mesages.

    Your situation may be further complicated that you are running software that is long past EOL, ie Windows XP (is EOL despite technically not official for a few more months) and VMware 4 and 5.

    Might I recommend getting another hard drive and installing latest openSUSE with QEMU-KVM or Xen on it? Those virt technologies should be able to read your VMware disks. Neither virt tech would be able to use your vmx (VMware config file) so you'd have to re-build the vm configuration.

    TSU

  4. #4
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    275

    Default Απ: Re: Unusable openSUSE VM after upgrade.

    Quote Originally Posted by tsu2 View Post
    Especially if you are running VMs, you should have copied the VM so you're upgrading only a copy without destroying the original. Sounds like you didn't do that so you might be SOL (not all upgrades work as expected). The only thing copying costs you is the amount of disk space being used.

    You're likely in the realm of normal troubleshooting, which means inspecting your syslog (/var/log/mesages.

    Your situation may be further complicated that you are running software that is long past EOL, ie Windows XP (is EOL despite technically not official for a few more months) and VMware 4 and 5.

    Might I recommend getting another hard drive and installing latest openSUSE with QEMU-KVM or Xen on it? Those virt technologies should be able to read your VMware disks. Neither virt tech would be able to use your vmx (VMware config file) so you'd have to re-build the vm configuration.

    TSU
    This is not the case. You missed the "Player", so, software it's up to date. Also, have you considered that I may not have the disk space required for a full VM backup?
    Syslog does not indicate a single issue. Although libvirt is not an option, you gave me an idea.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,378
    Blog Entries
    2

    Default Re: Απ: Re: Unusable openSUSE VM after upgrade.

    Quote Originally Posted by tpe View Post
    This is not the case. You missed the "Player", so, software it's up to date. Also, have you considered that I may not have the disk space required for a full VM backup?
    Syslog does not indicate a single issue. Although libvirt is not an option, you gave me an idea.
    Although I might be wrong, VMware v4/5 long ago reached EOL. If you're running updates, no updates beyond something long ago might have been retrieved.

    Yes, libvirt is not an option running VMware, am saying that if you want to consider running your VMware virtual disks using current, maintained technology then QEMU-KVM and Xen are options. Xen will run on Windows but QEMU-KVM not, if you decide to install Xen on your XP you'll likely need to uninstall VMware first, so recommend you have verified working VMware install media if you want to re-install.

    If whatever you might be trying really does produce results, be sure to post... Always interested in a approaches that work.

    TSU

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unusable openSUSE VM after upgrade.

    On 2013-02-15 19:36, tsu2 wrote:
    >
    > tpe;2527322 Wrote:
    >> This is not the case. You missed the "Player", so, software it's up to
    >> date. Also, have you considered that I may not have the disk space
    >> required for a full VM backup?
    >> Syslog does not indicate a single issue. Although libvirt is not an
    >> option, you gave me an idea.

    >
    > Although I might be wrong, VMware v4/5 long ago reached EOL.


    The current version of vmare player is 5.0.1, it is not EOL.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #7
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,076

    Default Re: Unusable openSUSE VM after upgrade.

    On Fri, 15 Feb 2013 18:36:04 +0000, tsu2 wrote:

    > Although I might be wrong, VMware v4/5 long ago reached EOL.


    This is true of VMware Workstation (which is currently at version 9), but
    VMware Player is versioned separately.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,378
    Blog Entries
    2

    Default Re: Unusable openSUSE VM after upgrade.

    Quote Originally Posted by hendersj View Post
    On Fri, 15 Feb 2013 18:36:04 +0000, tsu2 wrote:

    > Although I might be wrong, VMware v4/5 long ago reached EOL.


    This is true of VMware Workstation (which is currently at version 9), but
    VMware Player is versioned separately.

    Jim
    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at openSUSE Forums FAQ
    Just goes to show how long it's been since I've used Player. Once upon a time its versions were tightly sync-d with Workstation versions. I guess no major release has been necessary since 5. Interesting since VMs have to be converted to work with each new version of Workstation.

    To the OP, I don't know if supported in Player but Snapshots and incremental disks can enable rollbacks without the requirement of a full image's storage. Still, considering how cheap storage is nowadays (even a 360gig external costs less than $50 US) it's dirt cheap insurance for storing full VM disks.

    IMO,
    TSU

    TSU

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unusable openSUSE VM after upgrade.

    On 2013-02-16 23:26, tsu2 wrote:

    > To the OP, I don't know if supported in Player but Snapshots and
    > incremental disks can enable rollbacks without the requirement of a full
    > image's storage.


    Unfortunately no, Player does not support snapshots the last time I
    tried. I miss that feature sorely, the Server version had it.

    > Still, considering how cheap storage is nowadays (even
    > a 360gig external costs less than $50 US) it's dirt cheap insurance for
    > storing full VM disks.


    Some people may not even have that.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  10. #10
    Join Date
    Jul 2008
    Location
    Athens
    Posts
    275

    Default Απ: Unusable openSUSE VM after upgrade.

    We miss the point here, which is the extremely slow speeds.
    Also, a second problem is that after some time the lock screen/screen saver is turned black and I see nothing!
    The only way to login in the VM is to suspend it and resume it.

    So, I start to believe that the problem is the combination of the kernel and the VMWare player.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •