Results 1 to 7 of 7

Thread: Everytime I boot up, "wireless enabled" is unticked. How get this to stick?

  1. #1

    Default Everytime I boot up, "wireless enabled" is unticked. How get this to stick?

    Everytime I boot up, I tick the "enable wirelss" checkbox in the taskbar's wireless interfaces popup. When I do, it automatically connects to my wireless network (which is non-broadcasting). However, on reboot, it's unticked again! How do I get it to stick across reboots?

    I'm using:

    openSUSE 12.2
    KDE 4.8.5
    Kernel: 3.4.11 (64bit)
    8GB RAM (6.5GB free)
    Intel i5 1.7 quad core

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Exclamation Re: Everytime I boot up, "wireless enabled" is unticked. How get this to stick?

    Quote Originally Posted by 6tr6tr View Post
    Everytime I boot up, I tick the "enable wirelss" checkbox in the taskbar's wireless interfaces popup. When I do, it automatically connects to my wireless network (which is non-broadcasting). However, on reboot, it's unticked again! How do I get it to stick across reboots?

    I'm using:

    openSUSE 12.2
    KDE 4.8.5
    Kernel: 3.4.11 (64bit)
    8GB RAM (6.5GB free)
    Intel i5 1.7 quad core
    I am not aware of a Non-Broadcasting network (a wireless network with no SSID) being able to automatically connect using Network Manager. I think you are mistaken that having no SSID makes it safer. Just use some crazy random number+letters, 32 Max Charaters (such as: tyjuASDAIUEFD2W3R98723547Iuy6834) for your SSID, stop hiding it and Network Manager will connect automatically. And only I will know that is your secret name.

    Thank You,
    Last edited by jdmcdaniel3; 14-Feb-2013 at 20:35.
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Everytime I boot up, "wireless enabled" is unticked. How get this to stick?

    Make sure your connection is a system connection
    https://dl.dropbox.com/u/10573557/SU...reless-new.png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,893
    Blog Entries
    3

    Default Re: Everytime I boot up, "wireless enabled" is unticked. How get this to stick?

    Quote Originally Posted by 6tr6tr View Post
    Everytime I boot up, I tick the "enable wirelss" checkbox in the taskbar's wireless interfaces popup. When I do, it automatically connects to my wireless network (which is non-broadcasting). However, on reboot, it's unticked again! How do I get it to stick across reboots?
    I suggest checking whether there is a BIOS setting for this.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5

    Default Re: Everytime I boot up, "wireless enabled" is unticked. How get this to stick?

    Quote Originally Posted by jdmcdaniel3 View Post
    I am not aware of a Non-Broadcasting network (a wireless network with no SSID) being able to automatically connect using Network Manager. I think you are mistaken that having no SSID makes it safer. Just use some crazy random number+letters, 32 Max Charaters (such as: tyjuASDAIUEFD2W3R98723547Iuy6834) for your SSID, stop hiding it and Network Manager will connect automatically. And only I will know that is your secret name.

    Thank You,
    I don't non-broadcast for security, I do it to have less "noise."

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: Everytime I boot up, "wireless enabled" is unticked. How get this to stick?

    Can you tell us more about your hardware? (Laptop model, wireless card). In addition to nrickert's suggestion, I have seen this behaviour reported when 'hp_wmi' and 'acer_wmi' kernel modules were
    present with certain hardware (if applicable)

    FWIW, I came across this old thread, which had discussed a possible udev workaround to enabling wireless, which may be of interest to you or others who come searching.

  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: Everytime I boot up, "wireless enabled" is unticked. How getthis to stick?

    On 02/15/2013 01:56 AM, 6tr6tr wrote:
    >
    > jdmcdaniel3;2527299 Wrote:
    >> I am not aware of a Non-Broadcasting network (a wireless network with no
    >> SSID) being able to automatically connect using Network Manager. I
    >> think you are mistaken that having no SSID makes it safer. Just use
    >> some crazy random number+letters, 32 Max Charaters (such as:
    >> tyjuASDAIUEFD2W3R98723547Iuy6834) for your SSID, stop hiding it and
    >> Network Manager will connect automatically. And only I will know that
    >> is your secret name.
    >>
    >> Thank You,

    >
    > I don't non-broadcast for security, I do it to have less "noise."


    With that approach, you are quite likely getting more interference, if that is
    what you mean my "noise". Most modern APs are setup to use "auto" channel
    selection, and most users will plug them in and go, which means they use that
    feature. By not broadcasting your SSID, you are ensuring that these APs will not
    see your network when it scans, and greatly increasing the probability that it
    will use the same channels as you.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •