Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Date & Time keeps going back to incorrect time on reboot

  1. #1

    Default Date & Time keeps going back to incorrect time on reboot

    In the clock's "Adjust Date & Time" I have checked "set date and time automatically" and have it set to use "Public Time Server (pool.ntp.org)". If I untick this and then retick and hit "OK", it gets the correct time. However, on reboot, the time is again incorrect! It's always 5 hours too slow despite it having the correct timezone.

    How do i get this to stick properly?

    Using:
    openSUSE 12.2
    KDE 4.8.5
    (Nothing but opensuse on this computer. No windows)

  2. #2

    Default Re: Date & Time keeps going back to incorrect time on reboot

    I may have figured it out. There are multiple places to seemingly change the same thing!

    If you right click on the clock (or go into date/time via "Configure Desktop") you'll get to a dialog that lets you pretend to set the time automatically. This does not survive reboot despite asking for root password.

    If instead you go through YAST2->Date Time, you'll see it's set to use the hardware clock. You can then change this to set time automatically (defaults to bigben in dc). I'm hopeful that:

    1. This survives a reboot
    2. Somehow, the openSUSE team (or KDE?) puts this ll into one interface.

  3. #3

    Default Re: Date & Time keeps going back to incorrect time on reboot

    I'm skeptical that this will help, but we'll see. Most of the time when
    I've seen clocks change after reboot it's been a battery problem in the
    motherboard, but usually that also results in time resetting to something
    non-current as well.

    You can test whether or not the entire OS is taking your time changes
    using the 'date' or 'hwclock' commands. The latter must be run as root
    (`sudo /usr/sbin/hwclock`) but the former works as any old user.

    Good luck.

  4. #4

    Default Re: Date & Time keeps going back to incorrect time on reboot

    Quote Originally Posted by ab View Post
    I'm skeptical that this will help, but we'll see. Most of the time when
    I've seen clocks change after reboot it's been a battery problem in the
    motherboard, but usually that also results in time resetting to something
    non-current as well.

    You can test whether or not the entire OS is taking your time changes
    using the 'date' or 'hwclock' commands. The latter must be run as root
    (`sudo /usr/sbin/hwclock`) but the former works as any old user.

    Good luck.
    hwclock command shows the correct time.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Date & Time keeps going back to incorrect time on reboot

    On 2013-02-13 21:26, 6tr6tr wrote:
    > hwclock command shows the correct time.


    If "hwclock --debug" and "date", run as root in a terminal, show the
    correct time, then the clock is correct. Forget what KDE says the time is.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  6. #6

    Default Re: Date & Time keeps going back to incorrect time on reboot

    Quote Originally Posted by robin_listas View Post
    On 2013-02-13 21:26, 6tr6tr wrote:
    > hwclock command shows the correct time.


    If "hwclock --debug" and "date", run as root in a terminal, show the
    correct time, then the clock is correct. Forget what KDE says the time is.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)
    Sorry, I meant after I made the change in YAST2, now hwclock has the right time.

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Date & Time keeps going back to incorrect time on reboot

    On 2013-02-14 03:16, 6tr6tr wrote:
    > Sorry, I meant after I made the change in YAST2, now hwclock has the
    > right time.


    Ah, ok.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Date & Time keeps going back to incorrect time on reboot

    Quote Originally Posted by 6tr6tr View Post
    Sorry, I meant after I made the change in YAST2, now hwclock has the right time.
    Something else to consider here:

    What is UTC or GMT Time & a possible issue with openSUSE 12.2 and its solution: https://forums.opensuse.org/blogs/jd...-solution-116/

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9
    Join Date
    Sep 2012
    Posts
    4,972

    Default Re: Date & Time keeps going back to incorrect time on reboot

    This is a bug in ntp package which is fixed in current ntp update for 12.2: openSUSE-RU-2013:0235-1: moderate: ntp: remove --utc --noadjfile from hw

  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,917
    Blog Entries
    2

    Default Re: Date & Time keeps going back to incorrect time on reboot

    The most common solution to this is...

    1. Unless you're multi-booting with Windows, you need to set your Linux time to "UTC" -- <not> hardware or something else. Even if you think you've solved your problem otherwise, when something like "Daylight Savings Time" comes around, you'll be seeing problems again.

    2. I haven't seen it described anywhere, but after setting your time to be UTC based and the correct time zone, the little clock applet in the KDE panel (Taskbar to you Windows people) may display the UTC time instead of the local time zone, you should then rt-click on the panel clock, click "Digital Clock Settings" then <remove> UTC from the Time Zone setings (you're only removing the display, not altering basic functionality).

    HTH,
    TSU

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •