Results 1 to 10 of 10

Thread: Can't access internet after installing connman

  1. #1

    Default Can't access internet after installing connman

    I dicided to check out Enlightenment (e17) so I installed it from:http://download.opensuse.org/reposit...tenment-17.ymp
    I also installed connman to use the internet applet.
    Everything went fine, it was able to detect my wireless and acces internet.
    The problem is when I logged back to KDE I can connect to my wireless but I can't access the internet,to do that I must start "connmand" from command line.

    I tried removing connman, reinstalling NetworkManager and restart but it didn't work.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Can't access internet after installing connman

    Quote Originally Posted by ntasos View Post
    I dicided to check out Enlightenment (e17) so I installed it from:http://download.opensuse.org/reposit...tenment-17.ymp
    I also installed connman to use the internet applet.
    Everything went fine, it was able to detect my wireless and acces internet.
    The problem is when I logged back to KDE I can connect to my wireless but I can't access the internet,to do that I must start "connmand" from command line.

    I tried removing connman, reinstalling NetworkManager and restart but it didn't work.
    And the oprnSUSE version is????????????????
    Henk van Velden

  3. #3

    Default Re: Can't access internet after installing connman

    Quote Originally Posted by hcvv View Post
    And the oprnSUSE version is????????????????
    12.2 64 bit

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Can't access internet after installing connman

    Did you try ifup ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5

    Default Re: Can't access internet after installing connman

    Quote Originally Posted by vazhavandan View Post
    Did you try ifup ?

    I tried ifup with the same results.


    Ping on Google gives me: "unknown host google.com"


    And here is the nm log:




    Σήμερα 20:27:43 oS-122 NetworkManager[908] <info> Activation (wlan0) starting connection 'E5830-731d'
    Σήμερα 20:27:43 oS-122 NetworkManager[908] <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
    Σήμερα 20:27:43 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
    Σήμερα 20:27:43 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
    Σήμερα 20:27:43 oS-122 NetworkManager[908] <info> (wlan0): set MAC address to 43:44:A6:08:41:19
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <warn> Unknown supplicant state 'interface_disabled'
    Σήμερα 20:27:44 oS-122 NetworkManager[908] (nm-supplicant-interface.c:451):set_state_from_string: runtime check failed: (state > 0)
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Activation (wlan0/wireless): connection 'E5830-731d' has security, and secrets exist. No new secrets needed.
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Config: added 'ssid' value 'E5830-731d'
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Config: added 'scan_ssid' value '1'
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Config: added 'bssid' value '24:db:ac:02:73:1d'
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Config: added 'key_mgmt' value 'WPA-PSK'
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Config: added 'psk' value '<omitted>'
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> Config: set interface ap_scan to 1
    Σήμερα 20:27:44 oS-122 NetworkManager[908] <info> (wlan0): supplicant interface state: disconnected -> scanning
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> (wlan0): supplicant interface state: scanning -> associating
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> (wlan0): supplicant interface state: associating -> associated
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> (wlan0): supplicant interface state: associated -> 4-way handshake
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> (wlan0): supplicant interface state: 4-way handshake -> group handshake
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> (wlan0): supplicant interface state: group handshake -> completed
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful. Connected to wireless network 'E5830-731d'.
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> (wlan0): device state change: config -> ip-config (reason 'none') [50 70 0]
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> Activation (wlan0) Beginning DHCPv4 transaction (timeout in 45 seconds)
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> dhclient started with pid 3420
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
    Σήμερα 20:27:54 oS-122 NetworkManager[908] <info> (wlan0): DHCPv4 state changed nbi -> preinit
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> (wlan0): DHCPv4 state changed preinit -> reboot
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> address 192.168.1.102
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> prefix 24 (255.255.255.0)
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> gateway 192.168.1.1
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> nameserver '192.168.1.1'
    Σήμερα 20:27:59 oS-122 NetworkManager[908] nm_ip4_config_add_nameserver: assertion `nameserver != s' failed
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> nameserver '192.168.1.1'
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 5 of 5 (IPv4 Configure Commit) scheduled...
    Σήμερα 20:27:59 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 5 of 5 (IPv4 Commit) started...
    Σήμερα 20:28:00 oS-122 NetworkManager[908] <info> Clearing nscd hosts cache.
    Σήμερα 20:28:00 oS-122 NetworkManager[908] <info> (wlan0): device state change: ip-config -> activated (reason 'none') [70 100 0]
    Σήμερα 20:28:00 oS-122 NetworkManager[908] <info> Policy set 'E5830-731d' (wlan0) as default for IPv4 routing and DNS.
    Σήμερα 20:28:00 oS-122 NetworkManager[908] <info> Activation (wlan0) successful, device activated.
    Σήμερα 20:28:00 oS-122 NetworkManager[908] <info> Activation (wlan0) Stage 5 of 5 (IPv4 Commit) complete.
    Σήμερα 20:28:00 oS-122 NetworkManager[908] ATTENTION: You have modified /etc/resolv.conf. Leaving it untouched...
    Σήμερα 20:28:00 oS-122 NetworkManager[908] You can find my version in /etc/resolv.conf.netconfig ...
    Σήμερα 20:28:00 oS-122 nm-dispatcher.action Script '/etc/NetworkManager/dispatcher.d/nfs' exited with error status 2.




    So what does "error 2" mean? Is that the problem?

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Can't access internet after installing connman

    Ping on Google gives me: "unknown host google.com"
    This does not point to "no access to the internet", but to a lack of DNS server.

    When you want to test if you can access google.com over the internet, you should try by IP address, then no DNS is involved:
    Code:
    ping -c1 173.194.66.113
    And you can check your DNS server with:
    Code:
    nslookup google.com
    That brings me to the following:
    Please put computer text (like your loging above) between CODE tags (using the # button in the toolbar above the poste editor).
    Also, when possible, you should not tell stories like I cite above, but show the computer facts by copy pasting the prompt the commando and the output and the next prompt, copied/pasted directly between the CODE tags. Example (with a delibarate typo):
    Code:
    henk@boven:~> ping -c1 ggogle.com
    ping: unknown host ggogle.com
    henk@boven:~>
    Henk van Velden

  7. #7

    Default Re: Can't access internet after installing connman

    Sorry about the long log...

    So:

    Code:
    ntasos@oS-122:~> ping -c1 173.194.66.113
    PING 173.194.66.113 (173.194.66.113) 56(84) bytes of data.
    64 bytes from 173.194.66.113: icmp_seq=1 ttl=45 time=3624 ms
    
    --- 173.194.66.113 ping statistics ---
    1 packets transmitted, 1 received, 0% packet loss, time 0ms
    rtt min/avg/max/mdev = 3624.874/3624.874/3624.874/0.000 ms

    Code:
    ntasos@oS-122:~> nslookup google.com
    ;; connection timed out; no servers could be reached
    Obviously I can access the internet (I also just noticed that Ktorrent keeps downloading/uploading regardless of the connman)

    Should I set manually DNS servers?

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Can't access internet after installing connman

    Ok, your connection is there.

    Now the problem is, I do not know anything about that connman you talk about. Not what it is for or why it coul break things in your system (or not). So bear that in mind.

    About the DNS server. Normaly you get a DNS server configured by using DHCP (if you use DHCP) and thus most probably one that your ISP put into your router (often it is the router itself). It is configured in /etc/resolv.conf. Thus you can check yourself what is there. When no nameserver statements are in there, put a line like
    Code:
    nameserver 8.8.8.8
    at he end. That is a public DNS from Google and generaly seen as fast and trustworthy.
    You can also do this using YaST.

    Then check again if you can do the nslookup. Reboot and check again to see if it sticks.

    There remains the question why this connman (or another action you did) removed your reghular NDS server from the configuration.
    Henk van Velden

  9. #9

    Default Re: Can't access internet after installing connman

    Inside resolv.conf was :
    Code:
    # Generated by Connection Manager(connman)
    nameserver 127.0.0.1
    and since I use DHCP ,that was the problem.
    I deleted the contents of resolv.conf ,reconnected with NetworkManager and everything is fixed.
    And a normal nslookup:
    Code:
    ntasos@oS-122:~> nslookup google.com
    Server:         192.168.1.1
    Address:        192.168.1.1#53
    
    Non-authoritative answer:
    Name:   google.com
    Address: 173.194.44.7
    Name:   google.com
    Address: 173.194.44.8
    Name:   google.com
    Address: 173.194.44.9
    Name:   google.com
    Address: 173.194.44.14
    Name:   google.com
    Address: 173.194.44.0
    Name:   google.com
    Address: 173.194.44.1
    Name:   google.com
    Address: 173.194.44.2
    Name:   google.com
    Address: 173.194.44.3
    Name:   google.com
    Address: 173.194.44.4
    Name:   google.com
    Address: 173.194.44.5
    Name:   google.com
    Address: 173.194.44.6
    But at reboot connman puts it's own settings at resolv.conf. So I must figure out how to make it use DHCP(or just uninstall it)

    ConnMan it's just an alternative for NetworkManager. It's supposed to be lightweight and to use as few resources as possible.
    That's probably why Enlightenment use it.

    Thanks for all your help.

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Can't access internet after installing connman

    Quote Originally Posted by ntasos View Post
    Inside resolv.conf was :
    Code:
    # Generated by Connection Manager(connman)
    nameserver 127.0.0.1
    and since I use DHCP ,that was the problem.
    I deleted the contents of resolv.conf ,reconnected with NetworkManager and everything is fixed.
    And a normal nslookup:
    Code:
    ntasos@oS-122:~> nslookup google.com
    Server:         192.168.1.1
    Address:        192.168.1.1#53
    
    Non-authoritative answer:
    Name:   google.com
    Address: 173.194.44.7
    Name:   google.com
    Address: 173.194.44.8
    Name:   google.com
    Address: 173.194.44.9
    Name:   google.com
    Address: 173.194.44.14
    Name:   google.com
    Address: 173.194.44.0
    Name:   google.com
    Address: 173.194.44.1
    Name:   google.com
    Address: 173.194.44.2
    Name:   google.com
    Address: 173.194.44.3
    Name:   google.com
    Address: 173.194.44.4
    Name:   google.com
    Address: 173.194.44.5
    Name:   google.com
    Address: 173.194.44.6
    But at reboot connman puts it's own settings at resolv.conf. So I must figure out how to make it use DHCP(or just uninstall it)

    ConnMan it's just an alternative for NetworkManager. It's supposed to be lightweight and to use as few resources as possible.
    That's probably why Enlightenment use it.

    Thanks for all your help.
    Nice you found it.

    Indeed, DHCP will NOT enter it's DNS server in resolv.conf as it finds that resolv.conf was configured already in another way (that is mostly because sometimes people want to override and DHCP does not want to frustrate this, but in your case it was connman).
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •