Results 1 to 7 of 7

Thread: MP3 decoder missing. How do I get it?

  1. #1

    Default MP3 decoder missing. How do I get it?

    Hello guys. I've just installed k3b but after starting it, it welcomes me with the following warning:

    MP3 Audio Decoder plugin not found.
    K3b could not load or find the MP3 decoder plugin. This means that you will not be able to create Audio CDs from MP3 files. Many Linux distributions do not include MP3 support for legal reasons.

    Solution: To enable MP3 support, please install the MAD MP3 decoding library as well as the K3b MAD MP3 decoder plugin (the latter may already be installed but not functional due to the missing libmad). Some distributions allow installation of MP3 support via an online update tool.
    I've tried looking for the package but I couldn't find it. How can I fix this?

    Thanks in advance for the help,

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: MP3 decoder missing. How do I get it?

    On 2013-02-11 00:16, linmach89 wrote:

    > I've tried looking for the package but I couldn't find it. How can I
    > fix this?


    Do you really need it? Unless you want to “create Audio CDs from MP3
    files”, just ignore the message. If you need that feature, install k3b
    from packman.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: MP3 decoder missing. How do I get it?

    Quote Originally Posted by linmach89 View Post
    Hello guys. I've just installed k3b but after starting it, it welcomes me with the following warning:



    I've tried looking for the package but I couldn't find it. How can I fix this?

    Thanks in advance for the help,
    Of course its no big deal to follow the recommended multimedia update as suggested here: https://forums.opensuse.org/content/...uide-12-2.html, and if you have not read through it, it needs to be the very next thing you do. It will fix such errors as the one you have spoke of here.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4
    Join Date
    Sep 2012
    Location
    Germany
    Posts
    254

    Default AW: MP3 decoder missing. How do I get it?

    Code:
    zypper in k3b-codecs
    zypp it...

  5. #5

    Default Re: AW: MP3 decoder missing. How do I get it?

    Quote Originally Posted by zerum View Post
    Code:
    zypper in k3b-codecs
    Right, I see the package now, but when I try to install it, it says that I need to downgrade k3b to a previous version than the one installed on my machine. My question is, is it safe to do that (downgrade the k3b)?

    Thanks.

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: AW: MP3 decoder missing. How do I get it?

    Quote Originally Posted by linmach89 View Post
    Right, I see the package now, but when I try to install it, it says that I need to downgrade k3b to a previous version than the one installed on my machine. My question is, is it safe to do that (downgrade the k3b)?

    Thanks.
    That is OK to change the version as it only slight and means nothing, but if you allow vendor change in YaST the whole thing can occur without user intervention.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Sep 2012
    Location
    Germany
    Posts
    254

    Default AW: Re: AW: MP3 decoder missing. How do I get it?

    Quote Originally Posted by linmach89 View Post
    Right, I see the package now, but when I try to install it, it says that I need to downgrade k3b to a previous version than the one installed on my machine. My question is, is it safe to do that (downgrade the k3b)?
    It is safe. k3b-codecs is only offered by packman repo. So it wants to install the k3b version from packman. After that you will always see following message during "zypper up":
    Code:
    The following package updates will NOT be installed:
      k3b       2.0.2-22.1.2
      k3b-lang  2.0.2-22.1.2
    But this is ok because the version numbers of k3b are higher in openSUSE-12.2-Oss than in packman. But I believe the version from packman is newer although its version number is lower.
    zypp it...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •