Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Slow boot time with openSUSE 12.2 in a good laptop.

  1. Question Slow boot time with openSUSE 12.2 in a good laptop.

    Hello,

    I installed Opensuse 12.2 in a new laptop two months ago and notice a slow boot time, now finally I am trying to discover why the boot is taking so long to finish. I am still a noob with linux, I am using it since version 11.4 mostly with Xfce desktop.

    I am struggling to find out what is causing the delay and I have also notice that the boot time is increasing over the time. I thought of asking for help in this forum.

    The laptop boot time was like that:

    > systemd-analyze
    Startup finished in 6807ms (kernel) + 38714ms (userspace) = 45522ms

    > systemd-analyze blame
    31171ms systemd-vconsole-setup.service
    30769ms systemd-modules-load.service
    25792ms udev.service
    1665ms SuSEfirewall2_init.service
    1448ms remount-rootfs.service
    1172ms NetworkManager.service
    ...

    In order to collect the log files just for one Boot I usually delete "warn" and "messages" files from "/var/log" before reboot. I tryed to analyze these two files but I couldn't figure out any possible source of problems. As "systemd-analyze" points out long times for the "systemd" services I am guessing that it could be a problem with "systemd" itself.

    I found out that "systemd" has a logging service "systemd-journald" that stores the log at "/run/log/journal/...". To my surprise the "system.journal.log" was more than 120MB big

    After deleting 120+ MB log from /var/log/journal/41ef233e76e7528b304b79b700000697/system.journal.log and rebooting I've got a significant improvement in the boot time.

    # systemd-analyze
    Startup finished in 6684ms (kernel) + 17854ms (userspace) = 24539ms

    # systemd-analyze blame
    13228ms remount-rootfs.service
    12545ms systemd-modules-load.service
    8847ms udev-trigger.service
    3705ms systemd-vconsole-setup.service
    1413ms localnet.service
    850ms cycle.service
    ...

    Big log files slowing down systems is not a novelty, but I still not pleased with the boot time and I still suspecting it is a problem with systemd. That is why I am attaching some log files to this thread and asking for any good soul to analize then point out what could be the the problem.

    logs from /var/log (.log extension added)
    warn.log
    messages.log

    systemd-journal
    systemd-journalctl -a > systemd-journal.log

    dmesg
    dmesg > dmesg.log

    systemd-analyze
    systemd-analyze blame > blame.log
    systemd-analyze plot > plot.svg (print screen: plot.png)



    Systemd configuration
    /etc/systemd/system.conf

    [Manager]
    LogLevel=debug
    LogTarget=syslog-or-kmsg
    SysVConsole=no



    Hardware: Dell
    Model: Latitude E6430
    HD: 7200 RPM
    CPU: Intel Core i7-3520M CPU @ 2.90GHz
    Memory: 2 X 4 GB 1600 MHz DDR3
    Graphics: Intel HD 4000
    Bios: "A07" "10/08/2012"

    System: openSUSE 12.2 (x86_64)

    Desktops:
    Xfce 4.10 - most used
    Gnome 3,4,2.1
    KDE 4.8.5

    Thank you very much
    Best Regards
    Marcilio

  2. #2
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,230

    Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    hi Marcilio

    Similar problems have been encountered on different machines,
    on installs and updates

    pulseaudio seems to be the culprit, it can add up to 40 seconds onto the startup times if disturbed

    possible solution
    search in yast for
    pulse
    and delete all associated pulseaudio packages
    (best to take a note of what's deleted)
    reboot
    then re-install pulseaudio and again reboot

    best of luck

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,490

    Smile Re: Slow boot time with openSUSE 12.2 in a good laptop.

    Why not show us the contents of the file: /etc/systemd/systemd-journald.conf as I have nothing saved at /run/log/journal myself on either of two PC's running openSUSE 12.2 and it makes me think you have enabled this option somehow. While not specifically for openSUSE, I found an article on setting up the journal file here: journald.conf, also have you added any grub 2 kernel load options to increase the sysemd verbosity (http://www.freedesktop.org/software/...nd-line.html)?

    For System File Editing, have a look at this bash script: https://forums.opensuse.org/blogs/jd...rsion-1-00-60/ (For KDE & GNOME)

    For Editing and Viewing info on Grub 2 (Any Desktop): https://forums.opensuse.org/blogs/jd...elp-input-106/

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,305

    Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    here is mine for comparison .

    SUSE Paste

    Code:
    mantis@linux-u7wa:~> systemd-analyze 
    Startup finished in 2857ms (kernel) + 48112ms (userspace) = 50970ms
    My remount-rootfs.service took 1358ms .It seems to be a major difference between your plot and mine

    Also found this https://bugzilla.novell.com/show_bug.cgi?id=781299
    and also https://forums.opensuse.org/english/...s-service.html
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    www.vazhavandan.blogspot.com

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    23,793

    Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    On 2013-02-10 16:16, jdmcdaniel3 wrote:
    >
    > Why not show us the contents of the file:
    > /etc/systemd/systemd-journald.conf as I have nothing saved at
    > /run/log/journal myself on either of two PC's running openSUSE 12.2 and
    > it makes me think you have enabled this option somehow.


    There have been talks of this journal in the factory mail list, I think
    it is going to be enabled for 12.3, and instead syslog disabled.

    I understand that it rotates automatically, and there should be a size
    limit.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  6. #6

    Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    On Sun 10 Feb 2013 04:16:02 PM CST, vazhavandan wrote:


    here is mine for comparison .

    'SUSE Paste' (http://paste.opensuse.org/54165137)


    Code:
    --------------------
    mantis@linux-u7wa:~> systemd-analyze
    Startup finished in 2857ms (kernel) + 48112ms (userspace) = 50970ms

    --------------------


    My remount-rootfs.service took 1358ms .It seems to be a major
    difference between your plot and mine


    Hi
    Seems very slow.... mine is 23ms?
    http://paste.opensuse.org/30305122

    There is a tweak for network services....need to find my notes.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 2 days 19:56, 4 users, load average: 2.07, 2.10, 1.76
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


  7. #7
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,305

    Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Seems very slow.... mine is 23ms?
    SUSE Paste

    There is a tweak for network services....need to find my notes.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 2 days 19:56, 4 users, load average: 2.07, 2.10, 1.76
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile
    Yes. I too noticed that network service is taking its own sweet time :-)

    Probably due to this. what I don't understand is that i use ifup but network manager tries to start and fails everytime when it should not start(i flipped the swicth in yast==>n/w settings ) :-(
    Code:
    $systemctl status NetworkManager.service
    NetworkManager.service - Network Manager
          Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled)
          Active: failed (Result: exit-code) since Sun, 10 Feb 2013 19:54:09 +0530; 2h 33min ago
          CGroup: name=systemd:/system/NetworkManager.service
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    www.vazhavandan.blogspot.com

  8. #8

    Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    On Sun 10 Feb 2013 05:06:01 PM CST, vazhavandan wrote:


    malcolmlewis;2526058 Wrote:
    > Hi
    > Seems very slow.... mine is 23ms?
    > 'SUSE Paste' (http://paste.opensuse.org/30305122)
    >
    > There is a tweak for network services....need to find my notes.


    Yes. I too noticed that network service is taking its own sweet time
    :-)

    Probably due to this. what I don't understand is that i use ifup but
    network manager tries to start and fails everytime when it should not
    start(i flipped the swicth in yast==>n/w settings ) :-(

    Code:
    $systemctl status NetworkManager.service
    NetworkManager.service - Network Manager
    Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled)
    Active: failed (Result: exit-code) since Sun, 10 Feb 2013 19:54:09
    +0530; 2h 33min ago CGroup: name=systemd:/system/NetworkManager.service
    Hi
    Have you tried disabling the service?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 2 days 20:36, 4 users, load average: 0.04, 0.06, 0.43
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile


  9. #9
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,305

    Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Have you tried disabling the service?

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
    up 2 days 20:36, 4 users, load average: 0.04, 0.06, 0.43
    CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile
    Is it available under "Runlevel" editor. If yes what is the name ? i see "network" and "network-remote-fs" I don't want to turn off "ifup" by mistake

    or is this the way to do it ?
    Disables a service to not start during bootup:


    systemctl disable NetworkManager.service
    source:- Systemd - FedoraProject

    i am slightly reluctant to do the second one (CLI). I tend to forget these commands. Hence i tend to use runlevel
    GNOME 3.10.1
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    www.vazhavandan.blogspot.com

  10. Default Re: Slow boot time with openSUSE 12.2 in a good laptop.

    Quote Originally Posted by keellambert View Post
    hi Marcilio

    Similar problems have been encountered on different machines,
    on installs and updates

    pulseaudio seems to be the culprit, it can add up to 40 seconds onto the startup times if disturbed

    possible solution
    search in yast for
    pulse
    and delete all associated pulseaudio packages
    (best to take a note of what's deleted)
    reboot
    then re-install pulseaudio and again reboot

    best of luck
    Thanks for your suggestion, I've tryed

    1) remove pulseaudio (14 packs), and reboot (gain of 2 seconds)
    2) reinstall pulseaudio, and reboot (keeped the gain of 2s)

    Here is my Yast configuration of pulseaudio packages

    Cheers
    Marcilio

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •