Results 1 to 5 of 5

Thread: Errors in OS 12.2 for Android ADT Bundle (not in OS 12.1) missing lib32 stuff, but not in pattern!

  1. #1

    Default Errors in OS 12.2 for Android ADT Bundle (not in OS 12.1) missing lib32 stuff, but not in pattern!

    I installed the ADT bundle on my opensuse 12.1 64-bit and everything works perfectly. However, after installing on my openSUSE 12.2 machine, I'm getting a lot of errors. Errors such as:

    Code:
    aapt: error while loading shared libraries: libz.so.1
    and
    Code:
    Failed to parse the output of adb version libstdc++.so.6
    Apparently the solution should be that I install the lib32 stuff. But two issues:

    1. When I go to YAST/Software, View-Patterns and choose 32-Bit Runtime Environment it says "nothing to do) (Same in zypper). If I select all in that pattern to install, it throws an error

    2. In my older openSUSE 12.1 (which is also 64bit) I do not have that 32-bit runtime pattern installed, yet everything works perfectly. I also don't have a lib32 folder on that computer.

    What could be wrong? Why are the two machines setup similarly yet one works and the other doesn't? Where can I get the lib32 stuff from (I tried searching in YAST/Software for it but did not find it)

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,278
    Blog Entries
    2

    Default Re: Errors in OS 12.2 for Android ADT Bundle (not in OS 12.1) missing lib32 stuff, but not in patter

    Although your Linux host may be 64bit, AFAIK today all android devices are 32bit so you need those libraries. This may be changing over the next year or two.

    HTH,
    TSU

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Errors in OS 12.2 for Android ADT Bundle (not in OS 12.1) missing lib32 stuff, but not in patter

    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  4. #4

    Default Re: Errors in OS 12.2 for Android ADT Bundle (not in OS 12.1) missing lib32 stuff, but not in patter

    Quote Originally Posted by vazhavandan View Post
    Yes, sorry I realized it was in the wrong place and about the wrong title but the forum won't let you delete old threads.

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Errors in OS 12.2 for Android ADT Bundle (not in OS 12.1) missing lib32 stuff, but not in patter

    Quote Originally Posted by 6tr6tr View Post
    Yes, sorry I realized it was in the wrong place and about the wrong title but the forum won't let you delete old threads.
    In future you may Pm the admins, the one called "Global Moderators". They may be willing to help you.
    Admin list
    https://forums.opensuse.org/showgroups.php
    https://en.opensuse.org/openSUSE:Forums_team
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •