Results 1 to 9 of 9

Thread: OpenSuSE wont boot again!

  1. #1

    Default OpenSuSE wont boot again!

    Sorry to sound so negative to start with, but after using OpenSuSE for over 6 years it feels like the number of faults has increased with every release. So yes I have an OpenSuSE 12.2 install that wont boot again, this has happened since I installed some updates. I had a very similar problem with 12.1 where for some reason the OS decided that NFS must start and successfully mount all the shares before the network has been brought up... as you can guess that did not really work well! However the problem is different now (though exhibits the same sort of behavior on boot), I have booted off another CD and disabled NFS but the system still wont boot, it looks like the network configuration has been removed somehow as the machine no longer tries to use DHCP on booting (although it does see the network card). So any advice from someone in the know would be appreciated (I can probally get /var/log/messages.... etc off the machine, but that will have to wait until I can find a USB key), unfortunately I have no idea what updates I installed, YaST told me to install them and I did, but I am typically a bit lazy and will only install updates when there are a few, so it might not be the latest update that caused my problem, but another recent one.

    Thanks for your time.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: OpenSuSE wont boot again!

    Quote Originally Posted by Scott07 View Post
    Sorry to sound so negative to start with, but after using OpenSuSE for over 6 years it feels like the number of faults has increased with every release. So yes I have an OpenSuSE 12.2 install that wont boot again, this has happened since I installed some updates. I had a very similar problem with 12.1 where for some reason the OS decided that NFS must start and successfully mount all the shares before the network has been brought up... as you can guess that did not really work well! However the problem is different now (though exhibits the same sort of behavior on boot), I have booted off another CD and disabled NFS but the system still wont boot, it looks like the network configuration has been removed somehow as the machine no longer tries to use DHCP on booting (although it does see the network card). So any advice from someone in the know would be appreciated (I can probally get /var/log/messages.... etc off the machine, but that will have to wait until I can find a USB key), unfortunately I have no idea what updates I installed, YaST told me to install them and I did, but I am typically a bit lazy and will only install updates when there are a few, so it might not be the latest update that caused my problem, but another recent one.

    Thanks for your time.
    Here are a couple of suggestions that might get you going:

    Re-install Grub2 from DVD Rescue: https://forums.opensuse.org/content/...vd-rescue.html

    Using a LiveCD to take over / repair an installed system: https://forums.opensuse.org/content/...ed-system.html

    I have heard of people having a problem, though most did not have a problem. That means I do not know what specific issue might be the cause, but if you get up and running, we would want to know all about your system, the hardware and the software configuration. Here is one option to get some of that info on hardware:

    H.I. Hardware Information - A Bash script to install and run inxi with default options!: https://forums.opensuse.org/blogs/jd...lt-options-79/

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,149

    Default Re: OpenSuSE wont boot again!

    Sorry to sound so negative to start with, but after using OpenSuSE for over 6 years it feels like the number of faults has increased with every release.
    When you allow yourself starting grumbling, I allow myself the same. All those 6 years the name of the product was/is openSUSE. You can spare yourself a lot of Shift key usage by typing the same and doing it correct.
    Henk van Velden

  4. #4

    Default Re: OpenSuSE wont boot again!

    > Scott07;2527257 Wrote:
    >> Sorry to sound so negative to start with, but after using OpenSuSE for
    >> over 6 years it feels like the number of faults has increased with every
    >> release.


    I've used SuSE/.../openSUSE for over double that time and cannot agree with you on this. While I noticed a number of
    faults creep into the original release of openSUSE 12.1, they were quickly ironed out and I've found openSUSE 12.2
    virtually flawless, so I'm surprised by your assertion. I'm hope jdmcdaniel's suggestions help and that you are able to
    recover your system, but...

    >> So yes I have an OpenSuSE 12.2 install that wont boot again,
    >> this has happened since I installed some updates.
    >> <SNIP>
    >> unfortunately I have no idea what updates I installed, YaST told
    >> me to install them and I did, but I am typically a bit lazy and will
    >> only install updates when there are a few, so it might not be the latest
    >> update that caused my problem, but another recent one.


    ....you can't just blame software (presumably you mean Apper/Packagekit rather than YaST) for installing updates that you
    don't know about even know about even if it caused booting problems! The choice of updates will be depend on the active
    selections on your repository list, which you must take responsibility for. Once I made the mistake of leaving
    openSUSE's Factory repo active, and then my daily 'zypper up' all of a sudden wanted to download 1.04 GB for 1324
    packages until I deselected the repo, when it went down to a much more respectable 1.53 MB for 3 packages. While I've
    have experienced booting problems installing new programs that demanded idiosyncratic dependencies, they've been have
    very rare and usually only after not heeding warnings from the package management.

  5. #5
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: OpenSuSE wont boot again!

    Quote Originally Posted by flymail View Post
    > Scott07;2527257 Wrote:
    >> Sorry to sound so negative to start with, but after using OpenSuSE for
    >> over 6 years it feels like the number of faults has increased with every
    >> release.


    I've used SuSE/.../openSUSE for over double that time and cannot agree with you on this. While I noticed a number of
    faults creep into the original release of openSUSE 12.1, they were quickly ironed out and I've found openSUSE 12.2
    virtually flawless, so I'm surprised by your assertion. I'm hope jdmcdaniel's suggestions help and that you are able to
    recover your system, but...

    >> So yes I have an OpenSuSE 12.2 install that wont boot again,
    >> this has happened since I installed some updates.
    >> <SNIP>
    >> unfortunately I have no idea what updates I installed, YaST told
    >> me to install them and I did, but I am typically a bit lazy and will
    >> only install updates when there are a few, so it might not be the latest
    >> update that caused my problem, but another recent one.


    ....you can't just blame software (presumably you mean Apper/Packagekit rather than YaST) for installing updates that you
    don't know about even know about even if it caused booting problems! The choice of updates will be depend on the active
    selections on your repository list, which you must take responsibility for. Once I made the mistake of leaving
    openSUSE's Factory repo active, and then my daily 'zypper up' all of a sudden wanted to download 1.04 GB for 1324
    packages until I deselected the repo, when it went down to a much more respectable 1.53 MB for 3 packages. While I've
    have experienced booting problems installing new programs that demanded idiosyncratic dependencies, they've been have
    very rare and usually only after not heeding warnings from the package management.
    Hey its OK to be upset. We all want our system to work and can't believe it when they don't. As moderators we are sensitive to negative comments about openSUSE due the great effort put in by so many volunteers, but the fact remains that 1) Software has bugs, 2) Hardware can and does fail 3) Sometime we as users make mistakes that can stop our systems from working. No matter the cause, let us help you get on with using openSUSE as you desire and don't worry about all the rest.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,149

    Default Re: OpenSuSE wont boot again!

    Well, what I think flymail and also myself want to tell the OP in a light tone is hat mixing complaints that should go into a Soapbox thread and and a technical problem that should go into a Get Technical Help Here thread into one is not very productive wherever it is put.

    When such a thing shows up in a Soapbox thread, I will ingore it at all (when I want Soapbox, I go to the local pub) and thus not see the technical problem.

    When it is in a Technical Help forum and it starts with lines of self compassion, I also quit reading and go for a more prommissing thread.

    People who want help often forget that they must advertise and make their particular thread as attractive as possible to the volunteers here. Which means clear technical talk and facts.

    Now, what I write here may be interpreted as a bit harsh. And that is why I (and I guess flymail) tried to soften his first lines a bit. And that of course after we had seen that jmcdaniel3 allready started tackling the technical side. Because indeed, after all, in these Help forums, the most important thing is to try to help
    Henk van Velden

  7. #7

    Default Re: OpenSuSE wont boot again!

    On 2013-02-15, hcvv <hcvv@no-mx.forums.opensuse.org> wrote:
    > Well, what I think flymail and also myself want to tell the OP in a
    > light tone is hat mixing complaints that should go into a Soapbox thread
    > and and a technical problem that should go into a Get Technical Help
    > Here thread into one is not very productive wherever it is put.
    > <SNIP>
    > Now, what I write here may be interpreted as a bit harsh. And that is
    > why I (and I guess flymail) tried to soften his first lines a bit.


    Well, kind of . But I also agree with jdmcdaniel that we can expect those experiencing problems to be reasonably
    `cheesed-off' even if the problem is of their own making since we're only human. While the OP does commence the his post
    with an apology, the initial criticisms of the OP are unwarranted and he/she should have no allusions about this because
    the criticism suggested the mindset is as much part of the problem as the inability to boot per se:

    Since jdmcdaniel had already suggested a way forward to the fix the booting problem, the motivation behind my post was
    to make the OP aware that it's not safe to assume a cavalier approach when dealing with package management and then just
    blame the distro if anything goes wrong. I think technical help can (and perhaps should) go beyond handling specific
    problems, by providing general advice of preventing them from happening again... maybe .

  8. #8
    dd NNTP User

    Default Re: OpenSuSE wont boot again!

    > As moderators we are sensitive to negative
    > comments about openSUSE due the great effort put in by so many
    > volunteers


    i doubt moderators hold a special place when it comes to sensitivity
    to negative comments..

    --
    dd


  9. #9
    Join Date
    Nov 2009
    Location
    Australia
    Posts
    1,391

    Default Re: OpenSuSE wont boot again!

    Quote Originally Posted by Scott07 View Post
    Sorry to sound so negative to start with, but after using OpenSuSE for over 6 years it feels like the number of faults has increased with every release. So yes I have an OpenSuSE 12.2 install that wont boot again, this has happened since I installed some updates. I had a very similar problem with 12.1 where for some reason the OS decided that NFS must start and successfully mount all the shares before the network has been brought up... as you can guess that did not really work well! However the problem is different now (though exhibits the same sort of behavior on boot), I have booted off another CD and disabled NFS but the system still wont boot, it looks like the network configuration has been removed somehow as the machine no longer tries to use DHCP on booting (although it does see the network card). So any advice from someone in the know would be appreciated (I can probally get /var/log/messages.... etc off the machine, but that will have to wait until I can find a USB key), unfortunately I have no idea what updates I installed, YaST told me to install them and I did, but I am typically a bit lazy and will only install updates when there are a few, so it might not be the latest update that caused my problem, but another recent one.

    Thanks for your time.
    What error messages do you get?

    Have you tried booting in safe mode?

    Can you boot to the CLI?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •