Results 1 to 10 of 10

Thread: KDE Tray Icons are jumping

  1. #1

    Default KDE Tray Icons are jumping

    Hello,

    everytime my messenger makes any sound or someone is speaking in Mumble, my icons in the KDE tray are "jumping". I recorded it and uploaded it. See for yourself:

    Does anybody know how to fix this?


    Regards,
    Ctwx

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE Tray Icons are jumping

    Quote Originally Posted by Ctwx View Post
    Hello,

    everytime my messenger makes any sound or someone is speaking in Mumble, my icons in the KDE tray are "jumping". I recorded it and uploaded it. See for yourself:

    Does anybody know how to fix this?


    Regards,
    Ctwx
    Tell me what the non-kde icons do, in particular, the one that flashes red just before you get the disturbance in the force. Icons that are all white are KDE native while those with color are often not native and may have some sort of issue.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: KDE Tray Icons are jumping

    Quote Originally Posted by jdmcdaniel3 View Post
    Tell me what the non-kde icons do, in particular, the one that flashes red just before you get the disturbance in the force. Icons that are all white are KDE native while those with color are often not native and may have some sort of issue.
    The red one with the mouth is Mumble. It's red when I'm speaking. I asked a friend if he could say something. After he starts talking, the icons are starting to jump. The same happens when I get a new message on Pidgin. I think it's related to events when something should popup or so.


    Regards,
    Ctwx

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE Tray Icons are jumping

    Quote Originally Posted by Ctwx View Post
    The red one with the mouth is Mumble. It's red when I'm speaking. I asked a friend if he could say something. After he starts talking, the icons are starting to jump. The same happens when I get a new message on Pidgin. I think it's related to events when something should popup or so.


    Regards,
    Ctwx
    OK, so you are using KDE. What version of openSUSE do you use? Something I would find useful is a short hardware/software listing as the application called inxi can do. I have small bash script that can download and run inxi with its full hardware list. You can download the bash shell script here:

    H.I. Hardware Information - A Bash script to install and run inxi with default options!: https://forums.opensuse.org/blogs/jd...lt-options-79/

    Download hi, run hi, a download of inxi will take place and it will run with a hardware PC listing. Using the advanced message text editor, past the results between code # tags to look like this:

    Code:
               (hi) inxi, the universal, portable, system info script for irc.    
    
    System:    Host: linux-c100 Kernel: 3.7.5-2.10-desktop x86_64 (64 bit) 
               Desktop KDE 4.8.5 Distro: openSUSE 12.2 (x86_64) VERSION = 12.2 CODENAME = Mantis
    Machine:   Mobo: ASUSTeK model: P8Z77-V LE PLUS version: Rev X.0x Bios: American Megatrends version: 0606 date: 11/09/2012
    CPU:       Quad core Intel Core i7-3770K CPU (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) 
               Clock Speeds: 1: 3501.00 MHz 2: 3501.00 MHz 3: 3501.00 MHz 4: 3501.00 MHz 5: 3501.00 MHz 6: 3501.00 MHz 7: 3501.00 MHz 8: 3501.00 MHz
    Graphics:  Card: NVIDIA Device 1183 X.Org: 1.12.3 drivers: nouveau (unloaded: fbdev,nv,vesa) Resolution: 1920x1200@60.0hz 
               GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 0x301) GLX Version: 2.1 Mesa 8.0.4
    Audio:     Card-1: Creative Labs X-Fi Titanium series [EMU20k2] driver: snd_ctxfi Sound: ALSA ver: k3.7.5-2.10-desktop
               Card-2: NVIDIA GK104 HDMI Audio Controller driver: snd_hda_intel
    Network:   Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169 
               IF: eth0 state: up speed: 1000 Mbps duplex: full mac: 10:bf:48:b8:40:e1
    Drives:    HDD Total Size: 8121.6GB (11.0% used) 1: /dev/sda ST1000DM003 1000.2GB 
               2: /dev/sdb SSD2SC120GB1DA16 120.0GB 3: /dev/sdc ST31500541AS 1500.3GB 
               4: /dev/sdd ST32000641AS 2000.4GB 5: /dev/sde ST31500541AS 1500.3GB 
               6: USB /dev/sdf EARX 2000.4GB 
    Partition: ID: / size: 103G used: 31G (30%) fs: rootfs ID: / size: 103G used: 31G (30%) fs: ext4 
               ID: /home size: 252G used: 115G (48%) fs: ext4 ID: swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap 
               ID: swap-2 size: 8.59GB used: 0.00GB (0%) fs: swap 
    Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 36.0 
               Fan Speeds (in rpm): cpu: N/A 
    Info:      Processes: 243 Uptime: 5 days 20:58 Memory: 1286.5/16033.8MB Client: Shell inxi: 1.7.24 
    
               inxi version: Copyright (C) 2008-9 Scott Rogers & Harald Hope ...
    This was taken from my PC and I would like to see the same thing from yours.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: KDE Tray Icons are jumping

    Quote Originally Posted by Ctwx View Post
    Hello,
    everytime my messenger makes any sound or someone is speaking in Mumble, my icons in the KDE tray are "jumping". I recorded it and uploaded it. See for yourself:
    Does anybody know how to fix this?
    Regards,
    Ctwx
    That is a pretty cool feature that KDE has implemented :-)
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  6. #6

    Default Re: KDE Tray Icons are jumping

    Quote Originally Posted by jdmcdaniel3 View Post
    OK, so you are using KDE. What version of openSUSE do you use?
    I use openSUSE 12.2 x64 with KDE 4.9 since the default 4.8 has an Akonadi bug, see: https://forums.opensuse.org/english/...100-usage.html

    My H.I. is:
    Code:
               (hi) inxi, the universal, portable, system info script for irc.    
    
    System:    Host: Tux Kernel: 3.4.11-2.16-desktop x86_64 (64 bit) 
               Desktop KDE 4.9.5 Distro: openSUSE 12.2 (x86_64) VERSION = 12.2 CODENAME = Mantis
    Machine:   Mobo: ASUSTeK model: M4N75TD version: Rev 1.xx Bios: American Megatrends version: 1501 date: 11/22/2010
    CPU:       Quad core AMD Phenom II X4 965 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) 
               Clock Speeds: 1: 3400.00 MHz 2: 3400.00 MHz 3: 3400.00 MHz 4: 3400.00 MHz
    Graphics:  Card: NVIDIA G92 [GeForce 9800 GT] 
               X.Org: 1.12.3 drivers: nvidia (unloaded: fbdev,nv,vesa,nouveau) Resolution: 1280x1024@60.0hz 
               GLX Renderer: GeForce 9800 GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 304.64
    Audio:     Card: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver: snd_hda_intel Sound: ALSA ver: 1.0.25
    Network:   Card: NVIDIA MCP77 Ethernet driver: forcedeth 
               IF: eth0 state: up speed: 100 Mbps duplex: full mac: 48:5b:39:ca:0d:5a
    Drives:    HDD Total Size: 1660.3GB (6.1% used) 1: /dev/sda ST31500341AS 1500.3GB 
               2: /dev/sdb SAMSUNG_SP1614C 160.0GB 
    Partition: ID: / size: 50G used: 5.5G (12%) fs: rootfs ID: / size: 50G used: 5.5G (12%) fs: ext4 
               ID: /boot size: 942M used: 39M (5%) fs: ext2 ID: /home size: 319G used: 90G (30%) fs: ext4 
    Sensors:   Error: You do not have the sensors app installed.
    Info:      Processes: 171 Uptime: 1:05 Memory: 1728.8/8000.1MB Client: Shell inxi: 1.7.24 
    
               inxi version: Copyright (C) 2008-9 Scott Rogers & Harald Hope ...



    Regards,
    Ctwx

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: KDE Tray Icons are jumping

    Quote Originally Posted by Ctwx View Post
    I use openSUSE 12.2 x64 with KDE 4.9 since the default 4.8 has an Akonadi bug, see: https://forums.opensuse.org/english/...100-usage.html

    My H.I. is:
    Code:
               (hi) inxi, the universal, portable, system info script for irc.    
    
    System:    Host: Tux Kernel: 3.4.11-2.16-desktop x86_64 (64 bit) 
               Desktop KDE 4.9.5 Distro: openSUSE 12.2 (x86_64) VERSION = 12.2 CODENAME = Mantis
    Machine:   Mobo: ASUSTeK model: M4N75TD version: Rev 1.xx Bios: American Megatrends version: 1501 date: 11/22/2010
    CPU:       Quad core AMD Phenom II X4 965 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) 
               Clock Speeds: 1: 3400.00 MHz 2: 3400.00 MHz 3: 3400.00 MHz 4: 3400.00 MHz
    Graphics:  Card: NVIDIA G92 [GeForce 9800 GT] 
               X.Org: 1.12.3 drivers: nvidia (unloaded: fbdev,nv,vesa,nouveau) Resolution: 1280x1024@60.0hz 
               GLX Renderer: GeForce 9800 GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 304.64
    Audio:     Card: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver: snd_hda_intel Sound: ALSA ver: 1.0.25
    Network:   Card: NVIDIA MCP77 Ethernet driver: forcedeth 
               IF: eth0 state: up speed: 100 Mbps duplex: full mac: 48:5b:39:ca:0d:5a
    Drives:    HDD Total Size: 1660.3GB (6.1% used) 1: /dev/sda ST31500341AS 1500.3GB 
               2: /dev/sdb SAMSUNG_SP1614C 160.0GB 
    Partition: ID: / size: 50G used: 5.5G (12%) fs: rootfs ID: / size: 50G used: 5.5G (12%) fs: ext4 
               ID: /boot size: 942M used: 39M (5%) fs: ext2 ID: /home size: 319G used: 90G (30%) fs: ext4 
    Sensors:   Error: You do not have the sensors app installed.
    Info:      Processes: 171 Uptime: 1:05 Memory: 1728.8/8000.1MB Client: Shell inxi: 1.7.24 
    
               inxi version: Copyright (C) 2008-9 Scott Rogers & Harald Hope ...



    Regards,
    Ctwx
    I do not see anything in your hardware that would make me think its an issue. So, you have the latest KDE desktop and icons that don't come with KDE. I am thinking its a bug with KDE. One thing you can do in your system tray is to on purpose hide any icon. Why not disable all the ones with color and slowly put them back one at a time to see if the behavior is associated with just one (or all or none) of them. Right click and pick System Tray Settings and then pick Entries on the left and hide all icons with color. You may want to raise a bug report with the latest KDE desktop, but you need to find which, if any, icons are doing this.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8
    dd NNTP User

    Default Re: KDE Tray Icons are jumping

    > everytime my messenger makes any sound or someone is speaking in
    > Mumble, my icons in the KDE tray are "jumping". I recorded it and
    > uploaded it. See for yourself:


    to me it looks like they are not 'jumping' but instead some icons are
    being ADDED to those already present WHEN they become active causing the
    line up to be rearranged, and then the icons are taken out of the lineup
    again when they become inactive ... from what you wrote above i would
    say if you disabled the icons for Mumble and messenger then those icons
    wouldn't be added and then taken out again....and, everything would be
    calm (non-jumping/moving/rearranging)!!

    think about it: do you really need an icon to pop up to tell you that
    you are speaking into Mumble? Or, do you need an icon to pop up to tell
    you the sound you heard came from messenger?

    --
    dd
    http://tinyurl.com/DD-Caveat

  9. #9
    Join Date
    Nov 2010
    Location
    BEIJING,CHINA; SHANGHAI,CHINA
    Posts
    664

    Default 回复: Re: KDE Tray Icons are jumping

    Quote Originally Posted by dd View Post
    > everytime my messenger makes any sound or someone is speaking in
    > Mumble, my icons in the KDE tray are "jumping". I recorded it and
    > uploaded it. See for yourself:


    to me it looks like they are not 'jumping' but instead some icons are
    being ADDED to those already present WHEN they become active causing the
    line up to be rearranged, and then the icons are taken out of the lineup
    again when they become inactive ...
    I agree with this one.

    Indeed, the animation icons in KDE are done by a single svgz format in /usr/share/kde4/apps/desktoptheme/ while gtk are done by different but same size png format in /usr/share/pixmaps.

    Your mumble seems to be a Qt application but it seems to use two separate svg icons for the talking status:

    https://github.com/mumble-voip/mumble/tree/master/icons


    I'm not a KDE dev, I don't know if it can, but due to my knowledge, it's different with most of other applications.

    So maybe you can open an issue on that github page

    Marguerite
    Describe questions in details. Google the 'broken application + error message' first

  10. #10

    Default Re: KDE Tray Icons are jumping

    Thanks for your answers. When I wrote the thread, I didn't had the right words in mind to describe it better. Sorry, I didn't notice that I got answer. Subscripted this thread but didn't get any emails...

    I just hid all icons and guess what? Mumble, Skype and Pidgin are still visible... See here: https://www.dropbox.com/s/023cc3ebgzwh3hb/tray.png
    All icons are set to be invisible.



    Regards,
    Christian

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •