Results 1 to 8 of 8

Thread: Suse 12.2: KDE black screen on loading

  1. #1

    Default Suse 12.2: KDE black screen on loading

    Hi all, need advice what to do.

    I'm not an expert on linux, so if possible give step-by-step hints.

    Just made a new install of Suse 12.2 with KDE 4.8.5. The installation went smooth as usual, loaded the kde nicely.
    BUT after reboot the problem started: the OS loads, comes to the user selection screen without problems; after the KDE splash screen is displayed with 5 icons on green background - and that's it (nothing more). If I then click anywhere it does to BLACK screen with mouse pointer. No desktop.

    I've tried loading under root, it worked also ONLY for the first time. After that it behaves the same way (black screen with mouse pointer in the middle).

    What I've tried so far:
    1) booting with "nomodeset", failsafe - same result
    2) installed nVidia repo - from it latest drivers - run nvidia-xconfig - same result

    at this stage Google became useless for advice ((

    Looking forward for any hints/advice.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Suse 12.2: KDE black screen on loading

    Don't login as root

    Try again as normal user and as you login and the desktop loads
    Try pressing:

    ALT+SHIFT+F12
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Suse 12.2: KDE black screen on loading

    Quote Originally Posted by caf4926 View Post
    Don't login as root

    Try again as normal user and as you login and the desktop loads
    Try pressing:

    ALT+SHIFT+F12
    Thanks for reply, this did not help.

    So far it seems the problem is following:
    I've made a new clean install - everything works.
    If a make any changes to the "desktop settings" then on the next login I'm getting the same story (green background+5 icons) after a while I gets to black screen with a mouse pointer.
    The only way around, is to log in as root - delete user with "home" directory, and then to create new one. Only then it it will get to KDE (but only with default settings)
    Need to mention, my setup: "/" is on ssd with "noatime, discard" options; and /home is on hdd

    Any suggestions what is wrong and how to fix it?

  4. #4
    Join Date
    Jan 2013
    Location
    http://techlorebyigor.blogspot.com/
    Posts
    5

    Default Re: Suse 12.2: KDE black screen on loading

    Quote Originally Posted by skytter13 View Post
    Thanks for reply, this did not help.

    So far it seems the problem is following:
    I've made a new clean install - everything works.
    If a make any changes to the "desktop settings" then on the next login I'm getting the same story (green background+5 icons) after a while I gets to black screen with a mouse pointer.
    The only way around, is to log in as root - delete user with "home" directory, and then to create new one. Only then it it will get to KDE (but only with default settings)
    Need to mention, my setup: "/" is on ssd with "noatime, discard" options; and /home is on hdd

    Any suggestions what is wrong and how to fix it?
    I have the same problem with Linux Mint Nadia KDE after the latest updates. My desktop is gone, icons gone, just black screen, nothing else. Luckily I have Firefox set to autoload on boot. I can get to a terminal by keypresses but other than that...

    I don't have SSD, either, or anything fancy in my system...

  5. #5
    Join Date
    Jan 2013
    Location
    http://techlorebyigor.blogspot.com/
    Posts
    5

    Default Re: Suse 12.2: KDE black screen on loading

    Black screen in KDE in many distros, not just Open Suse

    Check out this thread
    Gentoo Forums :: View topic - kde 4.10 - worst yet

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Suse 12.2: KDE black screen on loading

    Quote Originally Posted by skytter13 View Post
    The only way around, is to log in as root - delete user with "home" directory, and then to create new one. Only then it it will get to KDE (but only with default settings)
    So with a new /home it works. I assume that means there is a setting that you had in /home it does not like. Do you apply a custom KDE desktop theme ? Or possibly you need to disable special desktop effects ?

  7. #7

    Default Re: Suse 12.2: KDE black screen on loading

    Quote Originally Posted by oldcpu View Post
    So with a new /home it works. I assume that means there is a setting that you had in /home it does not like. Do you apply a custom KDE desktop theme ? Or possibly you need to disable special desktop effects ?
    Yes it works, with new /home (or just with new .kde4 directory). Apparently, you are right - there is something wrong recorded in .kde4 as soon as some customization is done (So far I did manage to localize it to few fonts - which hang the KDE4 loading)

    P.S. just made a new clean install on other computer, no ssd - same installation media, same setup - same diagnose. So it seems it KDE problem of some sort.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,037
    Blog Entries
    14

    Default Re: Suse 12.2: KDE black screen on loading

    Quote Originally Posted by skytter13 View Post
    Yes it works, with new /home (or just with new .kde4 directory). Apparently, you are right - there is something wrong recorded in .kde4 as soon as some customization is done (So far I did manage to localize it to few fonts - which hang the KDE4 loading)

    P.S. just made a new clean install on other computer, no ssd - same installation media, same setup - same diagnose. So it seems it KDE problem of some sort.
    No need to remove the entire /home, entire ~/.kde4. This is totally plasma related, so removing the plasm* files from /home/YOURUSERNAME/.kde4/share/config is enough. This should be done, whilst the user not being logged in, i.e. from console or another user's account.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •