Results 1 to 4 of 4

Thread: after system updated, sublime2 can't input chinese

  1. #1

    Default after system updated, sublime2 can't input chinese

    yesterday, i receive the system's push update. after i update the system, i found the sublime text2 can't input chinese, while everything work correctly before.

    i have try several ways, but nothing is work for me.

    OS: openSUSE 12.2
    Sublime text2: build 2217
    Desktop: xfce4
    chinese input method: fctix. (i also try the scim and ibus, but none of them can work)

    any suggestion will be appreciated. thank u in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: after system updated, sublime2 can't input chinese

    I had a quick play and couldn't get ibus to input anything from anthy in sublimetext2.

    Then a quick google revealed that IME input into sublimetext2 is a known and common problem so perhaps you might be better asking your question over in the sublimetext forum. From the posts I saw a lot of users are disgruntled after purchasing sublimetext and then finding that input of foreign characters via an IME in linux does not work.
    Most comments seem to suggest hopefulness at there being a fix in sublimetext3.

    Does the following post help you at all?

    TIPI

  3. #3

    Default Re: after system updated, sublime2 can't input chinese

    Quote Originally Posted by farcusnz View Post
    I had a quick play and couldn't get ibus to input anything from anthy in sublimetext2.

    Then a quick google revealed that IME input into sublimetext2 is a known and common problem so perhaps you might be better asking your question over in the sublimetext forum. From the posts I saw a lot of users are disgruntled after purchasing sublimetext and then finding that input of foreign characters via an IME in linux does not work.
    Most comments seem to suggest hopefulness at there being a fix in sublimetext3.

    Does the following post help you at all?

    TIPI

    Indeed, there are lots of people get into the same trouble, and many articles are relatively old. In fact, two days ago, sublime text2 is completely normal in my pc. It turns bad after the system update. So i guess maybe something updated cause this problem, but i not sure which cause this.
    I hope it can miraculously turn back to work someday after another system update. Looking forward to the sublime text3 can quickly out.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: after system updated, sublime2 can't input chinese

    Quote Originally Posted by exceldream View Post
    Indeed, there are lots of people get into the same trouble, and many articles are relatively old.
    I dunno.
    Most articles I came across were six months old or less.
    The consensus among the articles was that foreign IME input is temperamental at best.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •