Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Problems updating: "The following package updates will NOT be installed:"

  1. #1
    Join Date
    Feb 2013
    Location
    Texas
    Posts
    12

    Exclamation Problems updating: "The following package updates will NOT be installed:"

    My system information:
    Processor (CPU): AMD Turion(tm) II P540 Dual-Core Processor, Speed: 800.00 MHz, Cores: 2, 4GB RAM
    ***
    OS: Linux 3.4.11-2.16-desktop x86_64
    System: openSUSE 12.2 (x86_64)
    KDE: 4.8.5 (4.8.5) "release 2
    ***
    Vendor: ATI Technologies Inc
    Model: ATI Mobility Radeon HD Graphics
    2D driver: radeon
    3D driver: Unknown Gallium (8.0.4)


    ###

    I've bee having issues trying to update some packages, when I try to update'em through zypper the following happens...

    Code:
    myname@mysystem:~> sudo zypper up
    root's password:
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      bind-libs bind-utils cups cups-client cups-libs cups-libs-32bit cyrus-sasl cyrus-sasl-32bit 
      cyrus-sasl-crammd5 cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-plain foomatic-filters 
      ghostscript ghostscript-fonts-other ghostscript-fonts-std ghostscript-x11 gutenprint hplip 
      hplip-hpijs hplip-sane k3b k3b-lang krb5 krb5-32bit libqca2 libqjson0 manufacturer-PPDs 
      OpenPrintingPPDs OpenPrintingPPDs-ghostscript OpenPrintingPPDs-hpijs 
      OpenPrintingPPDs-postscript openssh openssh-askpass parallel-printer-support ppp rsync vpnc 
      w3m 
    
    Nothing to do.
    ~~~~~

    And when I try zypper patch, this happens...

    Code:
    myname@mysystem:~> sudo zypper patch
    root's password:
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following NEW patches are going to be installed:
      openSUSE-2012-577 openSUSE-2012-583 openSUSE-2012-584 openSUSE-2012-657 openSUSE-2012-747 
      openSUSE-2012-803 openSUSE-2012-822 openSUSE-2012-842 
    
    The following packages are going to be REMOVED:
      autoyast2-installation gimp-help-browser gimp-lang gimp-plugins-python gnome-keyring 
      gtk3-immodule-amharic gtk3-immodule-inuktitut libcanberra-gtk3-0 NetworkManager 
    
    9 packages to remove.
    After the operation, 36.7 MiB will be freed.
    Continue? [y/n/?] (y): y
    Removing NetworkManager-0.9.4.0-5.8.1 .................................................[error]
    Removal of (64355)NetworkManager-0.9.4.0-5.8.1.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package NetworkManager-0.9.4.0-5.8.1.x86_64 is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing autoyast2-installation-2.22.5-1.1.1 ..........................................[error]
    Removal of (64406)autoyast2-installation-2.22.5-1.1.1.noarch(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package autoyast2-installation-2.22.5-1.1.1.noarch is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing gimp-help-browser-2.8.0-3.2.2 ................................................[error]
    Removal of (64591)gimp-help-browser-2.8.0-3.2.2.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package gimp-help-browser-2.8.0-3.2.2.x86_64 is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing gimp-lang-2.8.0-3.2.2 ........................................................[error]
    Removal of (64594)gimp-lang-2.8.0-3.2.2.noarch(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package gimp-lang-2.8.0-3.2.2.noarch is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing gimp-plugins-python-2.8.0-3.2.2 ..............................................[error]
    Removal of (64596)gimp-plugins-python-2.8.0-3.2.2.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package gimp-plugins-python-2.8.0-3.2.2.x86_64 is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing gnome-keyring-3.4.1-2.1.2 ....................................................[error]
    Removal of (64614)gnome-keyring-3.4.1-2.1.2.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package gnome-keyring-3.4.1-2.1.2.x86_64 is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing gtk3-immodule-amharic-3.4.4-2.8.2 ............................................[error]
    Removal of (64677)gtk3-immodule-amharic-3.4.4-2.8.2.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package gtk3-immodule-amharic-3.4.4-2.8.2.x86_64 is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing gtk3-immodule-inuktitut-3.4.4-2.8.2 ..........................................[error]
    Removal of (64679)gtk3-immodule-inuktitut-3.4.4-2.8.2.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package gtk3-immodule-inuktitut-3.4.4-2.8.2.x86_64 is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    Removing libcanberra-gtk3-0-0.29-2.3.2 ................................................[error]
    Removal of (65041)libcanberra-gtk3-0-0.29-2.3.2.x86_64(@System) failed:
    Error: Subprocess failed. Error: RPM failed: error: package libcanberra-gtk3-0-0.29-2.3.2.x86_64 is not installed
    
    
    Abort, retry, ignore? [a/r/i] (a): i
    i
    I just did the 'ignore' thing here so you could see that it's the same thing for all packages, but even if I try to do 'retry', nothing happens.

    ~~~

    And even if I follow apper's way, I'm still unable to succed.
    I'll leave some screenshots...
    screenshot 1
    screenshot 2

    It does as if it were actually doing the update, but id doesn't work, and it reloads the "screenshot 1" window again and again, it never succeeds to install/update.

    ~~~

    Any ideas?
    Thank you for your time folks!

  2. #2
    Join Date
    Feb 2013
    Location
    Texas
    Posts
    12

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    nobody really?....

    PLS Help!

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by 5m4rt1 View Post
    nobody really?....

    PLS Help!
    Please be patient. We're all volunteers here, and not always online. Meanwhile, post your configured repos
    Code:
    zypper lr -d
    If you have undertaken package switching (eg Packman repo packages), then the situation you reported in your opening post is normal.

    For example, I get
    Code:
    # zypper up
    Retrieving repository 'Printing' metadata .............................................................[done]
    Building repository 'Printing' cache ..................................................................[done]
    Retrieving repository 'packman-multimedia' metadata ...................................................[done]
    Building repository 'packman-multimedia' cache ........................................................[done]
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      amarok amarok-lang cups-libs-32bit foomatic-filters ghostscript ghostscript-fonts-other 
      ghostscript-fonts-std ghostscript-x11 gstreamer-0_10 gstreamer-0_10-lang gstreamer-0_10-plugin-esd 
      gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base 
      gstreamer-0_10-plugins-base-lang gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-lang 
      gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-ugly-lang gutenprint hplip hplip-hpijs hplip-sane jack 
      k3b kdenlive libavutil51-32bit libdvdcss2 libfreebl3 libfreebl3-32bit libgstapp-0_10-0 
      libgstapp-0_10-0-32bit libgstbasecamerabinsrc-0_10-23 libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 
      libgstinterfaces-0_10-0 libgstphotography-0_10-23 libgstreamer-0_10-0 libgstreamer-0_10-0-32bit 
      libgstsignalprocessor-0_10-23 libgstvdp-0_10-23 libjack0 libmjpegutils-2_0-0 libmlt++3 libmlt5 
      libmlt5-data libmlt5-modules libopencv2_4 libquicktime0 libsoftokn3 libsoftokn3-32bit libsox2 libstrigi0 
      libtag1 libtag1-32bit libtag_c0 libxine2 libxine2-pulse linphone manufacturer-PPDs melt mjpegtools 
      MozillaFirefox MozillaFirefox-branding-openSUSE MozillaFirefox-translations-common 
      mozilla-kde4-integration mozilla-nspr mozilla-nspr-32bit mozilla-nss mozilla-nss-32bit mozilla-nss-certs 
      mozilla-nss-certs-32bit OpenPrintingPPDs OpenPrintingPPDs-ghostscript OpenPrintingPPDs-hpijs 
      OpenPrintingPPDs-postscript parallel-printer-support sox strigi taglib 
    
    The following packages are going to be upgraded:
      cups cups-client cups-libs

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: Problems updating: "The following package updates will NOT be installed:"


  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems updating: "The following package updates will NOT be

    On 2013-02-03 01:46, 5m4rt1 wrote:
    >
    > nobody really?....
    >
    > PLS Help!


    Please be patient. We are volunteers, not paid support. It is also weekend.

    Start by posting the output of "zypper lr --details" inside code tags.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  6. #6
    Join Date
    Feb 2013
    Location
    Texas
    Posts
    12

    Talking Re: Problems updating: "The following package updates will NOT be installed:"

    @deano_ferrari
    I know guys I wasn't trying to be rude, I was just a little rushed, but anyways, Thank you all for your help!
    Code:
    myname@mysystem:~> zypper lr -d
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
     1 | Network12.2               | Network12.2                        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/network/openSUSE_12.2/             |        
     2 | OpenSuse_Printing_Repos   | OpenSuse Printing Repos            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Printing/openSUSE_12.2/            |        
     3 | google-chrome             | google-chrome                      | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                          |        
     4 | google-earth              | google-earth                       | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64                           |        
     5 | kde-extra                 | kde-extra                          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_12.2/          |        
     6 | libdvdcss                 | DVD Repository                     | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/12.2/                                         |        
     7 | openSUSE-12.2-1.6         | openSUSE-12.2-1.6                  | No      | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-STDVDRAM_GT30F_M57A8HD0859,/dev/sr0 |        
     8 | packman                   | Packman repository (openSUSE_12.2) | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_12.2                                   |        
     9 | repo-debug                | openSUSE-12.2-Debug                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/12.2/repo/oss/               |        
    10 | repo-debug-update         | openSUSE-12.2-Update-Debug         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/12.2/                              |        
    11 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/12.2-non-oss/                      |        
    12 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.2/repo/non-oss/                 |                                                                                              
    13 | repo-oss                  | openSUSE-12.2-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/12.2/repo/oss/                     |                                                                                              
    14 | repo-source               | openSUSE-12.2-Source               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/12.2/repo/oss/              |        
    15 | repo-update               | openSUSE-12.2-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.2/                                    |        
    16 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/12.2-non-oss/                            |
    this is what i get.

  7. #7
    Join Date
    Feb 2013
    Location
    Texas
    Posts
    12

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    any suggestions?

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by 5m4rt1 View Post
    any suggestions?
    You have the Printing repo enabled, and so when (cups) updates are available from the Updates repo, they will not be installed, unless you switch the packages, and they are likely to be later version from the printing repo anyway. The same sort of methodology applies to multimedia packages when you have deliberately switched to the Packman packages. It is deliberate.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,392
    Blog Entries
    1

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    Why are you trying to run 'sudo zypper patch'? If you want to update all available packages and preserve package switching, just do
    Code:
    zypper up
    If you want to install just applicable patches, then
    Code:
    zypper up -t patch
    and to check for any unresolved dependencies or package inconsistencies
    Code:
    zypper ve



  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,854
    Blog Entries
    14

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by 5m4rt1 View Post
    any suggestions?
    Hi, welcome

    Please understand that the forums are not some kind of paid support centre. All of us, i.e. all of us, are volunteers trying to help out where and when they can, all this in their spare time. So, take it easy, give those volunteers the time and chance to lookup things. Bumping a thread after 11 minutes is probably gonna do more bad than good. .
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •