My system information:
Processor (CPU): AMD Turion(tm) II P540 Dual-Core Processor, Speed: 800.00 MHz, Cores: 2, 4GB RAM
***
OS: Linux 3.4.11-2.16-desktop x86_64
System: openSUSE 12.2 (x86_64)
KDE: 4.8.5 (4.8.5) "release 2
***
Vendor: ATI Technologies Inc
Model: ATI Mobility Radeon HD Graphics
2D driver: radeon
3D driver: Unknown Gallium (8.0.4)


###

I've bee having issues trying to update some packages, when I try to update'em through zypper the following happens...

Code:
myname@mysystem:~> sudo zypper up
root's password:
Loading repository data...
Reading installed packages...

The following package updates will NOT be installed:
  bind-libs bind-utils cups cups-client cups-libs cups-libs-32bit cyrus-sasl cyrus-sasl-32bit 
  cyrus-sasl-crammd5 cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-plain foomatic-filters 
  ghostscript ghostscript-fonts-other ghostscript-fonts-std ghostscript-x11 gutenprint hplip 
  hplip-hpijs hplip-sane k3b k3b-lang krb5 krb5-32bit libqca2 libqjson0 manufacturer-PPDs 
  OpenPrintingPPDs OpenPrintingPPDs-ghostscript OpenPrintingPPDs-hpijs 
  OpenPrintingPPDs-postscript openssh openssh-askpass parallel-printer-support ppp rsync vpnc 
  w3m 

Nothing to do.
~~~~~

And when I try zypper patch, this happens...

Code:
myname@mysystem:~> sudo zypper patch
root's password:
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW patches are going to be installed:
  openSUSE-2012-577 openSUSE-2012-583 openSUSE-2012-584 openSUSE-2012-657 openSUSE-2012-747 
  openSUSE-2012-803 openSUSE-2012-822 openSUSE-2012-842 

The following packages are going to be REMOVED:
  autoyast2-installation gimp-help-browser gimp-lang gimp-plugins-python gnome-keyring 
  gtk3-immodule-amharic gtk3-immodule-inuktitut libcanberra-gtk3-0 NetworkManager 

9 packages to remove.
After the operation, 36.7 MiB will be freed.
Continue? [y/n/?] (y): y
Removing NetworkManager-0.9.4.0-5.8.1 .................................................[error]
Removal of (64355)NetworkManager-0.9.4.0-5.8.1.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package NetworkManager-0.9.4.0-5.8.1.x86_64 is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing autoyast2-installation-2.22.5-1.1.1 ..........................................[error]
Removal of (64406)autoyast2-installation-2.22.5-1.1.1.noarch(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package autoyast2-installation-2.22.5-1.1.1.noarch is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing gimp-help-browser-2.8.0-3.2.2 ................................................[error]
Removal of (64591)gimp-help-browser-2.8.0-3.2.2.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package gimp-help-browser-2.8.0-3.2.2.x86_64 is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing gimp-lang-2.8.0-3.2.2 ........................................................[error]
Removal of (64594)gimp-lang-2.8.0-3.2.2.noarch(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package gimp-lang-2.8.0-3.2.2.noarch is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing gimp-plugins-python-2.8.0-3.2.2 ..............................................[error]
Removal of (64596)gimp-plugins-python-2.8.0-3.2.2.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package gimp-plugins-python-2.8.0-3.2.2.x86_64 is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing gnome-keyring-3.4.1-2.1.2 ....................................................[error]
Removal of (64614)gnome-keyring-3.4.1-2.1.2.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package gnome-keyring-3.4.1-2.1.2.x86_64 is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing gtk3-immodule-amharic-3.4.4-2.8.2 ............................................[error]
Removal of (64677)gtk3-immodule-amharic-3.4.4-2.8.2.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package gtk3-immodule-amharic-3.4.4-2.8.2.x86_64 is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing gtk3-immodule-inuktitut-3.4.4-2.8.2 ..........................................[error]
Removal of (64679)gtk3-immodule-inuktitut-3.4.4-2.8.2.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package gtk3-immodule-inuktitut-3.4.4-2.8.2.x86_64 is not installed


Abort, retry, ignore? [a/r/i] (a): i
Removing libcanberra-gtk3-0-0.29-2.3.2 ................................................[error]
Removal of (65041)libcanberra-gtk3-0-0.29-2.3.2.x86_64(@System) failed:
Error: Subprocess failed. Error: RPM failed: error: package libcanberra-gtk3-0-0.29-2.3.2.x86_64 is not installed


Abort, retry, ignore? [a/r/i] (a): i
i
I just did the 'ignore' thing here so you could see that it's the same thing for all packages, but even if I try to do 'retry', nothing happens.

~~~

And even if I follow apper's way, I'm still unable to succed.
I'll leave some screenshots...
screenshot 1
screenshot 2

It does as if it were actually doing the update, but id doesn't work, and it reloads the "screenshot 1" window again and again, it never succeeds to install/update.

~~~

Any ideas?
Thank you for your time folks!