Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Problems updating: "The following package updates will NOT be installed:"

  1. #11
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems updating: "The following package updates will NOT be

    On 2013-02-04 06:06, 5m4rt1 wrote:
    >
    > any suggestions?


    You still have not answered my question...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  2. #12
    Join Date
    Sep 2012
    Location
    Germany
    Posts
    254

    Default AW: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by 5m4rt1 View Post
    Code:
    myname@mysystem:~> sudo zypper up
    root's password:
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      bind-libs bind-utils cups cups-client cups-libs cups-libs-32bit cyrus-sasl cyrus-sasl-32bit 
      cyrus-sasl-crammd5 cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-plain foomatic-filters 
      ghostscript ghostscript-fonts-other ghostscript-fonts-std ghostscript-x11 gutenprint hplip 
      hplip-hpijs hplip-sane k3b k3b-lang krb5 krb5-32bit libqca2 libqjson0 manufacturer-PPDs 
      OpenPrintingPPDs OpenPrintingPPDs-ghostscript OpenPrintingPPDs-hpijs 
      OpenPrintingPPDs-postscript openssh openssh-askpass parallel-printer-support ppp rsync vpnc 
      w3m 
    
    Nothing to do.
    Please let zypper be more verbose, so that we can see from which repos the updates come from.
    Code:
    zypper -vv up
    If you agree to a specific vendor change you can allow it with
    Code:
    zypper dup --from $REPO
    zypp it...

  3. #13
    Join Date
    Feb 2013
    Location
    Texas
    Posts
    12

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by Knurpht View Post
    Hi, welcome

    Please understand that the forums are not some kind of paid support centre. All of us, i.e. all of us, are volunteers trying to help out where and when they can, all this in their spare time. So, take it easy, give those volunteers the time and chance to lookup things. Bumping a thread after 11 minutes is probably gonna do more bad than good. .

    I understand it very well, and I appreciate you guys big time for your noble help and time. My self too, my schedule is so tight lately that I burly have time to use my pc.

    Thank you all!

  4. #14
    Join Date
    Feb 2013
    Location
    Texas
    Posts
    12

    Exclamation Re: AW: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by zerum View Post
    Please let zypper be more verbose, so that we can see from which repos the updates come from.

    zypper -vv up
    Verbosity: 2
    Initializing Target
    Checking whether to refresh metadata for Network12.2
    Retrieving: http://download.opensuse.org/reposit...2/repodata/rep[done]
    Checking whether to refresh metadata for OpenSuse Printing Repos
    Retrieving: http://download.opensuse.org/reposit....2/repodata/re[done]
    Checking whether to refresh metadata for google-chrome
    Retrieving: http://dl.google.com/linux/chrome/rp...ata/repomd.xml ....[done]
    Checking whether to refresh metadata for google-earth
    Retrieving: http://dl.google.com/linux/earth/rpm...ata/repomd.xml .....[done]
    Checking whether to refresh metadata for kde-extra
    Retrieving: Index of /repositories/KDE:/Extra/openSUSE_12.2/repodata[done]
    Checking whether to refresh metadata for DVD Repository
    Retrieving: http://opensuse-guide.org/repo/12.2/repodata/repomd.xml ....................[done]
    Checking whether to refresh metadata for Packman repository (openSUSE_12.2)
    Retrieving: http://packman.inode.at/suse/openSUS...ata/repomd.xml .............[done]
    Checking whether to refresh metadata for openSUSE-12.2-Debug
    Retrieving: http://download.opensuse.org/debug/d...po/oss/content ......[done]
    Retrieving: http://download.opensuse.org/debug/d.../media.1/media [done]
    Checking whether to refresh metadata for openSUSE-12.2-Update-Debug
    Retrieving: http://download.opensuse.org/debug/u...ata/repomd.xml .........[done]
    Checking whether to refresh metadata for openSUSE-12.2-Update-Debug-Non-Oss
    Retrieving: http://download.opensuse.org/debug/u...ata/repomd.xml .[done]
    Checking whether to refresh metadata for openSUSE-12.2-Non-Oss
    Retrieving: http://download.opensuse.org/distrib...on-oss/content ........[done]
    Retrieving: http://download.opensuse.org/distrib.../media.1/media ..[done]
    Checking whether to refresh metadata for openSUSE-12.2-Oss
    Retrieving: http://download.opensuse.org/distrib...po/oss/content ............[done]
    Retrieving: http://download.opensuse.org/distrib.../media.1/media ......[done]
    Checking whether to refresh metadata for openSUSE-12.2-Source
    Retrieving: http://download.opensuse.org/source/...po/oss/content .....[done]
    Retrieving: http://download.opensuse.org/source/.../media.1/media[done]
    Checking whether to refresh metadata for openSUSE-12.2-Update
    Retrieving: http://download.opensuse.org/update/...ata/repomd.xml ...............[done]
    Checking whether to refresh metadata for openSUSE-12.2-Update-Non-Oss
    Retrieving: http://download.opensuse.org/update/...ata/repomd.xml .......[done]
    Loading repository data...
    Reading installed packages...
    Force resolution: No

    The following package updates will NOT be installed:
    bind-libs
    9.9.2P1-110.3 x86_64 Network12.2 obs://build.opensuse.org/network
    bind-utils
    9.9.2P1-110.3 x86_64 Network12.2 obs://build.opensuse.org/network
    cups
    1.5.4-109.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    cups-client
    1.5.4-109.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    cups-libs
    1.5.4-109.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    cups-libs-32bit
    1.5.4-109.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    cyrus-sasl
    2.1.25-55.1 x86_64 Network12.2 obs://build.opensuse.org/network
    cyrus-sasl-32bit
    2.1.25-55.1 x86_64 Network12.2 obs://build.opensuse.org/network
    cyrus-sasl-crammd5
    2.1.25-55.1 x86_64 Network12.2 obs://build.opensuse.org/network
    cyrus-sasl-digestmd5
    2.1.25-55.1 x86_64 Network12.2 obs://build.opensuse.org/network
    cyrus-sasl-gssapi
    2.1.25-55.1 x86_64 Network12.2 obs://build.opensuse.org/network
    cyrus-sasl-plain
    2.1.25-55.1 x86_64 Network12.2 obs://build.opensuse.org/network
    foomatic-filters
    4.0.12-19.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    ghostscript
    9.06-33.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    ghostscript-fonts-other
    9.06-14.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    ghostscript-fonts-std
    9.06-14.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    ghostscript-x11
    9.06-33.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    gutenprint
    5.2.9-39.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    hplip
    3.12.11-67.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    hplip-hpijs
    3.12.11-67.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    hplip-sane
    3.12.11-67.1 x86_64 OpenSuse Printing Repos obs://build.opensuse.org/Printing
    k3b
    2.0.2-22.1.2 x86_64 openSUSE-12.2-Oss openSUSE
    k3b-lang
    2.0.2-22.1.2 noarch openSUSE-12.2-Oss openSUSE
    krb5
    1.10.2-95.1 x86_64 Network12.2 obs://build.opensuse.org/network
    krb5-32bit
    1.10.2-95.1 x86_64 Network12.2 obs://build.opensuse.org/network
    libqca2
    2.0.3-27.1 x86_64 Network12.2 obs://build.opensuse.org/network
    libqjson0
    0.8.1-32.2 x86_64 Network12.2 obs://build.opensuse.org/network
    manufacturer-PPDs
    10.2-519.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    OpenPrintingPPDs
    4.0.0-31.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    OpenPrintingPPDs-ghostscript
    4.0.0-31.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    OpenPrintingPPDs-hpijs
    4.0.0-31.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    OpenPrintingPPDs-postscript
    4.0.0-31.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    openssh
    6.1p1-53.2 x86_64 Network12.2 obs://build.opensuse.org/network
    openssh-askpass
    1.2.4.1-4.1 x86_64 Network12.2 obs://build.opensuse.org/network
    parallel-printer-support
    1.00-15.1 noarch OpenSuse Printing Repos obs://build.opensuse.org/Printing
    ppp
    2.4.5-27.1 x86_64 Network12.2 obs://build.opensuse.org/network
    rsync
    3.0.9-39.1 x86_64 Network12.2 obs://build.opensuse.org/network
    vpnc
    0.5.3r517-61.1 x86_64 Network12.2 obs://build.opensuse.org/network
    w3m
    0.5.3-172.1 x86_64 Network12.2 obs://build.opensuse.org/network


    Nothing to do.
    This is the output.

  5. #15
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    You should typically have done this:
    https://dl.dropbox.com/u/10573557/Sw...ckman_12.2.jpg

    After that, don't use zypper patch
    Only:
    Code:
    zypper up
    Or like this: https://dl.dropbox.com/u/10573557/system_update_all.mkv

    If you use zypper up
    You will still see that some packages will not be installed....
    Because the switch is holding them to Packman
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #16
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Problems updating: "The following package updates will NOT be

    On 2013-02-08 04:36, 5m4rt1 wrote:
    > This is the output.


    Unreadable. Please use code tags for printouts and commands. Advanced
    editor, '#' button.
    Posting in
    Code Tags - A Guide


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  7. #17
    Join Date
    Sep 2012
    Location
    Germany
    Posts
    254

    Default AW: Re: AW: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by 5m4rt1 View Post
    This is the output.
    Most packages that zypper does not update come from obs://build.opensuse.org/network and obs://build.opensuse.org/Printing. Have you installed packages from this repos via 1-click-install? Then are this repos enabled and there are newer packages in this repos, but zypper does them not install them because a "zypper up" does not allow a vendor change. Be careful with enabling repos from obs, it can break your system. If you want only one or few packages better download and install them from a local repo or with "zypper in <url-to-package.rpm>". If you are 100% sure you want all updates from specific repos you can run "zypper dup --from $REPO" (for your own risk).
    zypp it...

  8. #18
    Join Date
    Feb 2013
    Location
    Texas
    Posts
    12

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    is there a way I can restore to default my repos list?.... And perhaps go back to its original settings without having to reinstall the whole system?...
    -See, because it is very annoying that I cannot update/upgrade all the packages, but I understand that it is due to conflicts in repos, dependencies of old and new packages and stuff like that.
    I did install few 1-click install programs, but I do not recall what it was specifically (I've install so many things!).

    Thanks again gentlemen.

  9. #19
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,372
    Blog Entries
    1

    Default Re: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by 5m4rt1 View Post
    is there a way I can restore to default my repos list?.... And perhaps go back to its original settings without having to reinstall the whole system?...
    -See, because it is very annoying that I cannot update/upgrade all the packages, but I understand that it is due to conflicts in repos, dependencies of old and new packages and stuff like that.
    I did install few 1-click install programs, but I do not recall what it was specifically (I've install so many things!).

    Thanks again gentlemen.
    Yes, it is possible to go back to the default repos and update with 'zypper dup', but be aware that you then will lose useful multimedia support (via packman multimedia packages and associated restricted codecs).

  10. #20
    Join Date
    Sep 2012
    Location
    Germany
    Posts
    254

    Default AW: Re: Problems updating: "The following package updates will NOT be installed:"

    Quote Originally Posted by 5m4rt1 View Post
    is there a way I can restore to default my repos list?.... And perhaps go back to its original settings without having to reinstall the whole system?...
    This is the default repo list:
    Code:
     1 | repo-debug                | openSUSE-12.2-Debug                | Nein      | Ja            |   99      | NONE     | http://download.opensuse.org/debug/distribution/12.2/repo/oss/      |       
     2 | repo-debug-update         | openSUSE-12.2-Update-Debug         | Nein      | Ja            |   99      | NONE     | http://download.opensuse.org/debug/update/12.2/                     |       
     3 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | Nein      | Ja            |   99      | NONE     | http://download.opensuse.org/debug/update/12.2-non-oss/             |       
     4 | repo-non-oss              | openSUSE-12.2-Non-Oss              | Ja        | Ja            |   99      | yast2    | http://download.opensuse.org/distribution/12.2/repo/non-oss/        |       
     5 | repo-oss                  | openSUSE-12.2-Oss                  | Ja        | Ja            |   99      | yast2    | http://download.opensuse.org/distribution/12.2/repo/oss/            |       
     6 | repo-source               | openSUSE-12.2-Source               | Nein      | Ja            |   99      | NONE     | http://download.opensuse.org/source/distribution/12.2/repo/oss/     |       
     7 | repo-update               | openSUSE-12.2-Update               | Ja        | Ja            |   80      | rpm-md   | http://download.opensuse.org/update/12.2/                           |       
     8 | repo-update-non-oss       | openSUSE-12.2-Update-Non-Oss       | Ja        | Ja            |   80      | rpm-md   | http://download.opensuse.org/update/12.2-non-oss/                   |
    Packman repo is trustworthy and can remain activated.

    Run with the cleaned repo list "zypper dup" and look at the output. I think you will have to delete or downgrade some packages.
    zypp it...

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •