Results 1 to 4 of 4

Thread: LibreOffice writer - Embedded jpegs trashed

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default LibreOffice writer - Embedded jpegs trashed

    I am running LibreOffice 3.5:build-413 on my 12.2./KDE 4.9.5 64 bit desktop.
    It is loaded from the openSUSE 12.2 Update repo, ver 3.5.4.13-1.4.5-x86_64.

    I just encountered an issue opening a text file saved as a docx (need to share it with Windows users).
    On opening, All the embedded jpegs show as "Read-Error".

    This file was OK until recently, but I cannot relate it to a specific update, I just happened to notice it.

    I luckily had a somewhat recent backup that still opens correctly.

    Googling about, I followed a suggestion to open the files with ARK.
    From there, I can see that in fact the embedded jpegs have been trashed, they are now 8B in size, in my recent file but 300K or so in the old(good) file.

    Is this a common, known issue?
    I saw some references in my search that this was related to an issue with auto-save, but they seemed sort of old.

    Wow, this is ugly if it is a new bug.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: LibreOffice writer - Embedded jpegs trashed

    Try upgrading to 3.6.3 from community repos
    I heard there is a problem with OLE objects with older LibreOffice versions
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: LibreOffice writer - Embedded jpegs trashed

    Thanks - adding 'OLE' to my search I found THIS recent thread which I somehow missed first time around.
    I may risk upgrading to LO 3.6.3, although the thread indicates issues with 3.6 as well, perhaps versions earlier than 3.6.3.

    For those who stumble upon this thread and have similar problems:
    If you open the document with ARK, in my case there is a sub-directory in the archive "media" under which the jpegs are stored.
    From looking at the file sizes in my particular case, the jpegs had clearly been trashed. They were jpegs. YRMV.
    ARK_display

    If you use LO to create and edit documents with embedded images, DO SOMETHING !
    Version 3.5.x may destroy your documents!
    Use ark to look at the structure of your documents before you back them up.
    I have a feeling that the error occurred when exiting or perhaps auto-saving(I have seen that in discussion threads).
    Your current copy may already be damaged.
    It appears upgrading to LO 3.6.3 may be the fix, based on comments from others.
    Desk: i7-4790K Leap 15.1(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0
    Lap: HPDV7T i7 Leap 15.0(x86_64)4.12.14-lp151.28.7-default KF5 59.0 Plasma 5.14.4 Qt 5.13.0

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: LibreOffice writer - Embedded jpegs trashed

    @op - The user confirms that upgrading fixes the issue
    backup your files before trying :-)
    https://forums.opensuse.org/english/...ml#post2522661
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •