Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: set sublime text as default

  1. #1

    Default set sublime text as default

    I installed sublime text as an "ubstable package" since it's not available in yast. That might be why I can't set it as the default text editor. When selecting properties for a file it's not available as an option for default applciation.

    How do I set it as the default for certain files?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: set sublime text as default

    Quote Originally Posted by goltoof View Post
    I installed sublime text as an "ubstable package" since it's not available in yast. That might be why I can't set it as the default text editor. When selecting properties for a file it's not available as an option for default applciation.

    How do I set it as the default for certain files?
    It doesn't sound such a wise move
    But are you using kde or gnome?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: set sublime text as default

    Quote Originally Posted by caf4926 View Post
    It doesn't sound such a wise move
    But are you using kde or gnome?
    That could be, but that's all that's available for sublimetext and sublimetext2. If you could recommend a similar application that's more stable I'm all ears.

    I'm using gnome.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: set sublime text as default

    Gnome tweak tool is used to set the fonts
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: set sublime text as default

    Quote Originally Posted by caf4926 View Post
    Gnome tweak tool is used to set the fonts
    sublime text is not a font, it's an application.

  6. #6

    Default Re: set sublime text as default

    Any idea how to set an application as the default application to open a file when it's not showing as an option in the menu?

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: set sublime text as default

    On 2013-01-29 20:06, goltoof wrote:
    >
    > Any idea how to set an application as the default application to open a
    > file when it's not showing as an option in the menu?


    Don't you see an entry to browse files? You should be able to enter the
    binary program there.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  8. #8

    Default Re: set sublime text as default

    You can set the binary file by using the browser.

  9. #9

    Default Re: set sublime text as default

    Is anybody actually paying attention to what I'm saying here??

    I repeat, THERE IS NO OPTION TO SET SUBLIMETEXT AS THE DEFAULT PROGRAM.

    In other words, I can't even see the application available in the menu through the browser to set it as the default for binaries.

    There's got to be another way, but what?

    On a sidenote, I'm also not able to see files when I navigate to certain drives. Is there some permission issue with the application itself? Another thing is it doesn't even show the default icon for the software..

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: set sublime text as default

    Did you consider asking at: Sublime Forum • Index page
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •