Results 1 to 8 of 8

Thread: Configure KDM

  1. #1
    Join Date
    Dec 2011
    Location
    Sampa
    Posts
    45

    Default Configure KDM

    OpenSUSE 12.2 - KDE

    Hi there!

    I am trying to change KDM's login screen (Configure Desktop → Login Screen → Theme). Altough I am able to choose another theme, confirming with root password, I always get back to the default one.

    I furthermore installed successfully some more themes (Get New Themes) but they aren't available in the theme selection.

    Is there any problem with KDM?

    By the way, is it possible to activate a sound file for KDM and not just after entering KDE?

  2. #2
    Join Date
    Mar 2009
    Location
    United States
    Posts
    612

    Default Re: Configure KDM

    I know you can change the KDM theme using yast. Go into yast, go to /etc/sysconfig Editor. Search for kdm and go to the option DISPLAYMANAGER_KDM_THEME. Change the value to the theme you want and click ok. You might need to restart kdm before the theme takes effect (not sure).

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Configure KDM

    On 2013-01-26 20:46, nightwishfan wrote:
    >
    > I know you can change the KDM theme using yast. Go into *yast*, go to
    > */etc/sysconfig Editor*. Search for kdm and go to the option
    > *DISPLAYMANAGER_KDM_THEME*. Change the value to the theme you want and
    > click ok. You might need to restart kdm before the theme takes effect
    > (not sure).


    I remember a thread in the opensuse mail list, IIRC, where he tried that
    and many other things, none worked. You might look there for ideas.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.1 x86_64 "Asparagus" at Telcontar)

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,547

    Default Re: Configure KDM

    Quote Originally Posted by nightwishfan View Post
    I know you can change the KDM theme using yast. Go into yast, go to /etc/sysconfig Editor. Search for kdm and go to the option DISPLAYMANAGER_KDM_THEME. Change the value to the theme you want and click ok. You might need to restart kdm before the theme takes effect (not sure).
    I think what you actually do is go to DISPLAYMANAGER_KDM_THEME and delete openSUSE which will then allow you to configure kdm via KDE (configure desktop)

    I have heard though that doing this breaks other things so it is something you would need to be aware of. I guess the kdm theme is locked down by yast for a reason.

  5. #5
    Join Date
    Jul 2008
    Location
    San Diego, CA
    Posts
    193

    Default Re: Configure KDM

    I remember having a similar problem. Please review my thread; hopefully it's useful.

    https://forums.opensuse.org/english/...dm-config.html

  6. #6
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,164

    Default Re: Configure KDM

    This gets asked quite often here's how it's done:
    1) go to kde-look.org Look under kdm themes find one you like say one called ZXcity
    2) download save the tar.gz
    3)Unpack it in a folder say "my Kde Kdm themes" In this case you'd look for zxcity
    4)As root either c & p or move the folder to /usr/share/kde4/apps/kdm/themes/ after that's done close
    5)Open Yast go to the /etc/sysconfig Editor
    6)Desktop>Display manager>DISPLAYMANAGER_KDM_THEME
    7)Delete the theme in there type in your theme in this case zxcity click the OK's
    Done!
    I'm just a curious cat
    My 64 bit: RADEON RX 570 |CPU AMD - Ryzen 5 1600
    MOTHERBOARD B450M D53H GGABYTE
    Opensuse Tumbleweed Plasma 5

  7. #7
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Configure KDM

    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  8. #8
    Join Date
    Dec 2011
    Location
    Sampa
    Posts
    45

    Default Re: Configure KDM

    Quote Originally Posted by Sagemta View Post
    This gets asked quite often here's how it's done:
    1) go to kde-look.org Look under kdm themes find one you like say one called ZXcity
    2) download save the tar.gz
    3)Unpack it in a folder say "my Kde Kdm themes" In this case you'd look for zxcity
    4)As root either c & p or move the folder to /usr/share/kde4/apps/kdm/themes/ after that's done close
    5)Open Yast go to the /etc/sysconfig Editor
    6)Desktop>Display manager>DISPLAYMANAGER_KDM_THEME
    7)Delete the theme in there type in your theme in this case zxcity click the OK's
    Done!
    Worked out perfectly this way.

    Thanks to all for the DISPLAYMANAGER_KDM_THEME hint...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •