Results 1 to 4 of 4

Thread: configure: error: libgtkhtml3 development version >= 3.8.0 is needed.

  1. #1

    Default configure: error: libgtkhtml3 development version >= 3.8.0 is needed.

    I'm an end-user, not a hobbyist. Trying to install Bibledit Bibledit - Summary [Savannah]. There seems to be no Suse package for Bibledit; so I'm trying to compile it; other than having very little idea of what I'm doing, I'm getting the following error:
    configure: error: libgtkhtml3 development version >= 3.8.0 is needed.

    I installed libgtkhtml dev, but it's 4, is that my problem? Is the sourcecode calling for an older version, or is libgtkhtml3 something different?

    Confused.

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: configure: error: libgtkhtml3 development version >= 3.8.0 isneeded.

    On Wed, 23 Jan 2013 05:26:02 +0000, LanceHaverkamp wrote:

    > I installed libgtkhtml dev, but it's 4, is that my problem? Is the
    > sourcecode calling for an older version, or is libgtkhtml3 something
    > different?


    libgtkhtml3 is different from libgtkhtml.

    Since it's asking for libgtkhtml3, that's the one you need to use.

    You don't mention which version of openSUSE you're using, but on 12.2,
    only 4.0 exists in the standard repositories. If you search
    software.opensuse.org for libgtkhtml and pick the subpackages that are
    listed, you'll find version 3.x in the list for your distribution -
    download that and the -devel package and install, and you should be good
    for that requirement.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3

    Default Re: configure: error: libgtkhtml3 development version >= 3.8.0 isneeded.

    Since it's asking for libgtkhtml3, that's the one you need to use.

    You don't mention which version of openSUSE you're using, but on 12.2,
    only 4.0 exists in the standard repositories. If you search
    software.opensuse.org for libgtkhtml and pick the subpackages that are
    listed, you'll find version 3.x in the list for your distribution -
    download that and the -devel package and install, and you should be good
    for that requirement.
    OK, thanks. I found the libgtkhtml of 3.x, but there is no libgtkhtml-devel there for 3.x.
    Is that somewhere else?

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,645
    Blog Entries
    14

    Default Re: configure: error: libgtkhtml3 development version >= 3.8.0 isneeded.

    Quote Originally Posted by LanceHaverkamp View Post
    OK, thanks. I found the libgtkhtml of 3.x, but there is no libgtkhtml-devel there for 3.x.
    Is that somewhere else?
    That should be in the same repo. If you installed libgtkhtml3, and let being subscribed to that repo checked, you should see it in Yast - Software - Softwaremanagement. If you see no -devel packages at all, hit F7.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •