Results 1 to 5 of 5

Thread: ATI Issues with suse 12.2

  1. #1

    Default ATI Issues with suse 12.2

    I just got a new SSD and felt like doing a complete reinstall. The only thing that gave me trouble, is the only thing that ever gives me trouble, this dang proprietary ati driver.

    Before anyone says it, radeon/radionhd/ati is not an option for me, I want to use my 3 monitors, the only thing that works with this is the proprietary drivers.

    So I have tried the main methods (atiupgrade, makerpm, the repo, and "the hard way"), they all end up with the same result, when I change the catalyst settings and restart, the screen configuration is set properly for 2 of the monitors. All other catalyst settings aren't remembered, dragging windows leaves trails and lags the computer, scrolling is slow, 3d doesnt work, and the xorg logs has fatal warnings.

    So I did some digging,
    None of the following were listed in lsmod: radeon, radeonhd, ati, fglrx, vga
    Which means I have no clue what video driver is actually running.

    /var/log/Xorg.0.log has this to say
    Code:
    [     7.376] (WW) Falling back to old probe method for fglrx
    [     7.390] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
    [     7.443] (WW) fglrx(0): board is an unknown third party board, chipset is supported
    [     7.635] (WW) fglrx(0): ***********************************************************
    [     7.635] (WW) fglrx(0): * DRI initialization failed                               *
    [     7.635] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
    [     7.635] (WW) fglrx(0): * 2D and 3D acceleration disabled                         *
    [     7.635] (WW) fglrx(0): ***********************************************************
    [     7.681] (WW) fglrx(0): Textured Video not supported without DRI enabled.
    Finally "modprobe fglrx" gives me
    Code:
    WARNING: Error inserting amd_iommu_v2 (/lib/modules/3.4.11-2.16-desktop/kernel/drivers/iommu/amd_iommu_v2.ko): No such device
    FATAL: Error inserting fglrx (/lib/modules/3.4.11-2.16-desktop/extra/fglrx.ko): No such device
    Which makes no sense because X was apparently using it when it loaded
    "dmesg | grep fglrx" results in nothing

    "lspci" is
    Code:
    00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
    00:02.0 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
    00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
    00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
    00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
    00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
    00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
    00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
    00:1c.1 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Port 2
    00:1c.2 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 3
    00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
    00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
    00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
    00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
    00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
    00:1f.2 SATA controller: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller
    00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
    02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5430 Series]
    02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
    I can't male heads or tails of this my card should be supported

    Notes: My Card is a Radeon HD 5430
    The computer also has an integrated graphics card but it is not used.
    The three monitor setup, on this graphics card, was working with opensuse 12.2 before the reinstallation, with fglrx, I am not sure which driver version the old installation used

    And yes everything was/is/always will be 64bit

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: ATI Issues with suse 12.2

    Quote Originally Posted by scienceman91 View Post
    I just got a new SSD and felt like doing a complete reinstall. The only thing that gave me trouble, is the only thing that ever gives me trouble, this dang proprietary ati driver.

    Before anyone says it, radeon/radionhd/ati is not an option for me, I want to use my 3 monitors, the only thing that works with this is the proprietary drivers.

    So I have tried the main methods (atiupgrade, makerpm, the repo, and "the hard way"), they all end up with the same result, when I change the catalyst settings and restart, the screen configuration is set properly for 2 of the monitors. All other catalyst settings aren't remembered, dragging windows leaves trails and lags the computer, scrolling is slow, 3d doesnt work, and the xorg logs has fatal warnings.

    So I did some digging,
    None of the following were listed in lsmod: radeon, radeonhd, ati, fglrx, vga
    Which means I have no clue what video driver is actually running.

    /var/log/Xorg.0.log has this to say
    Code:
    [     7.376] (WW) Falling back to old probe method for fglrx
    [     7.390] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
    [     7.443] (WW) fglrx(0): board is an unknown third party board, chipset is supported
    [     7.635] (WW) fglrx(0): ***********************************************************
    [     7.635] (WW) fglrx(0): * DRI initialization failed                               *
    [     7.635] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
    [     7.635] (WW) fglrx(0): * 2D and 3D acceleration disabled                         *
    [     7.635] (WW) fglrx(0): ***********************************************************
    [     7.681] (WW) fglrx(0): Textured Video not supported without DRI enabled.
    Finally "modprobe fglrx" gives me
    Code:
    WARNING: Error inserting amd_iommu_v2 (/lib/modules/3.4.11-2.16-desktop/kernel/drivers/iommu/amd_iommu_v2.ko): No such device
    FATAL: Error inserting fglrx (/lib/modules/3.4.11-2.16-desktop/extra/fglrx.ko): No such device
    Which makes no sense because X was apparently using it when it loaded
    "dmesg | grep fglrx" results in nothing

    "lspci" is
    Code:
    00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
    00:02.0 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
    00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
    00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
    00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
    00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
    00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
    00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
    00:1c.1 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Port 2
    00:1c.2 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 3
    00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
    00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
    00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
    00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
    00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
    00:1f.2 SATA controller: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller
    00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
    02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Manhattan [Mobility Radeon HD 5430 Series]
    02:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series]
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
    I can't male heads or tails of this my card should be supported

    Notes: My Card is a Radeon HD 5430
    The computer also has an integrated graphics card but it is not used.
    The three monitor setup, on this graphics card, was working with opensuse 12.2 before the reinstallation, with fglrx, I am not sure which driver version the old installation used

    And yes everything was/is/always will be 64bit
    What driver version did you install? I found a link for the latest here: http://www2.ati.com/drivers/linux/am...x86.x86_64.zip

    Anyone using an AMD Video card should read through this message thread: https://forums.opensuse.org/english/...pgrade-28.html

    This is the end, but its good to read Back through the message where please_try_again has a bash script used to find and install the driver. Also read where you can't go beyond kernel version 3.5 so do not switch to Tumbleweed and do not use kernel:head or anything that would load kernel 3.6 or higher onto your PC.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,499

    Default Re: ATI Issues with suse 12.2

    Suggest you use the appropriate driver from

    Index of /mirror/amd-fglrx-legacy/openSUSE_12.2

    if you are using kernel 3.7.1-1 or later a patch in needed see

    https://forums.opensuse.org/english/...cy-driver.html

    Cheers

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,499

    Default Re: ATI Issues with suse 12.2

    @scienceman91

    Apologies, ignore my post (#3),

    technical blip, had in mind you were using an HD 4xxx series card.

    Ooops

  5. #5
    Join Date
    Feb 2011
    Location
    Athens, Greece
    Posts
    47

    Default Re: ATI Issues with suse 12.2

    I am using 3.4.11-2.16-desktop in openSuSE 12.2.
    I have a Radeon HD 5850 and this is the latest package I downloaded from AMD web site amd-driver-installer-catalyst-12.10-x86.x86_64.

    The method I am instaling the driver is by
    Code:
    ./amd-driver-installer-catalyst-12.10-x86.x86_64
    Occasionally I get the same error in Xorg.0.log, most often after a clean install, sometimes after an update. Eventually found out that it was some kernel-devel packages missing so while compiling / installing the drivers cannot generate the
    Code:
    fglrx.ko
    module.

    Check what devel packages you are missing, install them and reinstall the drivers. That usually works for me.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •