Results 1 to 5 of 5

Thread: kdenlive no audio

  1. #1
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default kdenlive no audio

    I am trying to create a video using kdenlive (have been reading posts on
    Doug08 thread), and I am having a similar problem. I recorded some video
    with a camcorder, mpg format, and brought it into kdenlive. When trying
    to play the video, I get no audio.

    Here are my packages:

    Code:
    george@tribaltrekker:~> rpm -qa | grep ffmpeg
    gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.5.x86_64
    ffmpeg-1.1-2.2.x86_64
    george@tribaltrekker:~> rpm -qa | grep mlt
    libmlt++3-0.8.6-5.5.x86_64
    libmlt5-0.8.6-5.5.x86_64
    libmlt5-modules-0.8.6-5.5.x86_64
    libmlt5-data-0.8.6-5.5.noarch
    Also, here is the terminal output when I run kdenlive from a konsole and
    hit the play button:

    Code:
    george@tribaltrekker:~]1;tribaltrekkergeorge@tribaltrekker:~> kdenlive
    No LADSPA plugins were found!
    
    Check your LADSPA_PATH environment variable.
    QWidget::insertAction: Attempt to insert null action
    QWidget::insertAction: Attempt to insert null action
    kdenlive(15377) Render::checkMaxThreads: // TRACTOR PROBLEM
    [mp3 @ 0x7fbdf85dd220] max_analyze_duration
    5000000 reached at 5015510
    [mp3 @ 0x7fbdf85dd220] Estimating
    duration from bitrate, this may be inaccurate
    [mp3 @ 0x7fbdf85e34e0]
    max_analyze_duration 5000000 reached at 5015510
    [mp3 @ 0x7fbdf85e34e0] Estimating
    duration from bitrate, this may be inaccurate
    [mpeg2video @ 0x7fbdf002bc00] warning:
    first frame is no keyframe
    [mp3 @ 0x1f62380] max_analyze_duration
    5000000 reached at 5015510
    [mp3 @ 0x1f62380] Estimating duration
    from bitrate, this may be inaccurate
    [mp3 @ 0x1f516e0] max_analyze_duration
    5000000 reached at 5015510
    [mp3 @ 0x1f516e0] Estimating duration
    from bitrate, this may be inaccurate
    [mp3 @ 0x7fbdf0008a00]
    max_analyze_duration 5000000 reached at 5015510
    [mp3 @ 0x7fbdf0008a00] Estimating
    duration from bitrate, this may be inaccurate
    [mp3 @ 0x7fbdf002b600]
    max_analyze_duration 5000000 reached at 5015510
    [mp3 @ 0x7fbdf002b600] Estimating
    duration from bitrate, this may be inaccurate
    [audioresample @ 0x7fbddc000f60] Audio
    sample format conversion failed
    [audioresample @ 0x7fbddc000f60] Audio
    sample format conversion failed
    [audioresample @ 0x7fbddc000f60] Audio
    sample format conversion failed
    [audioresample @ 0x7fbddc000f60] Audio
    sample format conversion failed
    [audioresample @ 0x7fbddc000f60] Audio
    sample format conversion failed
    Any help would be greatly appreciated, as I have been tasked with
    creating this video in the next couple of days and I know little to
    nothing about video processing.

    I did see in the other thread a suggestion to downgrade to ffmpeg 1.0.1,
    but that package is not in my current repositories, as I try and stay up
    to date. Only the latest one is in the list from packman that I saw, and
    I am not familiar with downgrading. I saw that Doug compiled from
    source, and I don't really know how to compile from source.

    Thanks in advance for your help.

    --
    G.O.
    Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
    learning openSUSE and loving it


  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,587
    Blog Entries
    38

    Default Re: kdenlive no audio

    For 'other's watching this thread, the 'Doug08' thread being referred to is here: https://forums.opensuse.org/english/...p4-videos.html

    I have no solutions myself, but I do note that the Packman packager of kdenlive is aware of the problem and is looking for a solution. Presumeably once that solution is found, there will be updates on the Packman site.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,587
    Blog Entries
    38

    Default Re: kdenlive no audio

    Quote Originally Posted by oldcpu View Post
    For 'other's watching this thread, the 'Doug08' thread being referred to is here: https://forums.opensuse.org/english/...p4-videos.html

    I have no solutions myself, but I do note that the Packman packager of kdenlive is aware of the problem and is looking for a solution. Presumeably once that solution is found, there will be updates on the Packman site.
    ffmpeg has been rolled back by Packman packagers and mlt/melt and kdenlive updated to work with that version. Has anyone tried kdenlive now with this update in place ?

  4. #4
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default Re: kdenlive no audio

    On 01/25/2013 02:46 PM, oldcpu wrote:
    > oldcpu;2520145 Wrote:
    >> For 'other's watching this thread, the 'Doug08' thread being referred to
    >> is here: http://tinyurl.com/adsp52w
    >>
    >> I have no solutions myself, but I do note that the Packman packager of
    >> kdenlive is aware of the problem and is looking for a solution.
    >> Presumeably once that solution is found, there will be updates on the
    >> Packman site.

    > ffmpeg has been rolled back by Packman packagers and mlt/melt and
    > kdenlive updated to work with that version. Has anyone tried kdenlive
    > now with this update in place ?
    >
    >

    I ran it just now and was able to bring in a videoclip, hear the sound
    in the preview, render to file (dv format only) several clips together
    and it worked.

    Here is the command line output from bringing in a single video clip and
    rendering it to a dv video:

    Code:
    
    > kdenlive
    No LADSPA plugins were found!
    
    Check your LADSPA_PATH environment variable.
    QWidget::insertAction: Attempt to insert null action
    QWidget::insertAction: Attempt to insert null action
    [mpeg2video @ 0x7fa4a8268a00] warning: first frame is no keyframe
    kdenlive(10785) Render::checkMaxThreads: // TRACTOR PROBLEM
    [mpeg2video @ 0x7fa4a8268200] warning: first frame is no keyframe
    [swscaler @ 0x7fa4a8008a20] Warning: data is not aligned! This can lead
    to a speedloss
    [mpeg2video @ 0x7fa4ac0023c0] warning: first frame is no keyframe
    kdenlive(10785) KSambaSharePrivate::testparmParamValue: We got some
    errors while running testparm "Load smb config files from
    /etc/samba/smb.conf
    Loaded services file OK.
    ERROR: pid directory /var/run/samba does not exist
    "
    //STARTING RENDERING:  true , false , "/usr/bin/melt5" , "dv_ntsc_wide"
    , "libdv" , "-" , "/tmp/kde-george/kdenlived10785.mlt" ,
    "/home/george/Videos/2012/Abby Soccer/soccertestraw.dv" , () ,
    ("threads=1", "real_time=-1") , -1 , -1
    Started render process:  "/usr/bin/melt5"
    "/tmp/kde-george/kdenlived10785.mlt -profile dv_ntsc_wide -consumer
    libdv:/home/george/Videos/2012/Abby Soccer/soccertestraw.dv progress=1
    threads=1 real_time=-1"
    Rendering of  "/home/george/Videos/2012/Abby Soccer/soccertestraw.dv"
    finished
    I don't know what LADSPA plugins are, and I also noticed that every
    codec is unsupported except dv. So I still have to use ffmpeg to convert
    to a smaller size file, and I am working on figuring out how to use
    avidemux.

    --
    G.O.
    Box #1: 12.2 | KDE 4.9.2 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 12.2 | KDE 4.9.1 | AMD Athlon X3 | 64 | 4GB
    Laptop: 12.2 | KDE 4.9.2 | Core i7-2620M | 64 | 8GB
    learning openSUSE and loving it


  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,587
    Blog Entries
    38

    Default Re: kdenlive no audio

    Quote Originally Posted by golson765 View Post
    I still have to use ffmpeg to convert
    to a smaller size file, and I am working on figuring out how to use
    avidemux.
    As noted in this thread I use handbrake a lot to re-encode videos. Here is my quote from the other thread ... (and I recommend you try handbrake) :
    Quote Originally Posted by oldcpu View Post
    ... handbrake is a viable option.

    I re-encode MANY of my videos for display on my Asus Transformer Tablet (which is currently only running ICS (android-4.0.4)) and also for my Zopo ZP-500+ android smart phone. I use custom settings in Handbrake which are noted here: [GUIDE] 720p Handbrake preset for TF101 (HC3.1 Update) - xda-developers I think the example for an MS-Windows version of Handbrake, but the same settings can be applied in the GNU/Linux handbrake version.

    ... I find those 'transformer' settings work well in my Smart phone.

    I find Handbrake reasonably quick in its encoding, and the resultant encoded file size not excessively large.
    If all you intend to do is re-encode, and not retune the video brightness, size or other aspect, then IMHO you are far better using handbrake than avidemux for this task.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •