Results 1 to 3 of 3

Thread: OpenFOAM installation issue

  1. #1

    Default OpenFOAM installation issue

    I have been trying to install OpenFOAM 32bit onto my system, and I get the following error:
    nothing provides libopen-pal.so.0 needed by OpenFOAM-2.1.1-1.i586

    I have already installed
    http://www.openfoam.org/download/sus....12-1.i586.rpm
    http://www.openfoam.org/download/sus...2.0-1.i586.rpm
    http://www.openfoam.org/download/sus...1.1-1.i586.rpm
    and I am running suse12.2

    Is there another package I also need to install, or did I manage to mess up the installation?

  2. #2

    Default Re: OpenFOAM installation issue

    I use OpenFOAM-2.1.1 on opensuse 11.4 32 bit system. I did a quick "find" on my system and found:

    /usr/lib/mpi/gcc/openmpi/lib/libopen-pal.so.0

    It looks to be a gcc file and not part of openfoam. Give a check at this directory to see if you have it. Perhaps it is available from them.

    Hope this gives some help.

    Tom Kosvic

  3. #3

    Default Re: OpenFOAM installation issue

    Hello again, I did a little more looking. Note I'm working with opensuse 11.4 and openfoam.

    The lib you have missing is available in Yast software and is contained in the "openmpi" package. This is available for 11.4 and I have it installed. I assume it would be available on 12.2 opensuse.
    The file list for this package constrains your lost file.

    Tom Kosvic

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •