Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Emacs editor window ugly font

Hybrid View

  1. #1
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Emacs editor window ugly font

    Hi,

    I'm using KDE 4.9 with openSUSE 12.2. In one of my machines, Emacs's editor window's font is ugly. Specifically, they are very "fat".
    Stangely the font on the menu of the emacs window are correctly rendered.

    I have included a screenshot: https://dl.dropbox.com/u/561594/snapshot1.jpeg
    As you can see, even though the letters on the menu are crisp, while the font on the editor window is blurry.

    Thanks,
    Joon

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Emacs editor window ugly font

    Quote Originally Posted by joonro View Post
    Hi,

    I'm using KDE 4.9 with openSUSE 12.2. In one of my machines, Emacs's editor window's font is ugly. Specifically, they are very "fat".
    Stangely the font on the menu of the emacs window are correctly rendered.

    I have included a screenshot: https://dl.dropbox.com/u/561594/snapshot1.jpeg
    As you can see, even though the letters on the menu are crisp, while the font on the editor window is blurry.

    Thanks,
    Joon
    You can enter a...

    Code:
    Alt-F2: kdesu qtconfig
    Run QT Config and change the font or what ever from there. In KDE you can also go to ...

    menu / Configure Desktop / Application Appearance / GTK Styles and Fonts and make some adjustment there as well.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Emacs editor window ugly font

    Quote Originally Posted by jdmcdaniel3 View Post
    You can enter a...

    Code:
    Alt-F2: kdesu qtconfig
    Run QT Config and change the font or what ever from there. In KDE you can also go to ...

    menu / Configure Desktop / Application Appearance / GTK Styles and Fonts and make some adjustment there as well.

    Thank You,

    Thanks for the reply. I tried all those before I asked the question, but it did not help. I have three machines with openSUSE, and two laptops with intel graphics have this problem while a desktop with nvidia doesn't, so I wonder if it has something to do with graphics.

    -Joon

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Emacs editor window ugly font

    Quote Originally Posted by joonro View Post
    Thanks for the reply. I tried all those before I asked the question, but it did not help. I have three machines with openSUSE, and two laptops with intel graphics have this problem while a desktop with nvidia doesn't, so I wonder if it has something to do with graphics.

    -Joon
    Besides just personnel tastes, the graphics chipset and even the monitor plays a role in the appearance of any of the application screens. I have had no problem changing the default font and finding one I like better. Except for my work laptop which uses Intel, I use nVIDIA based video and I feel it really works best for me.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Emacs editor window ugly font

    Quote Originally Posted by jdmcdaniel3 View Post
    Besides just personnel tastes, the graphics chipset and even the monitor plays a role in the appearance of any of the application screens. I have had no problem changing the default font and finding one I like better. Except for my work laptop which uses Intel, I use nVIDIA based video and I feel it really works best for me.

    Thank You,
    Thanks for the reply. Maybe I did not explain it well enough in my original post. The problem is that even if I use the same Dejavu sans font (whith is the font used for the emacs menus) for the Default font, the letters in the editor window are being rendered differently - they are fat, when the letters on the menu look normal.

    I just tried dejavu sans extralight - which is supposed to be very thin - but still in emacs window the letters look fat. Very strange.

    -Joon

  6. #6
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Emacs editor window ugly font

    Setting the subpixel rendering option to RGB and Hinting style to Full in the KDE system settings fixed the problem.
    It was strange - without the option set, majority of fonts were rendered as if subpixel hinting was set, some were not.

    Thanks for you help!

    -Joon

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Emacs editor window ugly font

    Quote Originally Posted by joonro View Post
    Setting the subpixel rendering option to RGB and Hinting style to Full in the KDE system settings fixed the problem.
    It was strange - without the option set, majority of fonts were rendered as if subpixel hinting was set, some were not.

    Thanks for you help!

    -Joon
    I also have setup this in KDE as well. Happy you found it as I did not think to mention it. It is my understanding that not all fonts respond to this setting properly, but I am not sure which ones have a problem. But in any event, I am happy you found the fix you required.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  8. #8
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Emacs editor window ugly font

    Quote Originally Posted by jdmcdaniel3 View Post
    I also have setup this in KDE as well. Happy you found it as I did not think to mention it. It is my understanding that not all fonts respond to this setting properly, but I am not sure which ones have a problem. But in any event, I am happy you found the fix you required.
    Thank you. Again the weird thing was that the same dejavu fonts were bering rendered differently depending on places - I guess for some places the subpixel hinting settings were applied automatically.

    -Joon

  9. #9
    dd NNTP User

    Default Re: Emacs editor window ugly font

    On 01/15/2013 02:46 AM, joonro wrote:
    > Emacs's
    > editor window's font is ugly.


    so change it to a font you like!
    click on Options and uncheck "Use system font" then click on "Set
    default font" and pick whatever is not 'ugly' to you.

    --
    dd http://tinyurl.com/DD-Caveat

  10. #10
    Join Date
    Aug 2012
    Location
    Austin, TX
    Posts
    77

    Default Re: Emacs editor window ugly font

    Quote Originally Posted by dd View Post
    On 01/15/2013 02:46 AM, joonro wrote:
    > Emacs's
    > editor window's font is ugly.


    so change it to a font you like!
    click on Options and uncheck "Use system font" then click on "Set
    default font" and pick whatever is not 'ugly' to you.
    Please read my post before replying - or maybe I did not explain it well enough. I am using the SAME font for both the menu and the editor window. And they are being rendered DIFFERENTLY.

    -Joon

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •