Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: LibreOffice Writer OLE problem

  1. #1

    Default LibreOffice Writer OLE problem

    I opened a document this morning that I was working on during the past couple of months, and all the graphs and equations within the document have been replaced with OLE placeholders. Is there a way to re-instate them? Are they stored separately from the main document and if so, could anyone tell me where? Hope someone can help me with this.

    Thanks

    Minsky

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,856
    Blog Entries
    14

    Default Re: LibreOffice Writer OLE problem

    Are the docs they refer to still available?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: LibreOffice Writer OLE problem

    I can open the document and all the text and tables are ok, but the equations and graphs which I entered using the built-in formula editor and graphs editor are missing.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,393
    Blog Entries
    1

    Default Re: LibreOffice Writer OLE problem

    Quote Originally Posted by Minsky View Post
    I can open the document and all the text and tables are ok, but the equations and graphs which I entered using the built-in formula editor and graphs editor are missing.
    Maybe you are missing some extensions?

    LibreOffice Extensions

    Check with

    Tools >> Extension Manager...

  5. #5
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: LibreOffice Writer OLE problem

    one of the Libreoffice calc version does have graph related issues
    i may affect writer too
    I would rollback to previous Libreoffice and check whether the doc works
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  6. #6
    dd NNTP User

    Default Re: LibreOffice Writer OLE problem

    On 01/14/2013 09:26 PM, Minsky wrote:
    > all the graphs and equations within the document
    > have been replaced


    somewhere (i do not remember where) i recently read of a bug in the most
    recent releases of LO...are you using the LO which came with your
    openSUSE (what version openSUSE is it you use--and what version of LO)

    or did you recently upgrade it??

    if you did, i think i would begin by rolling back to the previous
    (working) version of LO..

    --
    dd http://tinyurl.com/DD-Caveat

  7. #7

    Default Re: LibreOffice Writer OLE problem

    On Tue, 15 Jan 2013 04:52:44 GMT
    "dd" <dd@home.dk> wrote:

    > On 01/14/2013 09:26 PM, Minsky wrote:
    > > all the graphs and equations within the document
    > > have been replaced

    >
    > somewhere (i do not remember where) i recently read of a bug in the
    > most recent releases of LO...are you using the LO which came with
    > your openSUSE (what version openSUSE is it you use--and what version
    > of LO)
    >
    > or did you recently upgrade it??
    >
    > if you did, i think i would begin by rolling back to the previous
    > (working) version of LO..
    >


    Yes, best roll back to 3.5 as 3.6 is broken - at least the openSUSE
    version is.
    Calc bug: https://bugzilla.novell.com/show_bug.cgi?id=794698
    Write bug: https://bugzilla.novell.com/show_bug.cgi?id=791201


    --
    Graham P Davis, Bracknell, Berks.
    openSUSE 12.2 (64-bit); KDE 4.9.97; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210 (using nouveau driver);
    Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

  8. #8

    Default Re: LibreOffice Writer OLE problem

    Thanks for the replies guys, I'm using openSUSE 12.2 with KDE desktop and LO 3.5 build-413. I've been working on the document for the past month and have frequently opened it and updated it with a mixture of text, graphs and equations without any problems until yesterday morning. Prior to starting work on the document, I did upgrade to LO 3.6, but after having problems with saving the first graph, I rolled back to 3.5. Do you know if the OLE objects are embedded within the document or if they are stored in a separate file? Is there any way that the document can be repaired?

  9. #9
    dd NNTP User

    Default Re: LibreOffice Writer OLE problem

    On 01/15/2013 10:06 PM, Minsky wrote:
    > Is there any way that the document can be repaired?


    if, when you saw the graph was missing if you didn't save in 3.6 it
    should be there in the earlier working version..

    otherwise you may have to use your backup..

    --
    dd

  10. #10

    Default Re: LibreOffice Writer OLE problem

    Thank God for backups. It's still a pain repairing the document from the last backup. Does anyone know what causes this, and if the OLE objects are recoverable?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •