Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: energy saving mode still working when playing movie on VLC player

  1. #1

    Default energy saving mode still working when playing movie on VLC player

    Hi guys,

    When I play movie on VLC player, the energy saving mode still working. It's really annoying me when I'm watching movie, cus' the energy saving mode dim display every x minutes.
    I checked both option "Inhibit power management..." and "Disable screen saver" but still not working.

    But when I play movie on Kaffein, everything is ok, the energy mode saving mode is dead.

    So how can I fix this?

    Thanks for your helps!

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: energy saving mode still working when playing movie on VLC player

    Which openSUSE, which desktop?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: energy saving mode still working when playing movie on VLC player

    omg, sorry, i forgot.

    I'm using OpenSUSE 12.2, KDE 4.9

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: energy saving mode still working when playing movie on VLC player

    Workaround
    before running vlc. You can reset the usual screen blanking behavior with
    xset s on
    refer:- https://bbs.archlinux.org/viewtopic....853687#p853687

    There should be a plasmoid gadget or widget to this i guess.I have an inhibit button(extension) on panel in GNOME 3.4.2
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: energy saving mode still working when playing movie on VLC player

    Turn off the screensaver and check these settings
    https://dl.dropbox.com/u/10573557/12...ngs-kde4.9.png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    dd NNTP User

    Default Re: energy saving mode still working when playing movie on VLC player

    On 01/15/2013 02:26 AM, n00bvn wrote:
    > OpenSUSE 12.2, KDE 4.9


    go into Personal Settings - Configure Desktop » Hardware » Power
    Management » Global Settings and look to see which Profile Assignment is
    active when you play a movie (AC power plugged in or not) and then go to
    Power Profiles and select that profile (Performance or Power Save) and
    adjust the "Dim Display" and "Screen Energy Savings" and "Suspend
    Session" settings to a value you like (mine are set for over 100 minutes
    each)

    all of that is to say: apparently your VLC's controls do not
    work...maybe you should check if there is a bug logged on it..

    --
    dd http://tinyurl.com/DD-Caveat

  7. #7

    Default Re: energy saving mode still working when playing movie on VLC player

    Quote Originally Posted by caf4926 View Post
    Turn off the screensaver and check these settings
    https://dl.dropbox.com/u/10573557/12...ngs-kde4.9.png
    I do not want it dim display for many times like that. Cus' I still want the computer run power saving.

    Maybe I should play movie in Kaffein or SMPlayer, instead of VLC. I think it might be a bug of VLC player.

    Thanks you guys anyway!
    Sometimes I forget to tell information about version, desktop.
    I'm using OpenSUSE 13.1, KDE 4.11

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: energy saving mode still working when playing movie on VLC player

    I always use smplayer
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    74

    Default Re: energy saving mode still working when playing movie on VLC player

    No need to switch off screensaver and/or power management energy saver, just head to ~/.config/vlc/vlcrc and remove the # in the file for VLC to disable screensaver while playing video:

    Code:
    # Inhibit the power management daemon during playback (boolean) inhibit=0 ... 
    # Disable screensaver (boolean) 
    disable-screensaver=0
    Very strange that it is not enabled by default; who need the screensaver while watching videos!
    Plus I think the global policy of KDE 4.10 is still not followed by some apps, which also needs to be resolved.
    Linux & Open Source World
    E@zyVG's Vichar::World Connected

    Free and open-source software is good for you and for the world.

  10. #10
    Join Date
    Jun 2008
    Location
    Moscow, Russia
    Posts
    74

    Default Re: energy saving mode still working when playing movie on VLC player

    If the above doesn't work see the following link, very easy:

    https://forums.opensuse.org/english/...se-12-2-a.html
    Linux & Open Source World
    E@zyVG's Vichar::World Connected

    Free and open-source software is good for you and for the world.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •