Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Current window screenshots not working in GNOME

  1. #1

    Default Current window screenshots not working in GNOME

    When using GNOME's default Screenshot application, entire desktop and specific area options work well but current window option results in a totally messed up picture, no matter if pointer and window border are enabled or disabled and using no effect.

    Any ideas?

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Current window screenshots not working in GNOME

    did you try alt+PrintScreen
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3

    Default Re: Current window screenshots not working in GNOME

    The point is, I'm talking about the application itself, gnome-screenshot. Any ideas?

  4. #4
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Current window screenshots not working in GNOME

    "Alt+PrintScreen" does use gnome-screenshot. :-)
    I see no problem with images created using gnome-screenshot
    You can also try shutter(lot more options available) software.opensuse.org:
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  5. #5

    Default Re: Current window screenshots not working in GNOME

    Tried either with the app itself and with Alt + PrntScrn. Same result:
    SUSE Paste

    Again, either entire desktop and specific area shots work well though. Any ideas?

  6. #6
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Current window screenshots not working in GNOME

    Is this happening with particular application screenshot or all application ?
    i.e. You can try taking screen shot of Nautilus window and check whether this problem occurring ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  7. #7

    Default Re: Current window screenshots not working in GNOME

    Happens with all applications. I also noticed that using gnome-screenshot itself normally results in window shots like the one showed (messed up). But by using Alt + PrntScrn results in window shots all blackened.

  8. #8
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Current window screenshots not working in GNOME

    I suspect that this seems to be a display issue i.e. the graphics drivers are not performing as per requirements :-)
    Fix:-
    Get the graphics drivers correctly installed based on your Os. It may involve installing proprietary or switching to free drivers and also may require kernel changes.
    I am not having enough knowledge to correct driver issues. Someone here should be able help you .
    Workaround 1:-
    Try adding a delay of 2secs or so and check if it does the trick
    Workaround 2:-
    You can also try shutter(lot more options available) software.opensuse.org:
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  9. #9

    Default Re: Current window screenshots not working in GNOME

    I'm sure (or almost sure) I have the drivers correctly installed. Mine is an Nvidia GeForce 8600m GT. I installed the drivers by adding the Nvidia repo and installing the corresponding packages, that's the way I always do. Current installed version is 304.64-22.1, there has been no updates until now...

    To tell the truth, I wouldn't want to mess around with graphic drivers again... My Wine game (Limbo) still works well, display works well... How could I know if my graphic drivers are actually wrong? Could it be just the buggy screenshots? I repeat, only window screenshots are messed, desktop and area shots work well.

    Other points of view would be grateful...

  10. #10
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Current window screenshots not working in GNOME

    Did you read the workarounds part ?
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •