Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Setting up NX Server in OpenSuse(XFCE) 12.2

  1. #1
    Join Date
    Oct 2012
    Location
    India
    Posts
    332

    Default Setting up NX Server in OpenSuse(XFCE) 12.2

    Hi guys,

    I am using OpenSuse 12.2 with XFCE desktop environment.

    I have installed the freenx from repositories and tried to start the nxserver with the command nxserver --start.After executing the command it says it has started but immediately when I check with --status command it shows nxserver is stopped.

    Can anyone give me the link or post the procedure on HOW TO INSTALL AND CONFIGURE NXSERVER.

    I have followed numerous but none of them are working to me.

    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    On 01/12/2013 05:26 PM, nishanth9042 wrote:
    >
    > Hi guys,
    >
    > I am using OpenSuse 12.2 with XFCE desktop environment.
    >
    > I have installed the freenx from repositories and tried to start the
    > nxserver with the command nxserver --start.After executing the command
    > it says it has started but immediately when I check with --status
    > command it shows nxserver is stopped.
    >
    > Can anyone give me the link or post the procedure on HOW TO INSTALL AND
    > CONFIGURE NXSERVER.
    >
    > I have followed numerous but none of them are working to me.
    >
    > Thanks in advance.
    >
    >


    To my knowledge there is no working freenx server for 12.2.. not yet anyhow.
    My solution was to go back to 12.1.


  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    Quote Originally Posted by nishanth9042 View Post
    Hi guys,

    I am using OpenSuse 12.2 with XFCE desktop environment.

    I have installed the freenx from repositories and tried to start the nxserver with the command nxserver --start.After executing the command it says it has started but immediately when I check with --status command it shows nxserver is stopped.

    Can anyone give me the link or post the procedure on HOW TO INSTALL AND CONFIGURE NXSERVER.

    I have followed numerous but none of them are working to me.

    Thanks in advance.
    You need to read and follow one of these Article guides I would suggest.

    Setting up NX server (part I: FreeNX): https://forums.opensuse.org/content/...-i-freenx.html

    Setting up NX server (part II: NoMachine NX): https://forums.opensuse.org/content/...achine-nx.html

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    Quote Originally Posted by cjcox View Post

    To my knowledge there is no working freenx server for 12.2.. not yet anyhow.
    My solution was to go back to 12.1.
    I remember that Gnome and probably XFCE didn't work until I added -norender to the AGENT_EXTRA_OPTIONS_X. It indeed affected 12.2 and not 12.1 and Gnome or Xfce but not KDE. But the bug has been fixed in the latest NX agent, which is available in my repo

    Code:
    # zypper info NX
    
    Information for package NX:
    
    Repository: PTA
    Name: NX
    Version: 3.5.0-121.1
    Arch: x86_64
    Vendor: obs://build.opensuse.org/home:please_try_again
    Installed: Yes
    Status: up-to-date
    Installed Size: 9.0 MiB
    Summary: Proxy System for X11
    Description: 
    NX provides a proxy system for the X Window System.
    You need this version of the NX agent. Then it works with or without -norender, in Gnome and Xfce sessions.

    Notice that if you install FreeNX from my repo with freenx-setup, you should be able to open a XFCE session directly by choosing "CDE" as desktop in NoMachine client, thanks to this change in /usr/bin/nxloadconfig

    Code:
    # grep "^COMMAND_START_CDE=" /usr/bin/nxloadconfig
    COMMAND_START_CDE=startlxde
    It's a "goodie"

  5. #5
    Join Date
    Oct 2012
    Location
    India
    Posts
    332

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    What is your repository URL and what I need to install from your repository.

  6. #6

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    Quote Originally Posted by nishanth9042 View Post
    What is your repository URL and what I need to install from your repository.
    Just follow the links James posted earlier. Replace 12.1 with 12.2 in the URL given in this article (I wrote these 2 articles).

  7. #7

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    If you search the forum, you will also find threads where this issue has been discussed. I also thought it was broken until somebody gave me the solution. Later, I received a bug report mentionning that the bug had been fixed in the latest NX agent released by NoMachine. Thus I updated the package and it solved the problem (at least that particular one).

  8. #8
    Join Date
    Oct 2012
    Location
    India
    Posts
    332

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    These are the steps I have followed to install Free NX from please_try_again repository.

    1.I have added Please_try_again repository through zypper
    2.I have installed Free NX package from this repository
    3.Executed this command

    #freenx-setup

    which took the default settings.

    4.Finally I tried to start nxserver with this command

    #nxserver --start
    and while checking the status of the nxserver it shows nxserver is stopped.

  9. #9

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    Quote Originally Posted by nishanth9042 View Post

    4.Finally I tried to start nxserver with this command

    #nxserver --start
    and while checking the status of the nxserver it shows nxserver is stopped.

    I guess you're almost done.

    Try these commands:

    Code:
    # systemctl status freenx-server.service
    freenx-server.service - FreeNX Server
              Loaded: loaded (/lib/systemd/system/freenx-server.service; enabled)
              Active: inactive (dead) since Sun, 13 Jan 2013 06:48:39 -0800; 4s ago
             Process: 29724 ExecStopPost=/usr/bin/nxserver --cleanup (code=exited, status=1/FAILURE)
             Process: 29672 ExecStop=/usr/bin/nxserver --stop (code=exited, status=0/SUCCESS)
             Process: 1415 ExecStart=/usr/bin/nxserver --start (code=exited, status=0/SUCCESS)
             Process: 965 ExecStartPre=/usr/bin/nxserver --cleanup (code=exited, status=1/FAILURE)
             Process: 941 ExecStartPre=/usr/bin/freenx-server-check-setup.sh (code=exited, status=0/SUCCESS)
              CGroup: name=systemd:/system/freenx-server.service
    
    # systemctl start freenx-server.service
    
    # systemctl status freenx-server.service
    freenx-server.service - FreeNX Server
              Loaded: loaded (/lib/systemd/system/freenx-server.service; enabled)
              Active: active (exited) since Sun, 13 Jan 2013 06:49:07 -0800; 5s ago
             Process: 29724 ExecStopPost=/usr/bin/nxserver --cleanup (code=exited, status=1/FAILURE)
             Process: 29672 ExecStop=/usr/bin/nxserver --stop (code=exited, status=0/SUCCESS)
             Process: 29927 ExecStart=/usr/bin/nxserver --start (code=exited, status=0/SUCCESS)
             Process: 29873 ExecStartPre=/usr/bin/nxserver --cleanup (code=exited, status=1/FAILURE)
             Process: 29870 ExecStartPre=/usr/bin/freenx-server-check-setup.sh (code=exited, status=0/SUCCESS)
              CGroup: name=systemd:/system/freenx-server.service
    Code:
    # /usr/bin/nxsetup --test
    
    ----> Testing your nxserver configuration ...
    Warning: Invalid value "NX_LOGFILE=/var/log/nxserver.log"
             No logfile will be kept.
    
      Warnings occured during config check.
      To enable these features please correct the configuration file.
    
    <---- done
    
    ----> Testing your nxserver connection ...
    HELLO NXSERVER - Version 3.2.0-73 OS (GPL, using backend: 3.5.0)
    <--- done

    Code:
    # find /var/lib/nxserver/home/.ssh -ls
    426486    4 drwx------   2 nx       root         4096 Jan 13 06:49 /var/lib/nxserver/home/.ssh
    426498    4 -rw-r--r--   1 nx       root          979 Nov 22 15:06 /var/lib/nxserver/home/.ssh/known_hosts
    393850    4 -rw-------   2 nx       root          675 Oct 24 17:16 /var/lib/nxserver/home/.ssh/authorized_keys
    393850    4 -rw-------   2 nx       root          675 Oct 24 17:16 /var/lib/nxserver/home/.ssh/authorized_keys2
    407757    4 -rw-------   1 nx       root          601 Oct 24 17:16 /var/lib/nxserver/home/.ssh/server.id_dsa.pub.key
    426488    4 -rw-------   1 nx       root          668 Oct 24 17:16 /var/lib/nxserver/home/.ssh/client.id_dsa.key

  10. #10
    Join Date
    Oct 2012
    Location
    India
    Posts
    332

    Default Re: Setting up NX Server in OpenSuse(XFCE) 12.2

    the output of /usr/bin/nxsetup ---test is

    ----> Testing your nxserver configuration ...
    Error: Invalid value "NX_HOME_DIR=/var/lib/nxserver/home"
    Warning: "/usr/lib/cups/backend/nxipp" is not executable.
    Users will not be able to enable printing.
    Warning: "/usr/lib/cups/backend/smb" is not executable.
    Users will not be able to enable printing.
    Warning: Invalid value "COMMAND_START_KDE=startkde"
    Users will not be able to request a KDE session.
    Warning: Invalid value "COMMAND_START_GNOME=gnome-session"
    Users will not be able to request a Gnome session.
    Warning: Invalid value "COMMAND_SMBMOUNT=/sbin/mount.cifs". You'll not be able to use SAMBA.

    Errors occured during config check.
    Please correct the configuration file.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •